none
Error Code 31144 When Modifying Protection Group RRS feed

  • Question

  • We currently have a DPM 2012 R2 server that we are in the process of implementing.  We've had the server running now for several weeks with all of our protection groups configured, including System State groups.  As of yesterday afternoon I am now getting an error of 31144 "Cannot find <server> in Active Directory" when adding or removing a machine from any of the System State groups.  The odd thing is that I've noticed that the machine name in the error message is 9 times out of 10 not the machine I was either adding or removing.  I only get the error with the System State groups, none of the file data groups.  I've already removed all the System State groups, tried a dsquery when getting the error with a successful lookup, and updated to UR2.  I cannot add the System State protection groups back in even with different labels because I still get the same 31144 error.
    Friday, July 25, 2014 12:14 PM

All replies

  • I have seen this happen when there are other servers in the protection group that are either no longer valid servers (they have been removed from the domain), or maybe just aren't available at that time. Most likely it will be option one as DPM will check AD for all of the servers of a PG before it will modify it in any way.

    I would go through the entire PG and verify that the servers still exist.  If they don't, then you will need to modify the PG to remove them all at the same time.  If you try to do one at a time, it will fail again as it is checking the other servers in the group at that same time.


    Thanks, Chris - [MSFT] This posting is provided "AS IS" with no warranties, and confers no rights

    Thursday, September 25, 2014 3:20 PM