locked
Appv 5. The program can't start because Vcl50.bpl is missing from your computer RRS feed

  • Question

  • Hello

    I am trying to sequence an application in V5.1 that currently works fine in v4.6.  I have tried to do the conversion and also do a brand new sequence but on both occasions, when the sequenced app is run it errors with "The program can't start because Vcl50.bpl is missing from your computer. Try reinstalling the program to fix the problem".

    This file is installed to 'C:\Windows\System32' when I install the client along with a load of other .bpl files. I believe these are related to the BDE Administrator that it installs

    Any help will be welcome

    Friday, December 8, 2017 3:52 PM

All replies

  • Are you able to see the file by opening virtual bubble and looking inside.

    (Please click on Vote as Helpful and/or Mark as Answer, if it has helped you.)

    MVP - Windows and Devices for IT

    app2pack.blogspot.com: app2pack.blogspot.com

    Monday, December 11, 2017 9:13 AM
  • Hi

    If I open the bubble for amendment the application works fine and I can see all the .bpl files in the 'C:\Windows\System32' folder.

    Monday, December 11, 2017 10:00 AM
  • Here are the three most likely causes:

    1) Your package includes a change to the PATH variable.  On certain packages this is solved by removing the change to PATH, and adding an AppPath for the executables that includes the changes made to PATH.  This only affects some packages with Path changes and we don't know why. 

    2) You are using the 5.1 RTM Sequencer.  Try it with the MDOP 2017 fall update.

    3) A very unlikely possibility: You are sequencing on 32-bit OS and testing on x64 OS and the primary exe is of type "AnyCPU". 

    Tim


    Tim Mangan MVP for App-V and Citrix CTP Author of AppV books: "PowerShell with App-V 5 (5.1 Edition)", "The Client Book (4.x)" and "OSD Reference Book" (http://www.tmurgent.com/Books )

    Wednesday, December 13, 2017 5:15 PM
    Moderator