none
Private Microsoft Store - Something bad happened Unknown layout specified in manifest. RRS feed

  • Question

  • This is not happening to all users. We are using the private Microsoft Store, and allowed apps. We have groups specified for access to each application, and users added to those groups. 

    When some people on 1803 launch the store application, they are getting the error specified. If I do the normal fixes, it shows the store as if it were a consumer system. As soon as do a group policy update, it reverts to the error. So, it's clearly an issue with GPO, but there aren't many GPO's that modify the way the store operates, and it isn't happening to everyone on 1803. 

    Monday, April 15, 2019 10:51 PM

Answers

  • I did end up getting this resolved. Once we updated our version of Windows, the base version of the store was the one that allowed for the private store, which in a sense fixed it for all our clients as they were forced to update to the current -6mo channel.
    • Marked as answer by BobojoBaxter Saturday, February 15, 2020 1:17 AM
    Saturday, February 15, 2020 1:17 AM

All replies

  • Hi,

     

     If you are facing this error message, now please have a try with the methods below and see whether the issue remains:

     

    1. Reset the Windows Store

    Open Settings, click on system and then on Apps & features in the left panel. Next, identify the Windows Store app and click on it. Then Click on Advanced options.

    Here, you will have to click on the Reset button, to reset the app. Clicking on it will open the warning window, telling you that the app’s data will be deleted and preferences reset.

     

    1. Check Region & Language Settings

    Open Settings, click Time & Language, select Region & Language from options on left, Verify your Country/Region is correct from drop down list.

     

    Ensure the appropriate Language Pack is installed. If it’s in the state of being “available”, click Download and let the system install it from Microsoft servers.

     

    1. Reset Windows and run the Account troubleshooter

    Some users have found reset Windows and run the Account troubleshooter could repair any Windows issue preventing the sync with the Microsoft account.

     

    1. Updated the ADMX-package

    Activated "Only display the private store within the Windows Store app" and inactivated the "Turn off the Store application" GPO.

     

    Hope these can help you.


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Tuesday, April 16, 2019 7:15 AM
  • I've done all the normal troubleshooting that you mentioned. It resets the store. The offer Irv's the store and it looks like the consumer version not the private store. Once I update gpo it refers to something bad happened.
    Tuesday, April 16, 2019 7:43 AM
  • Hi,

     

    Here is a similar thread for reference:

    https://social.technet.microsoft.com/Forums/en-US/67278c5d-9a4e-4dc5-a0eb-2641fd167fd9/only-display-the-private-store-strange-behaviour?forum=win10itprogeneral

     

    Since it isn't happening to everyone, make sure they have  Azure AD account, as requirements below:

    And update the store to see if it will be fixed.

    Best Regards.


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Wednesday, April 17, 2019 7:26 AM
  • Hi,

     

    Was your issue solved?

     

    If yes, would you like to share your solution in order that other community members could find the helpful reply quickly.

     

    If no, please reply and tell us the current situation in order to provide further help.


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Friday, April 19, 2019 6:26 AM
  • We sync over azure ad accounts, but we don't use AAD accounts for anything in our environment. I have never logged into AAD on my account, and I can access the store just fine. 
    Friday, April 19, 2019 7:26 PM
  • No, this is still an issue. Might have to open a ticket with Microsoft. There are only like 3 or 4 GPO settings to modify for this to work, and it should work for everyone. 
    Friday, April 19, 2019 7:27 PM
  • No, this is still an issue. Might have to open a ticket with Microsoft. There are only like 3 or 4 GPO settings to modify for this to work, and it should work for everyone. 
    It appears if I have the updated version of the Store app - it seems to work. The problem now is, I can't update the store app outside of the store... if I could update the store app without launching the store I think I am in business.
    Friday, April 19, 2019 9:09 PM
  • Hi,

     

    Please try the steps below:

     

    >Open Settings.

    >Click on Update & security.

    >Click on For developers.

    >Under "Use developer features" select the Sideload apps option.

    >Click Yes to confirm the risks involved running an app outside the Windows Store.

    >Restart your computer if applicable to complete the task.

     

    I hope this can help.


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.


    Monday, April 22, 2019 8:37 AM
  • Hi,

     

    Any update? Please let us know if you need more help.


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Friday, April 26, 2019 8:07 AM
  • Hi,

     

    In order to resolve the issue more efficiently, I would like to confirm that have you upgrading or installing language packs in your case?

     

    Looking forward to hearing from you.

     

    Best regards,

    Farena


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Tuesday, April 30, 2019 2:25 AM
  • No language packs involved. Only GPO. If I reset the store with wsreset then open the store and update it, then apply GPO The store opens.
    Tuesday, April 30, 2019 4:03 AM
  • Hi,

    Based on the complexity and the specific situation, we need do more researches. If we have any updates or any thoughts about this issue, we will keep you posted as soon as possible. 


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Tuesday, April 30, 2019 8:41 AM
  • Hi

    Did this ever get resolved?  I have the same issue.  if I update the store app it goes away but you need to open the store and trigger the update, which isn't much use.

    Thursday, June 6, 2019 3:31 PM
  • Hi

    Did this ever get resolved?  I have the same issue.  if I update the store app it goes away but you need to open the store and trigger the update, which isn't much use.

    No. I basically have to remove group policy, launch the store, update it, then I can re-apply group policy and all is well. Private store.
    Thursday, June 6, 2019 3:33 PM
  • Hi

    Did this ever get resolved?  I have the same issue.  if I update the store app it goes away but you need to open the store and trigger the update, which isn't much use.

    No. I basically have to remove group policy, launch the store, update it, then I can re-apply group policy and all is well. Private store.
    OK, thanks.
    Thursday, June 6, 2019 3:34 PM
  • I am also looking for a answer to this. Every answer I Google online comes up with the following answers. 

    • Change the Language and Region
    • Reset the Cache in the store (wsreset.exe)
    • Reset the app to defaults - Get-AppXPackage *WindowsStore* -AllUsers | Foreach {Add-AppxPackage -DisableDevelopmentMode -Register "$($_.InstallLocation)\AppXManifest.xml}

    All of these did not fix the issue. The error message only happens when the Group Policy to only show the private store is enabled. If I lift the policy then it works just fine. I would love to see this get traction becuase this is affecting close to 50,000 machines in my environment.

    Does anyone else have some ideas?

    Thanks. 

    Tuesday, October 29, 2019 10:21 PM
  • I did end up getting this resolved. Once we updated our version of Windows, the base version of the store was the one that allowed for the private store, which in a sense fixed it for all our clients as they were forced to update to the current -6mo channel.
    • Marked as answer by BobojoBaxter Saturday, February 15, 2020 1:17 AM
    Saturday, February 15, 2020 1:17 AM