locked
SharePoint 2007 page does not render correctly RRS feed

  • Question

  • Hello All,

    I am site collection admin at our organization. We had created a custom list in MOSS 2007 and it works fine for all users within our organization except one of our user.

    user has Windows 7 Professional 32 Bit OS.

    IE 9 installed on it.

    Page loads like this.

    SharePoint 2007 Page rendering error

    Already tried downgrading IE 9 to IE8, tried in google chrome still page renders incorrectly. this link works fine for all users in our organization.

    Browser is already reset several times. page renders the same when user tries from another known good computer. I am sure this is not a browser problem.

    User already has contribute no delete permission on this site.

    Please help.

    Regards,

    Girish

    Sunday, February 12, 2012 5:38 PM

Answers

  • Hi Ray,

    I was able to solve this for my users, this is not a local system issue. Its actually caused by Group permissions where user is added to. Please revisit the group permission, When I did, I noticed that few permissions like open list item, view list item were missing from group permissions. correcting that helped.

    Regards,

    Girish Shenoy

    • Marked as answer by kgirishshenoy Wednesday, June 26, 2013 6:07 PM
    Friday, November 16, 2012 10:22 PM

All replies

  • Hi,

    Ask the user to access it from some other machine to check if it works.


    Thanks, Rahul Rashu

    Sunday, February 12, 2012 6:01 PM
  •  

    If you have the same problem from another machine, check in the ULS(SharePoint) logs for PermissionMask check failed when you reproduce the issue and paste the results in here.

    With this information form SP logs we can identify what permissions are missing in order to access correctly that page.


    MCITP|MCTS SharePoint| SharePoint Performance blog

    Sunday, February 12, 2012 6:49 PM
  • 2/13/2012 09:33:22.27  w3wp.exe (0x1114)                        0x18D0                                1463                           8l41 High     assertPermissionMask was called, but permissions haven't been computed yet. 
    02/13/2012 09:33:22.46  w3wp.exe (0x1114)                        0x121C CMS                            Publishing                     7fz3 Medium   Setting [Display] as the FormContext.FormMode for the current page 
    02/13/2012 09:33:22.46  w3wp.exe (0x1114)                        0x121C CMS                            Publishing                     7fz3 Medium   Setting [Display] as the FormContext.FormMode for the current page 
    02/13/2012 09:33:22.50  w3wp.exe (0x1114)                        0x121C CMS                            Publishing                     7fz3 Medium   Setting [Display] as the FormContext.FormMode for the current page 
    02/13/2012 09:33:22.50  w3wp.exe (0x1114)                        0x121C CMS                            Publishing                     7fz3 Medium   Setting [Display] as the FormContext.FormMode for the current page 
    02/13/2012 09:33:22.52  w3wp.exe (0x1114)                        0x121C Windows SharePoint Services    General                        72nz Medium   Videntityinfo::isFreshToken reported failure. 
    02/13/2012 09:33:22.71  w3wp.exe (0x1114)                        0x2224 CMS                            Publishing                     8ztg Medium   Got List Item Version, but item was null. 
    02/13/2012 09:33:22.72  w3wp.exe (0x1114)                        0x2224 CMS                            Publishing                     8ztg Medium   Got List Item Version, but item was null. 
    02/13/2012 09:33:22.72  w3wp.exe (0x1114)                        0x2224 CMS                            Publishing                     8ztg Medium   Got List Item Version, but item was null. 
    02/13/2012 09:33:23.44  w3wp.exe (0x1114)                        0x1258 CMS                            Publishing                     7fz3 Medium   Setting [Display] as the FormContext.FormMode for the current page 
    02/13/2012 09:33:23.44  w3wp.exe (0x1114)                        0x1258 CMS                            Publishing                     7fz3 Medium   Setting [Display] as the FormContext.FormMode for the current page 
    02/13/2012 09:33:23.50  w3wp.exe (0x1114)                        0x1258 Search Server Common           MS Search Query                90gl Medium   SQL: dbo.proc_MSS_ScopeCacheGetChangedConsumers 91401 
    02/13/2012 09:33:23.52  w3wp.exe (0x1114)                        0x1258 CMS                            Publishing                     7fz3 Medium   Setting [Display] as the FormContext.FormMode for the current page 
    02/13/2012 09:33:23.52  w3wp.exe (0x1114)                        0x1258 CMS                            Publishing                     7fz3 Medium   Setting [Display] as the FormContext.FormMode for the current page 
    02/13/2012 09:33:23.52  w3wp.exe (0x1114)                        0x1258 Windows SharePoint Services    General                        72nz Medium   Videntityinfo::isFreshToken reported failure. 
    02/13/2012 09:33:24.41  w3wp.exe (0x12E4)                        0x22D8 SharePoint Portal Server       Runtime                        8gp7 Medium   Topology cache updated. (AppDomain: /LM/W3SVC/633878595/ROOT-1-129736045271698219) 
    02/13/2012 09:33:24.63  w3wp.exe (0x1114)                        0x121C CMS                            Publishing                     8ztg Medium   Got List Item Version, but item was null. 
    02/13/2012 09:33:24.63  w3wp.exe (0x1114)                        0x121C CMS                            Publishing                     8ztg Medium   Got List Item Version, but item was null. 
    02/13/2012 09:33:24.65  w3wp.exe (0x1114)                        0x121C CMS                            Publishing                     8ztg Medium   Got List Item Version, but item was null. 
    02/13/2012 09:33:24.86  w3wp.exe (0x1114)                        0x19E8 CMS                            Publishing                     7fz3 Medium   Setting [Display] as the FormContext.FormMode for the current page 
    02/13/2012 09:33:24.86  w3wp.exe (0x1114)                        0x19E8 CMS                            Publishing                     7fz3 Medium   Setting [Display] as the FormContext.FormMode for the current page 
    02/13/2012 09:33:24.94  w3wp.exe (0x1114)                        0x19E8 CMS                            Publishing                     7fz3 Medium   Setting [Display] as the FormContext.FormMode for the current page 
    02/13/2012 09:33:24.94  w3wp.exe (0x1114)                        0x19E8 CMS                            Publishing                     7fz3 Medium   Setting [Display] as the FormContext.FormMode for the current page 
    02/13/2012 09:33:25.47  w3wp.exe (0x1114)                        0x1258 CMS                            Publishing                     8ztg Medium   Got List Item Version, but item was null. 
    02/13/2012 09:33:25.47  w3wp.exe (0x1114)                        0x121C CMS                            Publishing                     7fz3 Medium   Setting [Display] as the FormContext.FormMode for the current page 
    02/13/2012 09:33:25.47  w3wp.exe (0x1114)                        0x1258 CMS                            Publishing                     8ztg Medium   Got List Item Version, but item was null. 
    02/13/2012 09:33:25.47  w3wp.exe (0x1114)                        0x121C CMS                            Publishing                     7fz3 Medium   Setting [Display] as the FormContext.FormMode for the current page 
    02/13/2012 09:33:25.49  w3wp.exe (0x1114)                        0x1258 CMS                            Publishing                     8ztg Medium   Got List Item Version, but item was null. 
    02/13/2012 09:33:25.55  w3wp.exe (0x1114)                        0x121C CMS                            Publishing                     7fz3 Medium   Setting [Display] as the FormContext.FormMode for the current page 
    02/13/2012 09:33:25.55  w3wp.exe (0x1114)                        0x121C CMS                            Publishing                     7fz3 Medium   Setting [Display] as the FormContext.FormMode for the current page 
    02/13/2012 09:33:25.57  w3wp.exe (0x1114)                        0x121C Windows SharePoint Services    General                        72nz Medium   Videntityinfo::isFreshToken reported failure. 
    02/13/2012 09:33:25.79  w3wp.exe (0x1114)                        0x121C CMS                            Publishing                     8ztg Medium   Got List Item Version, but item was null. 
    02/13/2012 09:33:25.79  w3wp.exe (0x1114)                        0x121C CMS                            Publishing                     8ztg Medium   Got List Item Version, but item was null. 
    02/13/2012 09:33:25.80  w3wp.exe (0x1114)                        0x121C CMS                            Publishing                     8ztg Medium   Got List Item Version, but item was null. 
    02/13/2012 09:33:26.11  w3wp.exe (0x1114)                        0x1DE4 Windows SharePoint Services    General                        0 Medium   Entering MRU trim routine. 
    02/13/2012 09:33:26.11  w3wp.exe (0x1114)                        0x1DE4 Windows SharePoint Services    General                        0 Medium   Initial table size: 195255881 in 679 entries 
    02/13/2012 09:33:26.11  w3wp.exe (0x1114)                        0x1DE4 Windows SharePoint Services    General                        0 Medium   Final table size: 195255881 in 679 entries 
    02/13/2012 09:33:26.11  w3wp.exe (0x1114)                        0x1DE4 Windows SharePoint Services    General                        0 Medium   Exiting MRU trim routine. 
    02/13/2012 09:33:26.38  w3wp.exe (0x1114)                        0x2224 Windows SharePoint Services    General                        8e2s Medium   Unknown SPRequest error occurred. More information: 0x80070057 

    Monday, February 13, 2012 6:03 PM
  • Hello Bogdan,

    I have pasted it below. please let me know if I need to send entire file. Unfortunately I am unable to attach whole log.

    I already tried sign it as different user and it works fine. Please help.

    Regards,

    Girish


    Monday, February 13, 2012 6:06 PM
  •  

    Hi,

    Thank you for the logs.

    Could you please change the logging to verbose mode and then reproduce the issue? Once you have reproduced it, search for this error PermissionMask check failed

    Here you have a print screen with SharePoint logging configuration


    MCITP|MCTS SharePoint| SharePoint Performance blog

    Monday, February 13, 2012 6:47 PM
  • PermissionMask check failed. asking for 0x00010000, have 0x00000000
    PermissionMask check failed. asking for 0x00000005, have 0x08431061
    PermissionMask check failed. asking for 0x00000015, have 0x08431061
    PermissionMask check failed. asking for 0x00000041, have 0x00011001TCheckoutUserId IS NULL OR t1.LTCheckoutUserId <> @IU )) AND (1 = 1)) LEFT OUTER JOIN AllUserData AS t2 WITH(NOLOCK, INDEX=AllUserData_PK) ON (UserData.[tp_Editor]=t2.[tp_ID] AND UserData.[tp_RowOrdinal] = 0 AND t2.[tp_RowOrdinal] = 0 AND ( (t2.tp_IsCurrent = 1) )  AND t2.[tp_CalculatedVersion] = 0  AND t2.[tp_DeleteTransactionId] = 0x  AND t2.tp_ListId = @L3 AND UserData.tp_ListId = @L4) LEFT OUTER JOIN AllUserData AS t3 WITH(NOLOCK, INDEX=AllUserData_PK) ON (UserData.[tp_CheckoutUserId]=t3.[tp_ID] AND UserData.[tp_RowOrdinal] = 0 AND t3.[tp_RowOrdinal] = 0 AND ( (t3.tp_IsCurrent = 1) )  AND t3.[tp_CalculatedVersion] = 0  AND t3.[tp_DeleteTransactionId] = 0x  AND t3.tp_ListId = @L3 AND UserData.tp_ListId = @L4) LEFT OUTER JOIN AllUserData AS t4 WITH(NOLOCK, INDEX=AllUserData_PK) ON (UserD...

    PermissionMask check failed. asking for 0x00000005, have 0x0C231061eter: '@II' Type: Int Size: 0 Direction: Input Value: '1556'

    PermissionMask check failed. asking for 0x00000015, have 0x3C4312EFrsion],t2.[tp_ID] AS c3c5,t3.[nvarchar5] AS c10c7,UserData.[tp_CopySource],UserData.[tp_InstanceID] FROM UserData INNER JOIN Docs AS t1 WITH(NOLOCK) ON ( 1 = 1  AND UserData.[tp_RowOrdinal] = 0 AND t1.SiteId = UserData.tp_SiteId AND t1.SiteId = @L2 AND t1.DirName = UserData.tp_DirName  AND t1.LeafName = UserData.tp_LeafName  AND t1.Level = UserData.tp_Level  AND  (UserData.tp_Level = 255 AND t1.LTCheckoutUserId =@IU OR (UserData.tp_Level = 1 AND (UserData.tp_DraftOwnerId IS NULL OR  (UserData.tp_DraftOwnerId <>@IU AND  1=0 ))  OR UserData.tp_Level = 2 AND (UserData.tp_DraftOwnerId = @IU OR  1=1 )) AND (t1.LTCheckoutUserId IS NULL OR t1.LTCheckoutUserId <> @IU )) AND (1 = 1) AND UserData.tp_ListId = @L3) LEFT OUTER JOIN AllUserData AS t2 WITH(NOLOCK, INDEX=AllUserData_PK) ON (UserData.[tp_E...

    PermissionMask check failed. asking for 0x00000005, have 0x00011001ditor]=t2.[tp_ID] AND UserData.[tp_RowOrdinal] = 0 AND t2.[tp_RowOrdinal] = 0 AND ( (t2.tp_IsCurrent = 1) )  AND t2.[tp_CalculatedVersion] = 0  AND t2.[tp_DeleteTransactionId] = 0x  AND t2.tp_ListId = @L4 AND UserData.tp_ListId = @L3) LEFT OUTER JOIN AllUserData AS t3 WITH(NOLOCK, INDEX=AllUserData_PK) ON (UserData.[tp_CheckoutUserId]=t3.[tp_ID] AND UserData.[tp_RowOrdinal] = 0 AND t3.[tp_RowOrdinal] = 0 AND ( (t3.tp_IsCurrent = 1) )  AND t3.[tp_CalculatedVersion] = 0  AND t3.[tp_DeleteTransactionId] = 0x  AND t3.tp_ListId = @L4 AND UserData.tp_ListId = @L3) LEFT OUTER JOIN AllUserData AS t4 WITH(NOLOCK, INDEX=AllUserData_PK) ON (UserData.[tp_Author]=t4.[tp_ID] AND UserData.[tp_RowOrdinal] = 0 AND t4.[tp_RowOrdinal] = 0 AND ( (t4.tp_IsCurrent = 1) )  AND t4.[tp_CalculatedVersion] = 0  AND ...

    PermissionMask check failed. asking for 0x00000015, have 0x00011001t4.[tp_DeleteTransactionId] = 0x  AND t4.tp_ListId = @L4 AND UserData.tp_ListId = @L3) LEFT OUTER JOIN AllUserData AS t5 WITH(NOLOCK, INDEX=AllUserData_PK) ON (t1.[LTCheckoutUserId]=t5.[tp_ID] AND t5.[tp_RowOrdinal] = 0 AND ( (t5.tp_IsCurrent = 1) )  AND t5.[tp_CalculatedVersion] = 0  AND t5.[tp_DeleteTransactionId] = 0x  AND t5.tp_ListId = @L4) WHERE  UserData.tp_ListID=@L3 AND ( (UserData.tp_Level= 255 AND UserData.tp_CheckoutUserId = @IU OR  ( UserData.tp_Level  = 2 AND UserData.tp_DraftOwnerId IS NOT NULL OR UserData.tp_Level  = 1 AND UserData.tp_DraftOwnerId IS  NULL  ) AND ( UserData.tp_CheckoutUserId IS  NULL  OR UserData.tp_CheckoutUserId <> @IU)) )  AND UserData.tp_RowOrdinal=0 AND ((UserData.[tp_ID] = @II)) ORDER BY t1.[Type] Desc,UserData.[tp_ID] Asc OPTION (FORCE ORDER) '     C...

    PermissionMask check failed. asking for 0x00000041, have 0x00011001ommandType: Text CommandTimeout: 0     Parameter: '@L0' Type: UniqueIdentifier Size: 0 Direction: Input Value: '00000000-0000-0000-0000-000000000000'     Parameter: '@L2' Type: UniqueIdentifier Size: 0 Direction: Input Value: '5948bd26-ba10-4149-baee-574517a94a40'     Parameter: '@IU' Type: Int Size: 0 Direction: Input Value: '469'     Parameter: '@L3' Type: UniqueIdentifier Size: 0 Direction: Input Value: 'fd45e5ee-cbf7-43fa-9839-6afda63ff92f'     Parameter: '@L4' Type: UniqueIdentifier Size: 0 Direction: Input Value: '2ab9e595-bba2-49c3-a2b4-3f1f71aee49a'     Parameter: '@II' Type: Int Size: 0 Direction: Input Value: '151'

    Monday, February 13, 2012 8:39 PM
  • Hi Bogdan,

    Actually there is too may error information. .txt file is over 263MB unfortunately I cannot post the whole log. I have randomly pasted few error logs. Please let me know if you need any specific information from the log file.

    Thank You very much for your time.

    Regards,

    Girish

    Monday, February 13, 2012 8:41 PM
  •    

     PermissionMask check failed. asking for 0x00010000, have 0x00000000

    Open permission is missing


    PermissionMask check failed. asking for 0x00000005, have 0x08431061

    ViewListItems, EditListItems are missing


    PermissionMask check failed. asking for 0x00000015, have 0x08431061

    ViewListItems, EditListItems, ApproveItems are missing


    PermissionMask check failed. asking for 0x00000041, have 0x00011001T

    ViewListItems, ViewVersions are missing

    Try to re-add permission for this user. Check maybe is in a special group.

    MCITP|MCTS SharePoint| SharePoint Performance blog


    Monday, February 13, 2012 8:54 PM
  • Hi Bogdan,

    I have already verified. user is part of a group that has contribute no delete permission. Unfortunately this is a custom list that has confidential information from other users  as well, I cannot grant elevated access to this user. other users in the same group have no issues logging into SharePoint site. other pages work fine.

    Regards,

    Girish

    Monday, February 13, 2012 9:15 PM
  • Hi kgirishshenoy

    You can try to delete the user, and re-create the user, then add the user to the group.

    Thanks,

    Lhan Han 


    Tuesday, February 14, 2012 3:55 AM
    Moderator
  • Hi Lhan,

    I have already tried that as a part of priliminary troubleshooting.

    Regards,

    Girish

    Tuesday, February 14, 2012 11:18 PM
  • Hi, I am having the same issue as described above.  It started with one user and over the week has "spread" to 6 users.  Does anyone have an answer to this yet? The screenshot in the original post is much like what I am seeing on certain user's computers.  However, others are working fine.  It seems like each day a new user is having the problem.  Is there an update that may be impacting this on the individual machine or is this something that should be looked at the server level.  Any help would be greatly appreciated as it is impacting our business.
    Friday, November 16, 2012 8:04 PM
  • Hi Ray,

    I was able to solve this for my users, this is not a local system issue. Its actually caused by Group permissions where user is added to. Please revisit the group permission, When I did, I noticed that few permissions like open list item, view list item were missing from group permissions. correcting that helped.

    Regards,

    Girish Shenoy

    • Marked as answer by kgirishshenoy Wednesday, June 26, 2013 6:07 PM
    Friday, November 16, 2012 10:22 PM