locked
This workbook cannot be opened because it is not stored in an Excel Service Application Trusted Location RRS feed

  • Question

  • One of user get error message while opening Excel work book at SharePoint 2010 Document Library

    "To open this workbook, your computer must have a version of Microsoft Excel installed and your web browser must support opening files directly from Excel in the browser.”

    We have configured document library Opening Documents in the Browser option as " Use server default"

    User machine Configuration: Window 7

    I'm aware IE 64 has problem while opening Excel document but for this time its not working for IE 32.

    I beleive there is something wrong with IE.

    Any help will be much appreciated

    Tuesday, August 21, 2012 7:40 PM

All replies

  • In Shared Services Administration > Edit Excel Services Settings, make sure that all your Excel Services Settings are correctly setup per your environment

    Jeremy Ramos | .NET / SharePoint / Dynamics Developer

    Wednesday, August 22, 2012 11:57 AM
  • Hi James,

    Thanks for reply, I believe its related to some IE setting. All users are able to open excel work book except one user.

    Thanks

    Sam

    Wednesday, August 22, 2012 1:09 PM
  • Hi James,

    Thanks for reply, I believe its related to some IE setting. All users are able to open excel work book except one user.

    Thanks

    Sam

    I found this on one users workstation as well. I did isolate the issue to her profile, I built a new profile on the same workstation and she was able to open the file. Some setting in IE may be the issue, however, I did use the Reset for IE and that had no effect. If anyone does come up with a solution I would be very interested.
    Monday, November 5, 2012 8:40 PM
  • I'm having the same problem, also isolated to only one user (and I've also done a reset of IE settings). Before scratching the user's profile, I would be interested in knowing what's causing this, so I can prevent it from happening again...

    Thanks,
    Robert

    Thursday, November 8, 2012 8:34 AM
  • I have the same issue since a few months. All my colleagues are able to open normally their files from the sharepoint, and I am the only one here with this issue. Anybody knows what happens ? Any solution found ?
    Wednesday, January 23, 2013 7:15 AM
  • Hi, our organization supports sharepoint portals internally at http, and externally at https.  I received this error when I tried to access the https version of the portal from inside our corporate network (where the unsecured http would normally be used).  I am able to access files externally from https, and internally from http, but internally using https I receive the error in the subject of this thread.  I suspect this is a setting in the sharepoint configuration our IT department has configured, but I do not have access to those settings so cannot dig deeper into what would be the root cause.  Once I changed the url from https to http, the files are accessible.

    So, to others who have this issue and may have both an encrypted and unencrypted version of the sharepoint site running, maybe try the opposite of whichever is giving the error.
    Just a thought.

    -J.

    • Proposed as answer by sheralf Wednesday, April 10, 2013 9:18 PM
    • Unproposed as answer by sheralf Wednesday, April 10, 2013 9:18 PM
    Thursday, February 28, 2013 4:52 PM
  • Had the same issue and only had to verify that certain SharePoint add-ons were not installed.

    Go to:

    1. Open IE Tools
    2. Select Manage Add-Ons and check for all the SharePoint Add-ons in the image below

    If they are not installed, run the MS Office Repair in Control Panel>Programs and Features>Microsoft Office and select Change and then repair.

    Wednesday, April 10, 2013 9:26 PM