locked
Application initialization failed. Last error: 0x80070032 RRS feed

  • Question

  • hello,

    i recently had a backup problem and upon searching this forum, i found a potential solution that suggested that I remove any additional language packs.  see link:

    http://social.technet.microsoft.com/Forums/en-US/windowsbackup/thread/3d410b3d-2d1d-48ac-94cd-04a80095d92c

    I ran lpksetup.exe and saw that I had the english and greek modules listed.  after removing the greek language module, i now have a new error in the event viewer that says:

     

    Application initialization failed. Last error: 0x80070032

    -------------------------------------------------------------------

    Log Name:      System
    Source:        Microsoft-Windows-LanguagePackSetup
    Date:          6/26/2011 11:25:06 PM
    Event ID:      1001
    Task Category: Language Pack Setup Wizard functionality
    Level:         Error
    Keywords:     
    User:          SYSTEM
    Computer:      T61P
    Description:
    Application initialization failed. Last error: 0x80070032
    Event Xml:
    <Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
      <System>
        <Provider Name="Microsoft-Windows-LanguagePackSetup" Guid="{7237fff9-a08a-4804-9c79-4a8704b70b87}" />
        <EventID>1001</EventID>
        <Version>0</Version>
        <Level>2</Level>
        <Task>30</Task>
        <Opcode>31</Opcode>
        <Keywords>0x8000000000000000</Keywords>
        <TimeCreated SystemTime="2011-06-27T06:25:06.767Z" />
        <EventRecordID>386792</EventRecordID>
        <Correlation />
        <Execution ProcessID="2084" ThreadID="2088" />
        <Channel>System</Channel>
        <Computer>T61P</Computer>
        <Security UserID="S-1-5-18" />
      </System>
      <EventData>
        <Data Name="Error">0x80070032</Data>
      </EventData>
    </Event>

    --------------------------------------------------------

    clicking on the "Event Log Online Help" tells me to set the Windows Modular Installer to Automatic in the Services program. 

    After doing so and rebooting, I still receive the error in the event viewer log.

    how do i repair this new error?

    also, in task scheduler, "lpksetup.exe -v" is scheduled to run at every system startup.  however, the "-v" command option is not listed in the technet library. 

    http://technet.microsoft.com/en-us/library/cc766010(WS.10).aspx

    what does the " -v" do?

     

     

    Monday, June 27, 2011 10:52 AM

All replies

  • Hi,

     

    Is the backup issue resolved now? Does your computer run properly now?

     

    It seems this error can be safely ignored.

     

    http://support.microsoft.com/kb/971275/en-us

     

    In addition, please run the System Update Readiness Tool from the following site and then paste the result in %SYSTEMROOT%\Logs\CBS\CheckSUR.log

     

    http://support.microsoft.com/kb/947821

     

    Tim Quan

    Tuesday, June 28, 2011 5:57 AM
  • thank you for the help so far, unfortunately, i am not making much progress on either issue. 

    the backup question was answered, but the problem is not resolved.  the "File Backup" does not delete old files, so my usb backup drive fills up, and i need to manually delete the older backup files myself.  in my opinion, that is not a good solution.

    http://social.technet.microsoft.com/Forums/en-US/windowsbackup/thread/e665f60e-eeff-4634-bb2d-041009087f8a

     

    on this language pack problem, i downloaded the readiness tool and it ran without error.  the result automatically places the log file in the requested location.  i rebooted, but once again, seven minutes after booting, i receive the same error in the event viewer as stated above. 

    do you have any other suggestions?

    Tuesday, June 28, 2011 8:43 AM
  • Hi,

     

    Then I suggest performing an in-place upgrade of the system.

     

    Tim Quan

     

     

    Wednesday, June 29, 2011 1:43 AM
  • hello,

    on the original backup error, i deleted all the files and reformated the backup usb drive. the previously full backup drive now has plenty of space, and the backup error is gone.

    back to the language pack problem...i am not sure what you mean by "in-place upgrade."  is there a language pack upgrade?  what service or registry item could be causing this error? i did not have this error before I deleted the greek language pack, leaving only the default english language pack.  i was only following the advice of this link:

    http://social.technet.microsoft.com/Forums/en-US/windowsbackup/thread/3d410b3d-2d1d-48ac-94cd-04a80095d92c

     

    also, what does the "-v" in  "lpksetup.exe -v" do?  I do not see it listed as a switch option in the technet library.

     

     

    Sunday, July 3, 2011 11:19 PM
  • Hi,

     

    To perform an In-place Upgrade, please insert a Windows Server 2008 disk on the running computer, run setup.exe and choose Upgrade Install. Then install your system over the current system. For example, if you are running Windows Server 2008 Enterprise now, install Windows Server 2008 Enterprise again.

     

    Tim Quan

     

    • Marked as answer by Tim Quan Thursday, July 7, 2011 1:34 AM
    • Unmarked as answer by desertchief Thursday, July 7, 2011 5:21 AM
    Monday, July 4, 2011 5:20 AM
  • I am using windows vista ultimate. i do not know if an in-place upgrade is possible.  also, i don't know why i would do any upgrade if my system was running fine before using the advice of that link.

     

    why would lpksetup.exe initializatoin fail?

     

    what abou the "-v" question?

    Thursday, July 7, 2011 5:27 AM