none
SCDPM 2010 MS iScSI Target and CSV RRS feed

  • Question

  • Hi, i have my test enviroment configured in following way:

    One Windows 2008 R2 server with MS iSCSI Target and three CSVs on it.

    Two Hyper-V nodes in Hyper-V cluster.

    One SCDPM 2010 server.

    During backup with SCDPM i get following error:

    Failed to prepare a Cluster Shared Volume (CSV) for backup as another backup using the same CSV is in progress. (ID 32612 Details: Back up is in progress. Please wait for backup completion before trying this operation again (0x8007173D))

    To solve this idea i have tried:

    • Changed registry on SCDPM to limit parallel backups :HKLM\SOFTWARE\Microsoft\Microsoft Data Protection Manager\2.0\Configuration\MaxAllowedParallelBackups from 3 to 1
    • I have tried to change SCDPM configuration according to this article and enable "LUN serialization" - HKLM\SOFTWARE\Microsoft\Microsoft Data Protection Manager\2.0\Configuration\MaxAllowedParallelBackups, but didn't help
    • I have changed registry on DPM agents as was suggested in other topic but also didn't help. Now there is no error but tasks are running for hours without transfering any data (I enclose registry file that i've used)

    Windows Registry Editor Version 5.00
    [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Microsoft Data Protection Manager\Agent\CSV]
    "CsvMaxRetryAttempt"=dword:000000C8
    "CsvAttemptWaitTime"=dword:0002bf20d

    Does anyone have any idea how can i solve this issue?


    Friday, June 24, 2011 2:02 PM

Answers

  • Hi

    The Microsoft iSCSI Target VSS Hardware Provider does not support auto-recovery snapshots which is what is required for hyper-V ONLINE backups.

    You must configure each node to use built-in System VSS Provider, then enable Hyper-V serialization.  This will take longer to back up the guests since only one guest can be backed up at a time per node / per CSV.

    Perform all of the following..

    1) Make sure the cluster network configuration is optimized for redirected mode.

    System Center Data Protection Manager 2010 Hyper-V protection: Configuring cluster networks for CSV redirected access
    http://support.microsoft.com/default.aspx?scid=kb;EN-US;2473194

    2) Make sure the integration components are updated in the guests.

    3) Make sure automount is enabled on the host:  Run mountvol /E

    Then...

    1. On every node in the Hyper-V cluster, Open regedit and add the following key, this will tell DPM agent to use System Software Provider.

          HKLM\Software\Microsoft\Microsoft Data Protection Manager\Agent\UseSystemSoftwareProvider


    2. Enable Hyper-V Serialization according to the following technet article:
           
           Considerations for Backing Up Virtual Machines on CSV with the System VSS Provider
           http://technet.microsoft.com/en-us/library/ff634192.aspx


    Regards, Mike J. [MSFT] This posting is provided "AS IS" with no warranties, and confers no rights.

    • Marked as answer by Vilow Wednesday, August 10, 2011 10:39 AM
    Friday, June 24, 2011 10:44 PM
    Moderator

All replies

  • Hi,

    <snip>
     Now there is no error but tasks are running for hours without transfering any data.
    >snip<

    Try disabling TCP Chimney on the hyper-V hosts by running.

       Netsh int tcp set global chimney=disabled 


    Regards, Mike J. [MSFT] This posting is provided "AS IS" with no warranties, and confers no rights.
    Friday, June 24, 2011 2:56 PM
    Moderator
  • I hava tried but no results :(. I have noticed that if i turn off all VMs on the cluster, then all CSVs stay in 'online' mode and there is no problem with backups. When VMs are turned on then CSVs are switching to "redirected access' and DPM has problems with making backups of VMs :(

    Friday, June 24, 2011 4:32 PM
  • OK, i've instaled hardware provider from MS iSCSI target and it's working better. I got only 1 error regarding CVS but now i have error with VSS. I can't backup some of the VMs when they are turned on and running i get error:

    DPM encountered a retryable VSS error.(ID:30112 Details:VssError: The writer experienced a transient error.If the backup process is retried, the error may not reoccur.(0x800423F3)

    When i turn off the machine, there is no problem with backup.

    Friday, June 24, 2011 8:53 PM
  • Hi

    The Microsoft iSCSI Target VSS Hardware Provider does not support auto-recovery snapshots which is what is required for hyper-V ONLINE backups.

    You must configure each node to use built-in System VSS Provider, then enable Hyper-V serialization.  This will take longer to back up the guests since only one guest can be backed up at a time per node / per CSV.

    Perform all of the following..

    1) Make sure the cluster network configuration is optimized for redirected mode.

    System Center Data Protection Manager 2010 Hyper-V protection: Configuring cluster networks for CSV redirected access
    http://support.microsoft.com/default.aspx?scid=kb;EN-US;2473194

    2) Make sure the integration components are updated in the guests.

    3) Make sure automount is enabled on the host:  Run mountvol /E

    Then...

    1. On every node in the Hyper-V cluster, Open regedit and add the following key, this will tell DPM agent to use System Software Provider.

          HKLM\Software\Microsoft\Microsoft Data Protection Manager\Agent\UseSystemSoftwareProvider


    2. Enable Hyper-V Serialization according to the following technet article:
           
           Considerations for Backing Up Virtual Machines on CSV with the System VSS Provider
           http://technet.microsoft.com/en-us/library/ff634192.aspx


    Regards, Mike J. [MSFT] This posting is provided "AS IS" with no warranties, and confers no rights.

    • Marked as answer by Vilow Wednesday, August 10, 2011 10:39 AM
    Friday, June 24, 2011 10:44 PM
    Moderator