locked
WSS 3.0 Incoming emails problem when creating a new library/list RRS feed

  • Question

  • Hi guys,

    I have a client that is currently running WSS 3.0 on their server. Their intranet site is working at the moment , and they currently have 2 document libraries that are setup to accept incoming emails, which works flawlessly.

    The issue is when we are trying to create a new document library that has incoming emails enabled, I get the following error message:

    "The list was created successfully, but could not be assigned an e-mail alias because of the following error: Error in the application.
    "

    Upon checking, it does create the document library however the email settings are not enabled. Then when I try to set the email settings again within the document library settings, the following error message gets displayed "Error in application"

    -I have tried creating different document libaries with email settings in different workspaces to no avail
    -Existing incoming email lists still work.
    -I have checked the permissions on the sharepointdl OU in Active directory and the domain admin has full control over the OU. I also made sure delegate access had full permissions for the domain admins as well.
    -I also re-entered the service-account details for the app pool in Central Admin to the domain account and can confirm the central admin/intranet site/app pool are running under the same domain admin account.

    Sharepoint Environment

    WSS 3.0 12.0.0.6565 installed on Windows Server 2008 SP2 Server
    SQL Server SQL Server 2008 Service Pack 1 installed on the same server (content database is in here
    The same server is also the primary domain controller.

    There is a separate Windows Server 2008 SP1 SMTP server that exists for the sole purpose of processing emails for sharepoint.

    The incoming email settings are set to use the SharePoint directory management service to create ditribution groups and contacts. The SMTP server is set to the smtp server above and the Drop folder points to the drop folder on the SMTP server. There is a Sharepointdl OU created in AD and specified in the settings here with existing groups already in there.

    I'm at odds end why it can still work, yet I cant create a new list with incoming emails enabled. Can any one of you Sharepoint Gurus' help me out?

    Wednesday, June 19, 2013 6:15 AM

Answers

  • Are you sure that that email address isn't already in use?

    There is a tool called ULSViewer, you can see the current logging, so you retry you action and the browse through all the lines it logs. Mind you though there are a lot lines to go through.

    I'm not a doctor (just an abbreviation of my last name) ;)

    Friday, June 21, 2013 7:10 AM
  • Hi Guys,

    I managed to resolve the issue!

    Turns out the Central Administration app pool account was running on the NETWORKSERVICE account. I changed that to be the same account as the Intranet App pool and voila, fixed my problem.
    Monday, July 1, 2013 9:16 AM

All replies

  • Hello,

    Did you check your ULS logs, they normally provide way more information than the "Error in application" message, also I think that you need to install the smtp service on your SharePoint machine itself.

    here is a link on how to configure incoming email on wss and moss

    http://technet.microsoft.com/en-us/library/cc262947%28office.12%29.aspx

    Wednesday, June 19, 2013 8:05 AM
  • Just to clarify, the apppool account itself, does this have creation rights within the OU?

    Steven Andrews | SharePoint Professional | http://www.twitter.com/backpackerd00d | https://baron72.wordpress.com/

    Wednesday, June 19, 2013 9:55 AM
    Answerer
  • Hi Guys,

    Appreciate the response.

    Dr Leendert: What is the best way to look at /interepret the ULS logs. I havent done that before.

    The server that is running sharepoint also runs MS Exchange on there. We have a separate server purely for SMTP purposes which is currently running and the other incoming email document libraries work perfectly right now.

    @Steve Andrews: The app pool account is running on the domain admin account which i also logged into the server to make sure i could create the users in that OU. I also checked to make sure the delegate control was setup to full permissions for that same domain admin account.

    I'm bit of an odd ends on what else I can try...

    Friday, June 21, 2013 6:46 AM
  • Are you sure that that email address isn't already in use?

    There is a tool called ULSViewer, you can see the current logging, so you retry you action and the browse through all the lines it logs. Mind you though there are a lot lines to go through.

    I'm not a doctor (just an abbreviation of my last name) ;)

    Friday, June 21, 2013 7:10 AM
  • Hi guys,

    After running a realtime ULS scan and then trying to apply the incoming email settings on a document library I get the attached logs:

    The error that jumps out at me is the last High error highlighted above. The actual message is below:

    System.UnauthorizedAccessException: General access denied error      
     at System.DirectoryServices.Interop.UnsafeNativeMethods.IAds.SetInfo()    
     at System.DirectoryServices.DirectoryEntry.CommitChanges()    
     at Microsoft.SharePoint.EmailIntegration.SPEWSADManager.CreateContact(String Alias, String FirstName, String LastName, String ForwardingEmail, ContactFlags Flags)SPEWSADManager::CreateContact

    Upon looking at the error it looks like possibly it has an error trying to write to the Active Directory OU. I've assigned the domain administrator account full delegate control and permissions to the folder and can create users in there, so I'm not sure what else I can check.

    Any help would be appreciated!

    Monday, July 1, 2013 8:03 AM
  • Hi Guys,

    I managed to resolve the issue!

    Turns out the Central Administration app pool account was running on the NETWORKSERVICE account. I changed that to be the same account as the Intranet App pool and voila, fixed my problem.
    Monday, July 1, 2013 9:16 AM