locked
How can I turn off "needy state" for a specific program? RRS feed

  • Question

  • I like to keep my Taskbar set to Auto Hide.  Unfortunately, every time ANY window that I have running that enters the "needy state" prompts the taskbar to open.  This is nice when it happens occasionally, but when it happens every few seconds, it becomes VERY irritating.

    How about a Group Policy or Registry fix to keep the taskbar hidden when "specified" programs enter a "needy state"?

    Skype is a good example.  I like being able to chat with friends using Skype.  BUT it is not important that Skype tells me EVERY time someone types something in every conversation I have open. It is irritating while trying to multitask and working in another window to have the taskbar keep popping up and blocking things I want to see.  Skype does NOT have any option to stop this from occuring.

    It would be nice to keep other programs that enter the "needy state" from opening my taskbar every few seconds as well.

    Does anybody know how to fix this?

     

    Wednesday, January 4, 2012 11:58 PM

Answers

  • Hi,

     

    Are you trying to disable the prompt for the active programs?

     

    Also, you may see if you are running into the scenario in the following thread:

     

    My taskbar doesn't autohide when using certain programs...would be appreciated if fixed.

     

    If the above is not your scenario, could you please capture a screenshot for this to clarify the symptom clearly?

     

    Screenshot of the symptom

    ------------------------------------

    1. Press the Print Screen key (PrtScn) on your keyboard.

    2. Click the "Start" menu, type "mspaint" in the Search Bar and Press Enter.

    3. In the Paint program, click the "Edit" menu, click "Paste", click the "File" menu, and click "Save".

    4. The "Save As" dialogue box will appear. Type a file name in the "File name:" box, for example: "screenshot".

    5. Make sure "JPEG (*.JPG;*.JPEG;*.JPE;*.JFIF)" is selected in the "Save as type" box, click “Desktop” on the left pane and then click "Save".

     

    You can refer to the following link to upload the information:

     

    http://social.technet.microsoft.com/Forums/en-US/w7itproui/thread/4fc10639-02db-4665-993a-08d865088d65

     

    Regards,

     

    Sabrina

     

    TechNet Subscriber Support in forum

    If you have any feedback on our support, please contact  tnmff@microsoft.com.


    Sabrina

    TechNet Community Support

    • Marked as answer by Sabrina Shen Friday, January 13, 2012 1:36 AM
    Thursday, January 5, 2012 5:17 AM

All replies

  • Hi,

     

    Are you trying to disable the prompt for the active programs?

     

    Also, you may see if you are running into the scenario in the following thread:

     

    My taskbar doesn't autohide when using certain programs...would be appreciated if fixed.

     

    If the above is not your scenario, could you please capture a screenshot for this to clarify the symptom clearly?

     

    Screenshot of the symptom

    ------------------------------------

    1. Press the Print Screen key (PrtScn) on your keyboard.

    2. Click the "Start" menu, type "mspaint" in the Search Bar and Press Enter.

    3. In the Paint program, click the "Edit" menu, click "Paste", click the "File" menu, and click "Save".

    4. The "Save As" dialogue box will appear. Type a file name in the "File name:" box, for example: "screenshot".

    5. Make sure "JPEG (*.JPG;*.JPEG;*.JPE;*.JFIF)" is selected in the "Save as type" box, click “Desktop” on the left pane and then click "Save".

     

    You can refer to the following link to upload the information:

     

    http://social.technet.microsoft.com/Forums/en-US/w7itproui/thread/4fc10639-02db-4665-993a-08d865088d65

     

    Regards,

     

    Sabrina

     

    TechNet Subscriber Support in forum

    If you have any feedback on our support, please contact  tnmff@microsoft.com.


    Sabrina

    TechNet Community Support

    • Marked as answer by Sabrina Shen Friday, January 13, 2012 1:36 AM
    Thursday, January 5, 2012 5:17 AM
  • Hi,

     

    I am just checking to see how things are going there on this issue. If you would like further assistance, please do not hesitate to let me know.

     

    Thanks, and have a great day!

    Regards,

     

    Sabrina

    TechNet Subscriber Support in forum

    If you have any feedback on our support, please contact tnmff@microsoft.com.


    Sabrina

    TechNet Community Support

    Wednesday, January 11, 2012 2:22 AM
  • There's really not a way to control this, it's part of the shell.  If a program calls the FlashWindow function, the system does as requested.  The program really is in control (it'd be nice if more programs provided an option for this -- the Trillian instant messenger does, for example - which by the way has seamless Skype integration now).

    I don't have the programming expertise to know if this is possible, but I searched the web to see if there was any programs out there that could intercept that function call.  I didn't see any, unfortunately.  I would imagine such a program would have to hook pretty deeply into the system to block functions (something like a rootkit).

    Microsoft really is in a hard place with stuff like this, it all goes back to legacy compatibility.  This feature was built and established in 1993 with Windows NT, and countless programs use it.  It's a tough call to please the companies that built those programs versus users who want to be in control.  We've seen small steps in recent years (notably more so with Windows 7) towards users in control. That's why programs can no longer spam icons of themselves into the Start menu or Taskbar, and even their notification icons are force-hidden from view until/unless the user specifically puts an icon there.

    This is also a major reason why Windows 8 has an entire new application runtime environment that has been rebuilt with this generation in mind.


    Shawn Keene
    Friday, January 27, 2012 1:17 AM