none
transport rules are skipped RRS feed

  • Question

  • Hi all,

    we have a security requirement to lock down incoming and outgoing access for some of the mailboxes in our environment. as a result, we created 4 transport rules for this matter, in order of priority:

    1. restrict all mails sent 'outside the organization' with no exceptions for the specified mailboxes

    2. restrict all mails sent 'inside the organization' with no exceptions for the specified mailboxes

    3. restrict all mails received from 'outside the organization' unless sender address pattern matches @ourdearpartner.com for the specified mailboxes

    4. restrict all mails received from 'inside the organization' with no exceptions for the specified mailboxes

    generally, incoming rules works fine since there can be only one sender. Problem occurs when the specified mailboxes attempt to send a single mail to 2 recipients, one inside and one outside the organization. depending on the order of rule priority, mails to either one of the recipient will go through. Note that none of the rules has the 'Stop processing more rules' option checked. The behaviour seems to be as long as one of the rules have applied, other rules are ignored. 

    we have moved from domino recently and its a big security breach for us. can anyone shed some lights? TIA

    Tuesday, December 8, 2015 4:09 AM

Answers

  • I really don't understand how you think we could solve your problem without providing details of the rules you've created.

    Perhaps you might try adding -StopRuleProcessing:$False to all the rules.


    Ed Crowley MVP "There are seldom good technological solutions to behavioral problems."
    Celebrating 20 years of providing Exchange peer support!

    Wednesday, December 9, 2015 4:19 AM
    Moderator
  • Hi Staney,

    Which rule type did you create? Transport rule or Outlook client rule?

    Base on my knowledge, 'Stop processing more rules' option is an outlook client rule option,

    However, according to your description, you had created 4 transport rules to restrict mail flow for the specified mailboxes. 

    You should post the details of these rules, that could help us to troubleshoot the issue.

    Best regards,


    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    Niko Cheng
    TechNet Community Support

    Wednesday, December 9, 2015 8:28 AM
    Moderator

All replies

  • I really don't understand how you think we could solve your problem without providing details of the rules you've created.

    Perhaps you might try adding -StopRuleProcessing:$False to all the rules.


    Ed Crowley MVP "There are seldom good technological solutions to behavioral problems."
    Celebrating 20 years of providing Exchange peer support!

    Wednesday, December 9, 2015 4:19 AM
    Moderator
  • Hi Staney,

    Which rule type did you create? Transport rule or Outlook client rule?

    Base on my knowledge, 'Stop processing more rules' option is an outlook client rule option,

    However, according to your description, you had created 4 transport rules to restrict mail flow for the specified mailboxes. 

    You should post the details of these rules, that could help us to troubleshoot the issue.

    Best regards,


    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    Niko Cheng
    TechNet Community Support

    Wednesday, December 9, 2015 8:28 AM
    Moderator