none
Skype for Business, desktop sharing doesnt work when Hyper-V is installed.

    Question

  • Hello all,

    Having an issue that I nor Microsoft can seem to figure out. Skype for business desktop sharing works fine, I can share my screen with no issues. But as soon as I install Hyper-V on this same computer, the desktop sharing functionality doesnt work. I click share my screen and it just sits there "connecting..." then I get a message back saying the user didnt accept my invitation. If I uninstall Hyper-V from the computer everything works fine.

    We have uninstalled Skype and re-installed, re-imaged windows. Microsoft doesnt seem to know either at this point what could be causing this. We updated video drivers

    Any ideas? Thanks all!

    Thursday, November 15, 2018 7:54 PM

All replies

  • Hello Dan,

    I have never seen this before, even i have hyper-v on Windows 2012 R2, however the way you saying it seems INVITE is sent, and then it times out.
    Can you Paste INVITE Dialog over here, or share your client log along with ETL trace, i can have a look into this and share findings ASAP.

    Regards

    Durgesh

    Thursday, November 15, 2018 9:27 PM
  • Hi,

    Please make sure the full version and latest version of Skype for Business be installed in the virtual machine.

    Besides, did you try with other user account to share desktop? Does it work?

    If it still can’ t work, please check your OS version in your hyper-v environment, there are some update patches impacting the sharing feature after installed in OS. Here is an article for your reference: https://blogs.technet.microsoft.com/nexthop/2018/07/18/application-sharing-failures-after-applying-july-10-2018-windows-security-fixes/

    Kind regards,

    Calvin Liu


    Please remember to mark the reply as an answer if you find it is helpful. It will assist others who has similar issue. If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.

    Click here to learn more. Visit the dedicated forum to share, explore and talk to experts about Microsoft Teams.

    Friday, November 16, 2018 5:38 AM
    Moderator
  • I am having this same issue.

    Yesterday I installed Windows 10 1809 from scratch. I only installed newest Office 365 C2R -> Skype screen sharing works -> enable hyper-v role -> Skype screen sharing says "Connecting..."


    www.ictmanuaali.net

    Wednesday, November 21, 2018 5:22 AM
  • We are not trying to run Skype for Business on virtual machine. Problem is that when you add Hyper-V feature to your physical machine the Skype for Business sharing does not work anymore. In Teams client sharing works but not able to join to Skype for Business meetings with Teams client.

    Also tested Skype Meetings App and same result as using full Skype for Business client.

    Also tried to change boot options to disable hypervisor but same situation.

    Skype for Business sharing starts to work when you completely remove Hyper-V feature from OS. This is not very good if you need to for example run emulators on Hyper-V on mobile app development. Not possible to have development environment (that needs to be installed to physical device for some development tasks to work) and Skype for Business with sharing on same machine -> developers cannot share anything on Skype for Business meetings

    <style><br _moz_dirty="" /></style>
    Thursday, November 29, 2018 9:55 AM
  • I can confirm this behaviour on my Surface Book. Enable Hyper-v and Skype for business desktop sharing no longer works. Disable hyper-v and everything is fine.

    (Doesn't apply to Hyper-v management tools - Skype works fine with only the management tools enabled)

    Edit - Windows 1809 - 17763.134
    • Edited by MintyTrebor Thursday, December 13, 2018 11:45 AM added version info
    Thursday, December 13, 2018 11:44 AM
  • I have the same issue, It seems related to the Networks that are created by the Hyper-V if I disable the virtual switch then all is ok again but obviously my Hyper-V vms are not working at this point.

    I have 2 seperate NICS in my PC specifically for Hyper-V and I wonder if this is what it cant handle, Maybe its sending the invite to the wrong NIC.

    Wednesday, January 9, 2019 9:07 AM
  • I can confirm I have the same issue - I can work around this by disabling the Hyper-V Network adapters (rather than uninstalling Hyper-v).  As of this morning and after a Windows update the problem actually seesm to have gotten worse, in that I can now no longer connect to Skype Voice meetings either, or initiate a one to One voice call.  Skype itselfg is fine and can seee all my contacts and text chat, but when I try to join a meeting, the meeting window opens, but is just all white and have not chat, attendees and cannot speak or hear.

    As mentioned, if I go to "Network and Internet settings" and disable the Hyper-v adapter, everything works


    Mark Moore

    Wednesday, January 9, 2019 10:12 AM
  • Same issue, did not know why .... 

    After removing HyperV all back to normal.

    Thursday, January 17, 2019 3:50 PM
  • Mine has also got worse again now, Disabling the NIC no longer works and the issue is now also prevalant on another PC
    Friday, January 18, 2019 6:31 PM
  • Joining the fray!

    Brand new laptop, DELL 5591, Windows 10 64-bit, Office 2016 installed w/Skype For business client and all works well (this was both the 64-bit and 32-bit versions of Office and S4B).

    Install Hyper-V and S4B is broken ,screen sharing doesn't work, file trnsfers fail, cannot add additional participants to a call, etc... I'm sure there are other features that fail as well however those are the ones we use most.  

    Remove Hyper-V and all is back to normal.

    BTW, we also have another DELL 5591 and it works with it all installed.  So theoretically we have two identical machines (hardware), with what should be identical software and configs however they do not behave the same (also note these are stock Windows 10 builds from the OEM, not an image based build).  We are looking to verify driver sets and perhaps BIOS settings to note any differences.

    Still looking for a solution... alternative would be to use VMWare Workstation.

    Regards,

    Mike.

    Friday, January 18, 2019 7:30 PM
  • Just a follow up...

    Because this was a brand new build, we reset the laptop back to factory defaults.  Installed Hyper-V first and then Office 365 32-bit only with Skype 32-bit only.  All is working well.  Perhaps it is an order of operations thing that causes the problem as opposed to 32/64-bit software.

    Take a bazooka to an anthill and we're up and running.

    Regards,

    Mike.

    Monday, January 21, 2019 5:46 PM
  • Had the same issue only resolution was to turn off hyper v from windows features
    Tuesday, January 22, 2019 12:37 AM
  • Same issue. I have to remove hyper-v to get Skye for business desktop sharing to work.

    Tuesday, January 22, 2019 4:38 PM
  • Same issue here.    Two days on the phone line with Office 365 Support and now just saw this thread. 

    Disabling Hyper V Adapter did not work for me.   Had to completely uninstall.     

    If anyone happens along a fix.   Please post it!  

    Thanks!

    Wednesday, January 23, 2019 4:37 AM
  • Having this same issue, only fix i have found so far is disabling the Hyper-V Feature to allow desktop sharing to work again...

    Running Windows 10 - 1809

    Wednesday, January 23, 2019 6:59 PM
  • Can confirm this issue. Is this reportable via the Office team or the Windows team?
    Tuesday, February 5, 2019 3:32 PM
  • Hello,

    Yes this is a known issue


    Thanks, Darrell Gorter [MSFT] This posting is provided "AS IS" with no warranties, and confers no rights.

    Tuesday, February 5, 2019 7:19 PM
  • And...
    Friday, February 8, 2019 4:20 PM
  • @Darrell Gorter

    Is there a fix coming? If so any idea when? How will we be notified?

    Thanks

    Tuesday, February 12, 2019 3:18 PM
  • Hello,

    No timeline on a fix yet

    Here is a workaround that should work

    1. Net stop winnat
      netsh int ipv4 add excludedportrange tcp 50000 60
      netsh int ipv6 add excludedportrange tcp 50000 60
      netsh int ipv4 add excludedportrange udp 50000 60
      netsh int ipv6 add excludedportrange udp 50000 60
      Reboot

      Explanation:
      1. Create “port exclusions” as shown above covering the ports that you want wildcard port selection/reservation to stay away from. Any app will still be able to bind to a specified port inside the excluded range; only wildcard port selection (including winnat’s wildcard port reservation) is “excluded.” The exclusion will persist across reboots.
      2. The only remaining problem is that winnat may have already reserved those ports by the time you try to create the exclusion, in which case the exclusion will fail. Hence the step to stop winnat, add the exclusions and then reboot.


    Thanks, Darrell Gorter [MSFT] This posting is provided "AS IS" with no warranties, and confers no rights.

    • Proposed as answer by Eric Eicke Tuesday, February 12, 2019 7:46 PM
    Tuesday, February 12, 2019 6:41 PM
  • Darrell thanks for the workaround. It worked for me.
    Tuesday, February 12, 2019 7:38 PM
  • Thanks Darrell, that worked for me as well!
    Thursday, February 14, 2019 5:32 PM
  • Thank God!  This issue was driving me CRAZY!  I kept reinstalling O2016/365 and Skype would work properly for a while then eventually crap out.  The suggested changes for IP4 worked for me, thank you!

    Pat
    • Edited by Patrick Flick Saturday, February 16, 2019 6:28 PM Grammar
    Saturday, February 16, 2019 6:27 PM
  • Hello,

    No timeline on a fix yet

    Here is a workaround that should work

    1. Net stop winnat
      netsh int ipv4 add excludedportrange tcp 50000 60
      netsh int ipv6 add excludedportrange tcp 50000 60
      netsh int ipv4 add excludedportrange udp 50000 60
      netsh int ipv6 add excludedportrange udp 50000 60
      Reboot

      Explanation:
      1. Create “port exclusions” as shown above covering the ports that you want wildcard port selection/reservation to stay away from. Any app will still be able to bind to a specified port inside the excluded range; only wildcard port selection (including winnat’s wildcard port reservation) is “excluded.” The exclusion will persist across reboots.
      2. The only remaining problem is that winnat may have already reserved those ports by the time you try to create the exclusion, in which case the exclusion will fail. Hence the step to stop winnat, add the exclusions and then reboot.


    Thanks, Darrell Gorter [MSFT] This posting is provided "AS IS" with no warranties, and confers no rights.

    Thanks Darrell, it worked for me as well. Any chance there's an official KB for this bug that we can follow to see when it's officially acknowledged and fixed?
    Monday, March 4, 2019 4:58 PM
  • Thanks for this post and the workaround here.

    It made me crazy as sometimes i could join meetings and sometimes i could not. I did not know why (eth/wifi, network...)

    I used to have at least one NAT vswitch since i have windows 10, and it worked fine before erasing all vswitch and come back to the default one. I did not link it with my skype problem...

    Wednesday, March 6, 2019 10:19 AM
  • Thanks for the post and the workaround. Confirmed to work on the latest version of Windows 10 today. This was driving me crazy too. I reinstalled office countless times and removed other software in pursuit of a fix. Even reinstalled the whole machine and found Skype for Business sharing to be working after that. Only after re-enabling Hyper-V I realized the connection and found this thread.
    Sunday, March 17, 2019 3:12 PM
  • I am having this same issue.  My problem is that when I try these commands only the first netsh command works.  After that, they all return this error:

    C:\WINDOWS\system32>netsh int ipv6 add excludedportrange tcp 50000 60
    The process cannot access the file because it is being used by another process.

    If I reboot and try the second line again, then that one works, but the third one will not work.

    Not sure what I am doing wrong.  I am running inside an Administrator level command prompt.

    --Stewart McGuire


    Stewart McGuire

    Tuesday, March 26, 2019 3:53 PM
  • For me, both of the IPV4 commands work, but for the IPV6 commands I also get the error:

    The process cannot access the file because it is being used by another process.

    Despite this, after a reboot, skype is working normally again. I can join meetings, see other's screens and share my own screen as well.

    Thanks Darrel!

    Thursday, April 11, 2019 6:42 AM