none
Is there a way to force Windows Search to index? RRS feed

  • Question

  • Is there a brute force/manual way to get Vista to index the desired folders on my hard-drive?

    From what I understand indexing takes place during idle time, and I've let my pc sit idle for several nights, yet when I search "All mail items" for my own in Outlook 2007 for example, it returns not a single result, but instead I get a box stating that indexing is still taking place.  A subsequent click on that box yeilds a pop-up box stating that 6000 some-odd items remain to be indexed, and this number fluxuates up or down by a few hundred.

    Any ideas what is going on?  How can I remedy this and get Outlook indexed and searchable?  Search worked just as expected with my earlier XP setup with Outlook 2007 and Windows Desktop Search.  Why not now with Vista Ultimate?  I have ensured that Indexing is configured to index my Outlook personal and hotmail folders.

    Thanks in advance for your advise.

    Jason

    Saturday, March 3, 2007 1:36 PM

Answers

  • Open Control Panel, set it as classic view, double click Indexing Options. You can include encrypted files, rebuild, control file types you can index from Advanced tab,,, check more here down

    Indexing Options tool

    To navigate to the Indexing Options tool you can open the Control Panel and then click the appropriate icon as shown in Figure A.

    Figure A

    Control Panel

    Alternatively, you can use the search index itself to find the tool. Click the Start Menu button and type "index" into the search box. The Indexing Options tool will appear as one of the choices as you can see in Figure B.

    Figure B

    Indexing Options through search

    Once the Indexing Options tool is open (Figure C) you will get a brief synopsis of how many files are currently indexed and where they are located. In most cases, the default settings will be enough because the files most users use over and over will be located in their document folder. E-mail correspondence is the other area where searching comes in handy and that too is covered by default.

    Figure C

    Indexing Options tool default settings

    Clicking the Modify button on the initial screen of the Indexing Options tool will reveal the screen shown in Figure D. In this configuration screen you can use to add or subtract specific files and folders from the search index.

    Figure D

    Indexing Options modifications

    For example, clicking the Show all locations button will add all of the folders on your hard drives to the potential list of indexed locations (Figure E). However, adding all of those locations to the index will increase the size tremendously and likely make the search index useless for quickly and efficiently finding files. Take some time to plan exactly which locations you want to index.

    Figure E

    All locations

    The other configuration option available from the Indexing Options tool (Figure C) is under the Advanced button. You'll need administrative rights to make changes under this button. The Advanced Options screen (Figure F) gives you several more configuration options including the ability to index encrypted files, rebuild the search index, restore to default settings and select a new place to store the index.

    Figure F

    Advanced options

    The File Types tab on the Advanced Options screen is for those who like to get down to the most granular of settings (Figure G). From this screen you can change which files are indexed by their extension. You can even modify how deeply each extension is indexed from this screen. This is definitely an area for users with a clear understanding of how the search index functions and an even clearer idea of how they want their system configured.

    Figure G

    File types under Advanced Options
    Good luck
    Sunday, March 4, 2007 6:40 PM
  •  

    1. Try adding the outlook mail storage file (.PST) in the indexing location

    [i.e. Control Panel -> Indexing Options -> Show all locations - Then select the (.pst) storage folder in the plane above]

     

    2. Make sure that you have selected indexing of .pst files in the "Advanced Options" -> "File Types"

     

    3. Open "GPEDIT.MSC" and browse to;

     

    1. Local Computer Policy
    2. Administrative Templates
    3. Windows Components
    4. Search
    In the right plane look for "Disable indexer backoff". Click to open and set it to Enable.


    This might not be what exactly you were looking for but is an alternative to get the job done sooner. 

     

    Sunday, October 3, 2010 10:35 PM

All replies

  • Open Control Panel, set it as classic view, double click Indexing Options. You can include encrypted files, rebuild, control file types you can index from Advanced tab,,, check more here down

    Indexing Options tool

    To navigate to the Indexing Options tool you can open the Control Panel and then click the appropriate icon as shown in Figure A.

    Figure A

    Control Panel

    Alternatively, you can use the search index itself to find the tool. Click the Start Menu button and type "index" into the search box. The Indexing Options tool will appear as one of the choices as you can see in Figure B.

    Figure B

    Indexing Options through search

    Once the Indexing Options tool is open (Figure C) you will get a brief synopsis of how many files are currently indexed and where they are located. In most cases, the default settings will be enough because the files most users use over and over will be located in their document folder. E-mail correspondence is the other area where searching comes in handy and that too is covered by default.

    Figure C

    Indexing Options tool default settings

    Clicking the Modify button on the initial screen of the Indexing Options tool will reveal the screen shown in Figure D. In this configuration screen you can use to add or subtract specific files and folders from the search index.

    Figure D

    Indexing Options modifications

    For example, clicking the Show all locations button will add all of the folders on your hard drives to the potential list of indexed locations (Figure E). However, adding all of those locations to the index will increase the size tremendously and likely make the search index useless for quickly and efficiently finding files. Take some time to plan exactly which locations you want to index.

    Figure E

    All locations

    The other configuration option available from the Indexing Options tool (Figure C) is under the Advanced button. You'll need administrative rights to make changes under this button. The Advanced Options screen (Figure F) gives you several more configuration options including the ability to index encrypted files, rebuild the search index, restore to default settings and select a new place to store the index.

    Figure F

    Advanced options

    The File Types tab on the Advanced Options screen is for those who like to get down to the most granular of settings (Figure G). From this screen you can change which files are indexed by their extension. You can even modify how deeply each extension is indexed from this screen. This is definitely an area for users with a clear understanding of how the search index functions and an even clearer idea of how they want their system configured.

    Figure G

    File types under Advanced Options
    Good luck
    Sunday, March 4, 2007 6:40 PM
  • Nice screenshots, but the questions remains unanswered..

    Is there a way to force indexing? In XP there used to be a "Index Now" button...

    I have the same problem as jmoney, it´s been two days and outlook reports 3.500 items still being indexed!!

    On the other hand, the "Indexing Options" window shows 148.023 items indexed and status: "Indexing Complete. "!?
    How is that possible?? Outlook is among the configured locations, as well as all my mailboxes inside, then what is the problem?? Is it just lazy?
    Thursday, May 14, 2009 4:49 PM
  • I have to agree here - I am using the Windows 7 RC with Office Enterprise 2007 - when I go to search something in Outlook, it cannot find anything and tells me indexing is not complete (I have let the PC run for days).  I go to the indexing options and I see it is complete - WTH? One screen tells me it is not done, another tells me it is done.  When I go to a drive that is supposed to be indexed, I get NOTHING in results.

    Is there a way to force Indexing to actually run and start indexing.  I would love to be able to say "Hey start indexing, I am leaving now" hit the button and walk away.  Now I know I hate it when it tries to index while I am using the PC, but it sure would be nice to hit it when I know I am walking away and make it index the things it still has not gotten to yet.
    • Edited by confused2xover Monday, July 13, 2009 10:56 PM it changed a non offensive word to an underline so I had to change the word
    Monday, July 13, 2009 10:54 PM
  • I have the same question as the opening post and I also agree that the question was not answered.  I see that there is a "Pause" button to force the indexing mechanism to stop indexing.  I also notice that the indexing speed may be reduced because of disk activity.  I also see that there are a lot of fun options in the Indexing Options dialog and sub dialogs.  Regardless of all that...

    Is there an explicit option to tell the indexing system to "Index Now" at full capacity, regardless of disk activity?  This feature was in XP and I would like to know if that same feature is in Windows 7, and if so, where to find it.
    Matt Poland - Software Architect
    Friday, November 20, 2009 5:28 PM
  • Restarting the "Windows Search" service will start the indexing proces.
    Wednesday, November 25, 2009 12:07 PM
  • Having the same problem too (W7 64bit). Outlook says 5000 items not indexed and Indexing says Ready ;)
    In the Advanced section there's a Rebuild button, checking it out right now!
    Monday, December 14, 2009 9:01 AM
  • Be careful, clicking Rebuild will toss away all the previous indexing, sending you back to square one.
    I have a Windows 7 Gadget for Indexing, but there is no way that I have found to say "Use all resources and CPU cycles to speed up the Indexing process NOW".
     
    No way to put the Index process into overdrive, you know?
    That would be very handy.

    Friday, December 18, 2009 5:49 PM
  • I'm using this add in for index and search my account in Outlook. With Lookeen you can also add any folder on your system to be included in the search index... As I could experience it fortunately does the indexing in the back not using that much resources. So far it found almost everything I intended to look for :) Maybe worth a look and try... 
    Sunday, December 20, 2009 3:00 PM
  • Having the same problem too (W7 64bit). Outlook says 5000 items not indexed and Indexing says Ready ;)
    In the Advanced section there's a Rebuild button, checking it out right now!

    I'm having exactly the same problem on W7--the indexing service itself claims all indexing is complete, but when I use instant search in Outlook 2007, I'm told indexing still needs to be done--thousands of items need to be indexed, it says--but these items are NEVER indexed.  Obviously, something is not working properly here, and I can't find any way to force Outlook to finish the dang indexing already... very frustrating!
    Thursday, December 31, 2009 5:04 AM
  • Hi, I sit possible to force windows search not to run every time. What I mean, is it possible to scheduel it to run lets say once each wee?

    Thanks
    Tuesday, January 19, 2010 10:18 PM
  • Have you tried to run the 'Re-build' option under Figure F?
    Friday, January 29, 2010 9:33 PM
    • Regarding forcing the indexing..
    • I have 110k messages on my outlook pst folder. And I can never get the files get indexed.
    • I have repaired my pst files several times, copied it to another location, renamed it etc nothing helped. 
    • I've searched internet for days and all I have found so far is the little gadget called "indexer status" http://gallery.live.com/results.aspx?bt=1&q=index%20status . Unfortunately that has not helped either.
    • I'm considering switching back to Vista now from Windows 7 and see if that might help.
    • I'd appreciate if someone manages to come up with a way to force windows index our mails.
    • Thanks in advance.

     

     

    Friday, June 25, 2010 12:40 PM
  • You can do 2 things.

     

    1) You take an external tool which is faster in indexing than Windows (for example Lookeen as PeterZ2409 recommended)

    2) Buy a faster computer ;)

     

    I wish you good luck!

     

     

    Thursday, July 1, 2010 5:56 AM
  • I am finding the same thing. Nothing seems to work. I even installed Office 2010 over the original Office 2007 but the problem remains. The search tool does not work and it claims it is indexing but it never actually completes indexing.
    Wednesday, July 14, 2010 8:08 PM
  • I have a similar issue.  I am using Windows 7 64 with Office 2010 32.  I have over 8gb of MP3s and very few of them show up in search or in Windows media player.  I can open files specificially but they are not in my library and will not show up in search.  Search shows that indexing is complete.  I'll try rebuilding my index to see if this fixes the issue.
    Monday, July 19, 2010 7:06 PM
  •  

    1. Try adding the outlook mail storage file (.PST) in the indexing location

    [i.e. Control Panel -> Indexing Options -> Show all locations - Then select the (.pst) storage folder in the plane above]

     

    2. Make sure that you have selected indexing of .pst files in the "Advanced Options" -> "File Types"

     

    3. Open "GPEDIT.MSC" and browse to;

     

    1. Local Computer Policy
    2. Administrative Templates
    3. Windows Components
    4. Search
    In the right plane look for "Disable indexer backoff". Click to open and set it to Enable.


    This might not be what exactly you were looking for but is an alternative to get the job done sooner. 

     

    Sunday, October 3, 2010 10:35 PM
  • Well 2 years of discussion, and no one has answered this question. It should be a surprise no one knows, but the truth is, it's not anymore. I had assumed it was a simple option, but once again, I was wrong...
    Monday, December 13, 2010 1:59 AM
  • Same problem here.

    How to force indexing go through right ***** now

    Monday, February 14, 2011 6:03 PM
  • This is a not fully tested and finished features for Search from Microsoft side I believe.

    I got 74,386 items indexed in my Windows 7 Ultimate 32bit version with Office 2010.

    I tried few simple phrases both Chinese & English words(Cause I'm Chinese), so far it can found what I instant to look for.

    But my colleague not have such good luck like me, he is using Windows 7 Enterprise 64bit version with Office 2007 face a big problem,

    only few phrase can get successful results since it's a new OS. And he only got 1k items indexed.

    I also tried restart the Windows Search services and rebuild index, no help.

    Compare the indexed items numbers and OS working time, I think this feature will getting better after day and day.

    But I expect Microsoft Techional Engineer can detail how this search founction exactly works, not just told me to try check my spelling or try a different phrase.

     


    scott
    Friday, March 4, 2011 4:59 AM
  • You could try this Win7 gadget: http://gallery.live.com/liveItemDetail.aspx?li=45c441a6-edbc-454d-9262-d264728d6a3a

    Pressing the fast forward button forces indexing and it appears to be working.

     

    Monday, July 11, 2011 5:17 PM
  • I haven't found a way to fix this yet, but I did notice that the search works fine on the computer where I receive my E-Mail. I then copy the PST file to a laptop that is having trouble with the indexing. I believe the way I'm doing this is confusing Outlook. Unfortunately, I MUST do it this way, so I really need a way to force the indexing.
    Tuesday, July 12, 2011 4:56 PM
  • Keywords: Service Windows search, WSD 4.0, Event ID 3100, 0 items indexed

    OS: Vista with SP2

     

    I couldn’t search the emails in Outlook due to Indexing Options: 0 items indexed.

    I have been working on the problem for about 20 hours. Read all the forums and tried so many things.

    Here is the summary:

     

    1. Indexing Options: Delete all indexing places.

    I have deleted all places.

    For the Start menu you have to navigate to C:\ProgramData\Microsoft\Windows\Meni Start.

    For the Internet Explorer you go to IE / Internet Options / Content / AutoComplete / Use Windows Search for better results [http://www.ghacks.net/2011/03/17/disable-indexing-of-internet-explorer-web-history-by-windows-search/]

    If you want to add the Outlook for the Search again and it is not listed, then you have to open Outlook to apear on the browsing list.

     

    2. Indexing Options: Change the place of indexing file

    If you want to test some permission I suggest redirecting indexing files to your own map (ex.: C:\MyIndexFiles)

     

    3. Indexing Options: Reindex the database

    I have also deleted all the files in C:\MyIndexFiles. You have to restart the computer in the safe mode with F8 and be the administrator.

     

    4. Indexing Options: Testing folder in Explorer

    Just add 1 folder for the testing purposes with 10 files.

     

    5. Explorer search options

    Explorer / Tools / Options / tab Search / Don’t use the indexer for searching files

     

    6. Explorer search window

    Explorer / Icon: Tools for search / Search window ... resize it

    Include unindexing, hidden and system files

    Here you can test the search over and over again

     

    7. Service: interact with desktop

    Computer / Manage / Services / Windows Service / Properties / tab Log On / Allow service to interact with desktop ... must be empty (this solve my problem !!!-!!!-!!!-!!!)

    [http://social.msdn.microsoft.com/forums/en-US/windowsdesktopsearchhelp/thread/7f4c7a27-e344-486e-a657-577896e7a37f/]

     

    7. Service: Log on as

    Computer / Manage / Services / Windows Service / Properties / tab Log On

    Use Local System Account. It was recommended to me that leave it on Local System account.

     

    8. Outlook pst: create new

    C:\Users\xy\AppData\Local\Microsoft\Outlook

    We use exchange server so I have deleted the temporary pst file.

     

    9. Clean your disk

    Cleanup tool (Accessories menu > System Tools)

    [http://www.vistax64.com/vista-general/160496-indexing-not-working-properly.html]

     

    10. Service Pack: no deinstall

    Install the SP2. WSD 4.0 is already included in the system, so after installing Vista SP2 you cannot deinstal WSD 4.0.

     

    11. Reinstall WSD 4.0 with Vista SP2

    In registry search for SetupCompletedSuccessfully, change the value to 0 and reboot [http://www.vistax64.com/vista-general/160496-indexing-not-working-properly.html]

     

    12. Indexer status Gadget

    Install it from [http://brandontools.com/files/folders/sidebar_gadgets/entry511.aspx]

     

    13. Check the file Windows.edb

    ###Index path from Indexing Options### \Search\Data\Applications\Windows\Windows.edb

    The file should not be 34 kb, my file size is 1.000.000 KB now.

     

    14. Power options

    Change Plan Settings: make it to High Performance [http://codeka.com/blogs/index.php/2007/07/11/search_stuffed_in_vista]

    Do not hibernate the disk while rebuilding the database. It took me 2 days to rebuild.

     

    15. Speed up the indexing process

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows Search\Gathering Manager\DisableBackoff set the value to 1

    If you can’t edit see the [http://office-watch.com/t/n.aspx?a=596]

     

    16. Basic print screens

    If you want to be familiar here are some print screens at the link of [http://social.technet.microsoft.com/Forums/en-US/itprovistadesktopui/thread/76970267-4121-417d-95af-caf307d6a678/]

     

    17. Set the owner for the service

    In the "Current Owner" text box type the following text in CAPS: SYSTEM. For the details see the [http://codeka.com/blogs/index.php/2007/07/11/search_stuffed_in_vista]

     

    18. Repair tool

    Try the repair tool [http://www.restoreguard.com/p/file-Wuaueng.dll.html?keyword=Wuaueng.dll&cct_info=1|26128|9823937937|55836387|1657090587|e|6534950667|kw|1078072342|g|||&cct_ver=3&cct_bk=wuaueng.dll&gclid=CLmFqbrn5asCFSNItAodgUcRKQ]

     

    19. Microsoft download

    Try to install Windows Search 4.0 for Windows Vista (KB940157)

     

    20. Locate the errors in log file

    Didn’t find it useful but here is anyway: [http://blogs.msdn.com/b/varungupta/archive/2010/06/22/troubleshooting-net-framework-4-install-failures.aspx?PageIndex=4]

     

    21. Add registry permission for the service HKCR\Interface\{4F5385F1-F9A8-4536-9920-93E8D144DBD0} and HKCR\Interface\{89BCB740-6119-101A-BCB7-00DD010655AF}.

    How to install: [http://social.msdn.microsoft.com/forums/en-US/windowsdesktopsearchdevelopment/thread/2c80bbc5-fc92-4eee-8d93-b06d2962c5cd/]

     

    22. Microsoft fixit (Event ID 10)

    Use Microsoft fixed for the fix. [http://support.microsoft.com/default.aspx?scid=kb;en-US;2545227]

     

    23. Check the corrupt file

    C:\Windows\SoftwareDistribution\DataStore\Logs\edb.log

    It was in the event viewer that the file was corrupt. I have deleted the file. I don't know I you can delete it or not.

     

    24. Windows update

    Make all the windows update. Make it 5 times until it says: no more updates available.

     

    25. Check the Event viewer for the red alerts. Try to fix the red alert with the link from the Microsoft. If the page could not be found, browse the web for the ID error.

     

     

    Conclusion:

    I and my colleagues have browsed the net for the "Index service not working”. We didn’t manage to find the solution so I decided to make the full update. After the 3 times update it remained only one red alert in the event viewer (Event ID: 3100). The solution was for the Search service not to interact with the desktop.

    I hope that this will help !!!

     

    Regards

     

    Matjaz

    Monday, October 17, 2011 1:56 PM
  • Thanks Matjaz. I'be been looking for a solution for 2 weeks. Your conclusion - "Windows search service log on-don't interact with the desktop" was all it needed. The system immediately started indexing again. So simple in the end.

    Wednesday, October 19, 2011 8:05 AM
  • I've no trouble with the Index Options panel, but on one of 3 windows 7 installations, I cannot find/open "Windows Search Indexing Status"

    Where is it/what's the name of the executable?

    Friday, August 30, 2013 7:55 PM