locked
IPv6 router advertisement not configurable on Windows 2008 and 2008 R2 servers. RRS feed

  • Question

  • Hello Networking experts,

    I want to configure a windows server to act as a publisher for the IPv6 domain prefix. According to the article Configuring IPv6 with Windows Vista it should be easy. If have choosen the prefix  fd43:b2bc:bc95::/64 (generated based on the computers MAC Address see http://www.kame.net/~suz/gen-ula.html).

    On the server i configured the network like this:

    netsh interface ipv6 add address interface="Local Area Connection" address=fd43:b2bc:bc95::1
    netsh interface ipv6 set interface interface="Local Area Connection" advertise=enabled
    netsh interface ipv6 add route prefix=::/0 interface="Local Area Connection" nexthop=:: publish=Yes
    netsh interface ipv6 add route interface="Local Area Connection" prefix=fd43:b2bc:bc95::/64 publish=yes
    

    On a test machine that work pretty well. However if I try to adapt the configuration to our domain i have the problem that the router advertising remains disabled. I tried it on a Domain Server (no other role installed) and on an other server where the only role installed is "Network Policy and Access Services" with routing and ras running.

    If I dump the configuration I get the following response:

    > netsh interface ipv6 dump
    # ----------------------------------
    # IPv6 Configuration
    # ----------------------------------
    
    pushd interface ipv6
    reset
    add route prefix=fd43:b2bc:bc95::/64 interface="Local Area Connection" nexthop=:: publish=Yes
    add route prefix=::/0 interface="Local Area Connection" nexthop=:: publish=Yes
    set interface interface="Local Area Connection" forwarding=enabled advertise=enabled nud=enabled routerdiscovery=disabled managedaddress=disabled otherstateful=disabled advertisedefaultroute=enabled
    add address interface="Local Area Connection" address=fd43:b2bc:bc95::1
    popd
    
    # End of IPv6 configuration
    
    ... 
    
    

    However  the interface properties is showing the following

    Interface Local Area Connection Parameters
    ----------------------------------------------
    IfLuid    : ethernet_5
    IfIndex    : 11
    State    : connected
    Metric    : 5
    Link MTU    : 1500 bytes
    Reachable Time   : 26000 ms
    Base Reachable Time  : 30000 ms
    Retransmission Interval  : 1000 ms
    DAD Transmits   : 1
    Site Prefix Length   : 64
    Site Id    : 1
    Forwarding    : enabled
    Advertising   : disabled
    Neighbor Discovery   : enabled
    Neighbor Unreachability Detection : enabled
    Router Discovery   : disabled
    Managed Address Configuration : disabled
    Other Stateful Configuration : disabled
    Weak Host Sends   : disabled
    Weak Host Receives   : disabled
    Use Automatic Metric  : enabled
    Ignore Default Routes  : disabled
    Advertised Router Lifetime  : 1800 seconds
    Advertise Default Route  : enabled
    Current Hop Limit   : 0
    Force ARPND Wake up patterns : disabled
    Directed MAC Wake up patterns : disabled
    

    I tried to figure out the differences between my test machine and the designated advertisement server but haven't found any obvious differences. Using procmon didn't help either. Netsh sets the same registry setting on both machines. Of course i tried playing around with other configuration options like forwarding, router discovery and so on. But nothing helped. There must be some other system parameters that prevents a server from adverting. Does anybody know the reason?

    Note: Having the default router advertised or not makes no difference.

    BTW: If asked the question already two years ago i a microsoft newsgroup but nether got a answer. I hoped R2 would fix it but there is no difference between Windows Server 2008 and Windows Server 2008 R2.

    Any help is welcome
       Ralf

    • Edited by Ralias Friday, July 16, 2010 2:54 PM Formatting
    Friday, July 16, 2010 7:40 AM

Answers

  • Hi, I found the solution. It turned out router discovery must be enabled to use advertising, so try

    set int "name" rou=e adv=e

     

    • Marked as answer by Ralias Thursday, August 26, 2010 1:45 PM
    Thursday, August 26, 2010 1:22 PM

All replies

  • Isn't anybody out there who knows the reason? Well I think I have to contact the microsoft support. If they solve the problem I'll report the solution.
    Wednesday, August 4, 2010 10:53 AM
  • Hi, I am facing the same problem as yours.

    About one year ago, I set up a router on a WS2008 RC box and it worked flawlessly. Recently I want to set it on my own Windows 7 computer for my home network. Forwarding can be enabled without a problem and manual configuration gives IPv6 access to other computers, but I just can't get advertising enabled.

    Now I think about it, RAS might be the problem (I have incoming connections set up). Another possibility is Teredo. (It seems Teredo creates tunnels that are bind to a physical interface instead of creating new virtual NICs.)

    Thursday, August 26, 2010 2:24 AM
  • Hi, I found the solution. It turned out router discovery must be enabled to use advertising, so try

    set int "name" rou=e adv=e

     

    • Marked as answer by Ralias Thursday, August 26, 2010 1:45 PM
    Thursday, August 26, 2010 1:22 PM
  • Hi Bill,

    Great! That's the solution. I've tried toggleing routerdiscovery but never together with advertising. So that's all and explains the mystery. Setting routerdiscovery and advertising to enabled with the same command does the job. It's still a mystery why I didn't had the same problem in my test enviornoment but never mind.

    Thank you very much!

    Ralf

    Thursday, August 26, 2010 1:45 PM
  • Hi,

    I think this problem didn't show up on your test machine because router discovery was on by default. This was the case on the first server I configured.

    I turned it off on my laptop's NIC because someone in my company is broadcasting rogue default routes and I totally forgot about this. However the implementation is quite stupid this way.

    Saturday, August 28, 2010 1:45 PM