none
Outlook 2016/Exchange 2010 - keeps prompting for credentials RRS feed

  • Question

  • I have a user, running Outlook 2016, that suddenly is getting prompted for credentials.  This happens a minute or two after launching outlook, and then re-occurs every few minutes.  Outlook has been updated, there are no saved outlook credentials in credential manager, a new profile has been created and the prompts continue.  The strange part is that you don't need to authenticate, you can click cancel, and outlook continues to send and receive mail as normal, then several minutes later, the credential prompt pops up again, cancel and repeat.
    Wednesday, January 10, 2018 4:44 PM

Answers

  • Huzzah!!!! Good ol reddit had the fix

    https://www.reddit.com/r/sysadmin/comments/7pk33j/outlook_2016_password_prompt/

    This man deserves a beer

    The fix is to create the following Registry keys on affected machine:

    Navigate to HKEY_CURRENT_USER\Software\Microsoft\Office\x.0\Outlook\AutoDiscover (x.0 corresponds to the Outlook version: 16.0 = Outlook 2016)

    For Outlook 2016 version 16.0.6741.2017 and later versions, please add the following

    DWORD: ExcludeExplicitO365Endpoint
    value 1

    It looks like Microsoft is forcing 365 login for auto discover. I hope this helps, this problem trashed my day yesterday. Microsoft needs to apply a fix asap.

    Good luck to ya.

    • Proposed as answer by Monkey Brawler Thursday, January 11, 2018 4:23 PM
    • Marked as answer by RDWilderman Thursday, January 18, 2018 4:25 PM
    Thursday, January 11, 2018 4:10 PM

All replies

  • Hi,

    Outlook keeps prompting for password could be caused by several reasons:

    • Outlook is configured to prompt you for credentials
    • Incorrect password cached in credential storage
    • Required Authentication Settings for outgoing server and incoming server
    • Outlook Anywhere is not configured to use NTLM Authentication
    • Corrupt Outlook profile
    • Slow or unstable network connection
    • Antivirus programs
    • Shared calendars

    We have a forum article discussed this issue in detail, please follow the instructions in the article to troubleshoot the issue:

    https://social.technet.microsoft.com/Forums/en-US/bcd2d9c2-1a1b-4446-bf32-69fee8cdf11b/why-does-outlook-keep-prompting-for-password?forum=outlook

    Thanks

    Saurabh


    Please remember to mark the solution as the answer using "Mark as Answer". If you find a solution to be helpful, please use "Vote as Helpful".

    Wednesday, January 10, 2018 6:23 PM
    • Outlook is configured to prompt you for credentials NO
    • Incorrect password cached in credential storage ALREADY ANSWERED
    • Required Authentication Settings for outgoing server and incoming server NO
    • Outlook Anywhere is not configured to use NTLM Authentication NO
    • Corrupt Outlook profile ALREADY ANSWERED
    • Slow or unstable network connection NO
    • Antivirus programs Will check tomorrow
    • Shared calendars NO
    Thursday, January 11, 2018 6:31 AM
  • Hello,

    I have same problem with an Exchange 2013 and Outlook 2016 . Many users have this problem for 2 days.

    When the prompt ask credentials, i saw in credential manager a line outlook.office365.com . Do you check if you have this entry ?

    Benoît

    Thursday, January 11, 2018 9:20 AM
  • Hello,

    Same thing for us since begining of the week, with differents user / organisation. But always Outlook / Exchange.

    Workaround : new Outlook profil.

    If someone got a quicker solution or at least an explanation ?

    Romain

    Thursday, January 11, 2018 10:16 AM
  • Hi Romain,

    Have you the turnaround that I have provided above?

    Please confirm.


    Cheers,

    Saurabh

    Please remember to mark the solution as the answer using "Mark as Answer". If you find a solution to be helpful, please use Vote as Helpful

    Thursday, January 11, 2018 12:45 PM
  • Sorry,

    I forget to mentioned that we have try every step / solution above.

    We suspect an update. But after sevral unsuccesfull test on Outlook side, it's could be a server side update.

    But to heavy to confirm on production enviroment :-(

    Thursday, January 11, 2018 2:38 PM
  • Hi Romain,

    Generally, the type for Exchange Directory is used for sync GAL or OAB information for Exchange account.

    I suggest you can disable Cached Exchange mode in Outlook side to check if the Password prompted issue can be reproduced in Outlook Online mode.

    If there is no issue in Outlook Online mode, I think the issue may be related to the OAB (Offline Address Book) service which is generally used as GAL in Cached Exchange mode. Switch Outlook in Cached mode, go to Send/Recevie tab, click Send/Receive Groups > Download Address Book, click OK. Confirm if there is any error in Outlook Send/Receive Process window.


    Cheers,

    Saurabh

    Please remember to mark the solution as the answer using "Mark as Answer". If you find a solution to be helpful, please use Vote as Helpful

    Thursday, January 11, 2018 3:15 PM
  • Huzzah!!!! Good ol reddit had the fix

    https://www.reddit.com/r/sysadmin/comments/7pk33j/outlook_2016_password_prompt/

    This man deserves a beer

    The fix is to create the following Registry keys on affected machine:

    Navigate to HKEY_CURRENT_USER\Software\Microsoft\Office\x.0\Outlook\AutoDiscover (x.0 corresponds to the Outlook version: 16.0 = Outlook 2016)

    For Outlook 2016 version 16.0.6741.2017 and later versions, please add the following

    DWORD: ExcludeExplicitO365Endpoint
    value 1

    It looks like Microsoft is forcing 365 login for auto discover. I hope this helps, this problem trashed my day yesterday. Microsoft needs to apply a fix asap.

    Good luck to ya.

    • Proposed as answer by Monkey Brawler Thursday, January 11, 2018 4:23 PM
    • Marked as answer by RDWilderman Thursday, January 18, 2018 4:25 PM
    Thursday, January 11, 2018 4:10 PM
  • Hi,
    We have the same issue.  I have two sites:

    1: Exchange 2010 with Win7 & Win10 Mixed clients Office 2016

    2: Exchange 2010 with Win10 client Office 2016

    It "magically" became the same issue this week: users would log into their domain machines, open Outlook and be prompted for logon creds.  Entering their UPN or Windows user name and their correct password wouldn't "save" and cause the dialogue request to "stay away".  If you "answered" it 3-8 times (or you can cancel the prompt, go to "Send/Receive" tab and click the "type Exchange password" button to have it work immediately) it would "accept it" and "Connect to Exchange" but after that it would come back *random* minutes later.

    I also tried clearing out the users Credential Manager passwords with no luck.  I was also personally affected (I'm site #2 ;)

    It appeared after the last "Monthly Channel" update from Microsoft for Office 2016 (Click-To-Run Edition), Version 1711 7230.2175.  May have affected earlier version as well.  I had to roll back to 1710 8625.2139 to make the issue go away.  Any 1711 versions still had the same issue (I originally tried 8730.2127 thinking it was just the Jan 2018 update but that didn't help me).

    So it for us, it was the Office 2016 Update and a roll back to the November 27, 2017 (1710.8625.2139) fixed for us.

    https://support.microsoft.com/en-ca/help/2770432/how-to-revert-to-an-earlier-version-of-office-2013-or-office-2016-clic

    Those instructions with:

    https://support.office.com/en-us/article/Version-and-build-numbers-of-update-channel-releases-ae942449-1fca-4484-898b-a933ea23def7?ui=en-US&rs=en-US&ad=US

    Those versions are what got my client site, and my computer, back up and stable. 

    Hope this helps!

    Tom

    Friday, January 12, 2018 4:49 AM
  • Thanks, I'll have to try that on my PC (which was affected until I rolled back my Office version as a "fix") to see if that works as well!
    Friday, January 12, 2018 4:50 AM
  • Hi, 

    thanks a lot, this solved my problem.

    Regards, 

    Stanley

    Friday, January 12, 2018 7:39 AM
  • Hi,

    Please be free to mark it as answer. if you find contribution useful. That will encourage me - and others - to take time out to help you.


    Cheers,

    Saurabh

    Please remember to mark the solution as the answer using "Mark as Answer". If you find a solution to be helpful, please use Vote as Helpful


    • Edited by Saurabh_Y Friday, January 12, 2018 8:24 AM
    Friday, January 12, 2018 8:24 AM
  • Hi RDWilderman,

    Just checked in to see how everything is going on with the issue? Please feel free to post back if you still need assistance on this.

    Best regards,
    Yuki Sun


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.


    Click here to learn more. Visit the dedicated forum to share, explore and talk to experts about Microsoft Teams.

    Monday, January 15, 2018 8:59 AM
    Moderator
  • Thanks! You are my hero
    Monday, January 15, 2018 1:03 PM
  • Worked for me too!
    Monday, January 15, 2018 4:35 PM
  • Thanks for this, if anyone is looking for a quick script to do this 

    Set-ItemProperty -Path "HKCU:\Software\Microsoft\Office\16.0\Outlook\AutoDiscover" -Name 'ExcludeExplicitO365Endpoint' -Value 1 -Type DWORD -Force

    Wednesday, January 17, 2018 1:37 AM
  • Thanks for this, if anyone is looking for a quick script to do this 

    Set-ItemProperty -Path "HKCU:\Software\Microsoft\Office\16.0\Outlook\AutoDiscover" -Name 'ExcludeExplicitO365Endpoint' -Value 1 -Type DWORD -Force

    Or command line:

    reg add HKEY_CURRENT_USER\Software\Microsoft\Office\x.0\Outlook\AutoDiscover /t REG_DWORD /v ExcludeExplicitO365Endpoint /d 1 

    Thursday, January 18, 2018 4:06 PM
  • another solution is to redirect two dns entries in the local hosts file (or local DNS Server) to 127.0.0.1

    127.0.0.1 autodiscover-s.outlook.com
    127.0.0.1 outlook.office365.com

    • Proposed as answer by Mind IT Wednesday, November 14, 2018 6:56 PM
    Thursday, January 18, 2018 5:51 PM
  • Hi all,

    If anyone that has worked around the issue by setting the AutoD reg key ExcludeExplicitO365Endpoint and is willing to work with support to investigate to get to root cause please let me know.  I am checking with the Outlook Team if they are detecting any issues from the service but will probably need client logging to be able to submit a bug for it.

    Friday, January 19, 2018 12:31 AM
  • Thanks for the fix, the reg entry was all we needed (so far?).

    Roy W.

    Friday, January 19, 2018 9:52 PM
  • Hi all,

    So far we have found that the auth prompt issue can occur when there is an Office 365 consumer account e.g. Outlook.com in the Outlook profile.  If any of you who ran into this can confirm that please let me know. Or, if you don't have an Outlook.com account but have other consumer or O365 services connected under File, Account, Connected Services that would be helpful to know too.  We will get the bug fixed I just want to make sure we are capturing all the scenarios.

    Friday, January 19, 2018 10:59 PM
  • Hi all,

    The Outlook Team has made a service side change to fix the issue.  If you see any new reports please ask users to restart the Outlook client to pick up the change.  For any new reports please do not use the registry key to address it.



    Saturday, January 20, 2018 2:45 AM
  • Hi Gabriel,

    I just found myself in same situation. Please note, that this happened on brand new, freshly installed win10 machine, right after I installed newest office 365. Apparently "change to fix" is not working well...

    Tuesday, March 13, 2018 8:23 AM
  • Pavel,

    What version of Outlook are you running?  Click File, Office Account, Version and Build?

    Do you have an MSA Microsoft Account that matches your on prem email address configured to sign into or activate Office?  I think this was the scenario we saw before but want to double check specifically?  

    If you set this registry key does it mitigate the issue:

    HKEY_CURRENT_USER\Software\Microsoft\Office\16.0\Outlook\AutoDiscover

    DWORD: ExcludeExplicitO365Endpoint
    value 1

    Tuesday, March 13, 2018 2:25 PM
  • we are having exactly the same issue here but on Outlook 2016 AND Outlook 2010!!!  both fresh installs with all updates through WSUS

    Outlook 2016:  16.0.4.266.1001

    That registry fix does not resolve our issue.

    if you click cancel you can use outlook as normal, conencted fine. but next time open outlook again wants user/pass. have to cancel 3 times then carry on.....

    Wednesday, March 14, 2018 3:48 PM
  • Solution is not working.  
    Thursday, April 19, 2018 5:57 PM
  • I am able to wipe the OST file from the host and then outlook with operate just fine.  Close down outlook and you are prompted for a password that even if it is valid will not connect.  All reg key hacks do not address or fix.  Sad and frustrated that I have to downgrade all workstations back to 2010 because of this.
    Thursday, April 19, 2018 5:59 PM
  • I'd Just thought I'd add my 'solution'

    I had a client that had this when using an imap account to an email host which started happening on one PC, but then after a day happened to another of their PCs.  After spending several hours trying the fixes suggested, I spoke to the hosting company to see if they had made any changes...

    They had blocked the client's public IP address for too many failed attempts - note the client could still access webmail, just not from outlook.  Once the block had been removed the popups stopped. 

    Monday, April 23, 2018 12:36 PM
  • Thanks for the response adhguy.  I have gone through the ringer on this, and all recommended solutions are not working.  I am on version 16.0.4.266.1001 as well with no option to update or patch.  On prem Exchange 2016 is patched to CU9.  I have confirmed that all accounts we have are doing this action, on any pc, even the domain admin.  Confirmed there are no permissions issues with the OST file (added everyone with full control to test).  It doubt that the hundreds of dollars to open an MS case will resolve.
    Tuesday, April 24, 2018 3:07 PM
  • Hi,

    I stumbled upon this issue with eternal login prompts for Windows Outlook clients with cached mode showing up where Mapi over HTTP was enabled first time, a O365 hybrid solution since earlier with no issues.
    Solving the issue for me was changing the authentication settings {Ntlm, OAuth} for /mapi virtual directory to Negotiate.
    Set-MapiVirtualDirectory -Identity "CAS\mapi (Default Web Site)" -InternalUrl https://CAS.contoso.com/mapi -IISAuthenticationMethods Negotiate
    Run iisreset afterwards on affected CAS servers.

    Monday, May 7, 2018 9:16 AM
  • Not working for me either.   I have both GMail and Hotmail on my Outlook.  It will. not. accept.  my GMail login password.   Incredibly annoying.  Will this bug be fixed soon?  I'm just using my GMail on the web.

    Cheers,

    Connie

    Monday, June 11, 2018 9:43 PM
  • I WAS SEARCHING FOR A SOLUTION FOR 3 HOURS AND I STUMBLED UPON THIS. Thank you! You are the man. If I could give you an award, I would!!
    Wednesday, June 13, 2018 4:51 AM
  • Solved it for me, too!  I deleted my credentials in Credential Manager and that only worked temporarily.
    Wednesday, June 13, 2018 2:03 PM
  • We only started to experience the issue about three weeks ago.  When my son returned, he was able to fix the problem by resetting/reconfiguring autodiscover the SBS201 server.

    Saturday, August 25, 2018 12:17 AM
  • Thanks Monkey Brawler,

    You're a lifesaver. Have added to GP and will see what happens next restart of PC's/Laptops. This started with two PC's and like a typical MS tsunami, spread like a virus across the domain.

    Office365 has to be one of the most under developed Suites out there and frequently causes us in IT to get grey hair prematurely.

    I'm extremely glad that you posted this as the thread would have been the typical one filled with the usual time wasting answers from Microsoft.


    SOS Computer Services Pty Ltd

    Monday, August 27, 2018 11:40 PM
  • Hi Gabriel,

    7 months after the supposed FIX by your Outlook team and we started getting it last week. Have put the REG key in place until MS finally fix it. Happening with both Windows 7 Pro and 10 Pro.


    SOS Computer Services Pty Ltd

    Monday, August 27, 2018 11:46 PM
  • Graeme,

    Can you please share specifics of the issue and I will check if we are getting any other reports or if we can repro.  Do you have an MSA Microsoft Account that matches the on prem email address configured to sign into or activate Office?  If not what are the repro details?

    Was the mitigation the reg key?

    If you set this registry key does it mitigate the issue:

    HKEY_CURRENT_USER\Software\Microsoft\Office\16.0\Outlook\AutoDiscover

    DWORD: ExcludeExplicitO365Endpoint
    value 1

    Tuesday, August 28, 2018 2:13 PM
  • Hi

    I have the same exact problem.  Outlook 2016 with exchange 2010.

    The registry fix doesn't work.  Outlook 2016 has all the patches.

    What should I do?

    Thursday, September 6, 2018 3:58 PM
  • Me to, have tried every fix I've seen on the web, nothing works.
    Wednesday, September 12, 2018 12:04 PM
  • same problem here since today !!

    Exchange 2016

    Outlook 2016

    Friday, October 12, 2018 1:24 PM
  • I had this issue on a Windows 10 PC and the problem ended up being Windows 10 changed the default mail program to "Mail" instead of "Outlook" after an update. I changed it back and rebooted and everything started working correctly.
    Friday, October 12, 2018 4:15 PM
  • Finally!!
    Wednesday, October 24, 2018 8:05 PM
  • +1 for Rick_Stinson's hosts file fix. Reg key didn't work, and while Windows had made Mail the default putting it back to Outlook didn't resolve, but the hosts file did fortunately. Procmon showed loads connections to various .msn.net IP addresses, some of which pointed to those two host addresses.
    Thursday, October 25, 2018 2:55 PM
  • Hi Gabriel, as an FYI we have an environment with Exchange 2010 on premises with users using Office 365 Business license for Office Software and recently encountered the same issues.

    Clearing Credentials in Credential Manager, new Outlook Profiles, new Windows Profiles - none provided a long term fix. In some cases switching to Online Mode for the Outlook profile was successful, but this is not a great solution for mobile users.

    finally found this thread and a few similar and implemented the registry fix which successfully solved the issue.

    just wanted to give you as much detail as possible.

    we'll be migrating to Exchange 2016 very shortly to as an fyi.

    Tuesday, November 6, 2018 8:29 PM
  • This issue happened in my job too and we solve it with a single command line: 
    reg add HKEY_CURRENT_USER\Software\Microsoft\Office\16.0\Common\Identity /v DisableADALatopWAMOverride /t reg_dword /d 1 /f
    More details about the solution and issue below:

    https://support.microsoft.com/en-us/help/4025962/cant-sign-in-after-update-to-office-2016-build-16-0-7967-on-windows-10




    Tuesday, November 6, 2018 8:43 PM
  • Environment
    Exchange 2016
    Outlook 2016
    Everything fully patched as of 11.12.18

    This workaround fixed it for me for an existing Outlook profile. Side effect, it breaks the ability to add a new Outlook profile. 

    127.0.0.1 autodiscover-s.outlook.com
    127.0.0.1 outlook.office365.com

    DWORD: ExcludeExplicitO365Endpoint did not help me in this instance.

    Monday, November 12, 2018 10:11 PM
  • Thanks its work.
    Wednesday, November 14, 2018 6:53 PM
  • Hi,

    Working find for us, new problem that we have, how can we do this with an office installed from Microsoft Store. Their is no registry key HKEY_CURRENT_USER\Software\Microsoft\Office ?

    Thank you

    Thursday, December 6, 2018 10:25 AM
  • Champion thank you very much :)  this resolved the credential popup issue

    FYI on premise 2010 Exchange and Office 365 Outlook 2016 local PC

    Wednesday, December 12, 2018 12:47 AM
  • thanks and in case the Autodiscover key is missing is it a case of just manually creating this key
    Friday, January 25, 2019 8:18 PM
  • Thanks !!!

    It works also for Office 2019 !


    FXE

    Thursday, January 31, 2019 9:15 PM
  • This worked for me!  Finally!!  Thanks @MonkeyBrawler  O365 trying to take over the world!
    Tuesday, February 19, 2019 6:12 PM
  • This is my solution. Thanks!
    • Proposed as answer by 80sGirl4Sure Tuesday, May 7, 2019 8:21 PM
    Tuesday, May 7, 2019 8:20 PM
  • Bless your soul, it worked.  This issue nearly drove me to insanity.  5 days now that I had to type in password every couple of seconds.
    Monday, May 27, 2019 10:45 AM
  • Windows 10 Pro Version 1903 Build 18362.175 (64-bit)
    Microsoft Office Professional Plus 2016
    Microsoft Office Outlook Version 1906 (Build 11727.20210 Click-to-Run)
    Product ID: 00351-35024-02208-AA609
    IMAP connections to several Microsoft email accounts.

    Problem: In the last couple of months, Outlook has started prompting for login credentials for some, but not all, Microsoft email accounts I have configured in Outlook. Every time I run Outlook, it prompts for at least one login, sometimes more.

    I always specify "Microsoft apps only" in the login process. I allow the login, then immediately Sign Out. Outlook immediately reminds me that I need to restart to apply privacy settings. Of course, restarting merely ends up with the login prompt(s) again!

    I do not want to use any online Microsoft services in any Microsoft Office product! How can I stop this infuriating behaviour?!

    I have tried several of the remedies noted above and elsewhere.

    In particular, I now have set:
    -- HKCU\Software\Microsoft\Office\16.0\Outlook\AutoDiscover REG_DWORD entries set to the value 1 for:
        . ExcludeHttpsAutoDiscoverDomain
        . ExcludeHttpsRootDomain
        . ExcludeExplicitO365Endpoint
        . PreferLocalXML
        . ExcludeHttpRedirect
        . ExcludeScpLookup
        . ExcludeSrvRecord

    I also have set HKCU\Software\Microsoft\Office\16.0\Common\Identity\DisableADALatopWAMOverride=1

    Why this started after a "normal" Microsoft update is of secondary interest, but the primary goal here is to STOP this EXTREMELY ANNOYING behaviour!

    All help most welcome. Thanks!
    Tuesday, June 25, 2019 2:21 AM