locked
DHCP Management Pack: Module was unable to convert parameter to a double value RRS feed

  • Question

  • Hello;

    I have some trouble with the DHCP management pack (version 6.0.7065.0) as I'm getting the error "Generic Performance Mapper failed execution" => Module was unable to convert parameter to a double value.
    This error occurs on my DHCP servers, which are also domain controllers.
    Found similar issue on http://social.technet.microsoft.com/Forums/en/operationsmanagermgmtpacks/thread/9da3d71d-90ee-48ef-8cef-011b32b011cb in this discussion they suggest changing the regional settings (decimal symbol) to use . and not comma ";"

    My questions:

    -Can we solve this without changing regional settings ?
    -Regional settings are user-related, how do I set those knowing that the agent action account runs as local system ?

    Thanks in advance for your help!

    Kind regards,

    Iliass
    Tuesday, November 10, 2009 12:38 PM

Answers

  • This is a bug in the management pack related to a missing "SetLocale" statement at the top of scripts.  When the server's default local is not using a US english numberic reference, you will get this error.  A work around is to set the server locale to US english and set your user login settings to other locales.  That way the server processes run with the necessary numeric formatting, and via MUI, you get user support for non us-english locale preferences.
    Microsoft Corporation
    • Marked as answer by Iliass Monday, November 16, 2009 11:59 AM
    Saturday, November 14, 2009 1:42 AM

All replies

  • This is a bug in the management pack related to a missing "SetLocale" statement at the top of scripts.  When the server's default local is not using a US english numberic reference, you will get this error.  A work around is to set the server locale to US english and set your user login settings to other locales.  That way the server processes run with the necessary numeric formatting, and via MUI, you get user support for non us-english locale preferences.
    Microsoft Corporation
    • Marked as answer by Iliass Monday, November 16, 2009 11:59 AM
    Saturday, November 14, 2009 1:42 AM
  • Hello,

    thanks for your reply, marking this one as answered!

    KR,

    Iliass
    Monday, November 16, 2009 11:59 AM
  • We are having the same problem.  I have checked the regional settings - it is set to US for local and the decimal is set to . not a ,

    This only started happening since we updated our Domain Controllers / DHCP servers to R2

    Microsoft Windows DHCP 2008 Server MP is 6.0.6452.0
    Microsoft Windows DHCP Server Library is 6.0.6452.0

    Greg
    Wednesday, November 25, 2009 7:32 PM
  • I'm in the same boat as Greg, any ideas?
    Thursday, November 26, 2009 5:18 PM
  • Hello,

    the regional settings are user specific. To solve this issue, I changed the default server locale settings as below:

    HKEY_USERS\DEFAULT\CONTROL PANEL\INTERNATIONAL

     

    sDecimal => change to “.”

    sThousand => change to “,”

    sMONDecimalSep => change to “.”

    sMONThousandSep => change to “,”

     

    Let me know if it helps.

     

    Kind regards

     

    Iliass

     

    Tuesday, December 1, 2009 6:36 PM
  • Hello,

    I have already these settings in place as I am using US English and still I am in the same boat as Greg and Jroger2...
    Microsoft Windows DHCP 2000 Server MP is 6.0.6452.0
    Microsoft Windows DHCP 2003 Server MP is 6.0.6452.0
    Microsoft Windows DHCP 2008 Server MP is 6.0.6452.0
    Microsoft Windows DHCP Server Library is 6.0.6452.0
    all of them seems current...

    Any idea?

    Thanks,
    Dom

    Altiris Support / System Center Configuration Manager Support
    Tuesday, December 15, 2009 7:45 PM
  • Hello;

    I have some trouble with the DHCP management pack (version 6.0.7065.0) as I'm getting the error "Generic Performance Mapper failed execution" => Module was unable to convert parameter to a double value.
    This error occurs on my DHCP servers, which are also domain controllers.
    Found similar issue on http://social.technet.microsoft.com/Forums/en/operationsmanagermgmtpacks/thread/9da3d71d-90ee-48ef-8cef-011b32b011cb in this discussion they suggest changing the regional settings (decimal symbol) to use . and not comma ";"

    My questions:

    -Can we solve this without changing regional settings ?
    -Regional settings are user-related, how do I set those knowing that the agent action account runs as local system ?

    Thanks in advance for your help!

    Kind regards,

    Iliass
    Hello Iliass

    Where did you find this Management Pack 6.0.7065.0 as I downloaded mine today and it is still
    6.0.6452.0? Is it a DHCP MP or an Active Directory MP?

    Thanks,
    Dom
    System Center Operations Manager 2007 / System Center Configuration Manager 2007 R2 Support
    Wednesday, December 30, 2009 1:25 AM
  • Hello,

    apologies for the late answer, I was on holiday... You're right I checked and the latest version (and the one I implemented) is 6.0.6452.0, sorry for the typo


    Kind regards,

    Iliass
    Monday, January 4, 2010 7:56 AM
  • I am in exactly the same position - just upgraded a DC/DHCP server to Windows 2008 R2, and now getting these alerts logged in SCOM 2007 every few minutes.

    If it's a bug, I guess the only option is to ignore it in SCOM...
    Monday, January 25, 2010 4:08 PM
  • Anyone solve this yet? I'm seeing it on one domain controller as well. The registry settings match what Iliass posted above already.
    Wednesday, January 27, 2010 6:11 PM
  • nothing yet for me still floating ...
    System Center Operations Manager 2007 / System Center Configuration Manager 2007 R2 Support
    Wednesday, January 27, 2010 6:35 PM
  • Hello,

    changing the registry values above solved the problem for me, sure you don't have a GPO in place that overwrites the server's default locale ?

    Kind regards,

    Iliass
    Thursday, January 28, 2010 9:21 AM
  • Hello,

    Let me review the registries again to se if there is something not set to English but as it one site only which mono-language I doubt but I will check again

    Thanks,
    Dom
    System Center Operations Manager 2007 / System Center Configuration Manager 2007 R2 Support
    Thursday, January 28, 2010 1:29 PM
  • Hi,

    A few rules of current version of DHCP MP do not work well on Server 2008 R2. There are two options here:

    1.       Disable DHCP MP for Server 2008 R2 computers and wait for a new DHCP MP release for Server 2008 R2

    2.       Disable rules which do not work correctly for Server 2008 R2 computers (other DHCP monitoring  might still work correctly)

    In order to disable DHCP MP for Server 2008 R2 computers:

    1.       Open Operations Console

    2.       Go to Authoring pane->Management Pack Objects->Object Discoveries

    3.       Find “DHCP 2008 Server Discovery”

    4.       Open context menu, Overrides->Disable the Object Discovery->For all objects of another class…

    5.       Type “Server 2008 R2” in look for edit box

    6.       Select “Window Server 2008 R2 Computer”

    Then already discovered objects by this discovery on Server 2008 R2 computers need to be removed. For this cmdlet “Remove-DisabledMonitoringObject” might be used from Operations Manager command shell. Please see this post for more information: http://blogs.technet.com/jonathanalmquist/archive/2008/09/14/remove-disabledmonitoringobject.aspx

     In order to disable rules which generate these events do steps 1-6 but against particular rules/monitors (Microsoft.Windows.DHCPServer.Library.Collect.FreeScopeAddresses, Microsoft.Windows.DHCPServer.Library.Scope.CollectScopeAddressesInUse, etc.).

     Thanks,

    Zaki

    Monday, February 1, 2010 1:36 AM
  • Any update on the availability of the new DHCP MP for 2008 R2?  The workaround stops all the errors, but the ability to monitor DHCP scopes is not there.  An update of the progress being made on the new MP would be helpful.
    Wednesday, March 10, 2010 10:06 PM