none
Can not Access Public Folders Exchange 2003/2007 RRS feed

  • Question

  • Greetings All

    I am Exchange 2003 and 2007 in a mixed environment with multiple forestest that uses linked accounts that connect to Exchange.  Recently we had an issue where the AD accounts for the linked mailboxes were deleted.  After they were restored the users started getting access denied when trying to access the public folders.  This happens in OWA and in the Outlook 2010 client.  In Owa users get: "Outlook Web Access 2007 cannot open this folder.  If the problem continues, contact technical support for your oranization"

    On the client users get: "Cannot display the folder. Microsoft Outlook cannot access the specified folder location.  This folder cannot be opened because there is a configuration problem on the server.  Contact your Microsoft Exchange Administrator for Assistance."

    When I try to add a user to the folder in Outlook I get:  "Changes to the distrbution list membership could not be saved.  You do not have sufficient permission to perform this operation on the object." 

    If there is more information that is needed please let me know.  My Exchange 2003 knowlege is limited as well is my knowlege of Public Folders.  Thanks.

    Tuesday, April 21, 2015 6:45 PM

Answers

  • Hi,

    Please confirm whether the issue only happens to these users who have linked mailboxes and are restored from backup recently. How about other users?

    Also check whether other Exchange features can work for linked mailbox or not. Please provide more information about your environment, such as where the public folder database is located, on Exchange 2003 or 2007? Please check the Public Folder permission and the master account for linked mailbox:
    Get-Mailbox user | select LinkedMasterAccount

    Get-MailboxPermission -Identity linkedMailbox

    Regards,


    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    Winnie Liang
    TechNet Community Support

    Wednesday, April 22, 2015 11:20 AM
    Moderator

All replies

  • Hi,

    Please confirm whether the issue only happens to these users who have linked mailboxes and are restored from backup recently. How about other users?

    Also check whether other Exchange features can work for linked mailbox or not. Please provide more information about your environment, such as where the public folder database is located, on Exchange 2003 or 2007? Please check the Public Folder permission and the master account for linked mailbox:
    Get-Mailbox user | select LinkedMasterAccount

    Get-MailboxPermission -Identity linkedMailbox

    Regards,


    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    Winnie Liang
    TechNet Community Support

    Wednesday, April 22, 2015 11:20 AM
    Moderator
  • Hi thank you for your reply.

    This issue is happening only to users who have linked accounts.  We host 2003/2007 mailbox dbs for other organizations.  They have their own AD domain but link back to us for mail support.  The accounts in question are on Exchange 2003.  The users are able to access theire email through Outlook client.  They are also able to get into OWA and activesnyc is still working.  Just not Public Folders. 

    Seems like the master account would be a good place to start.  How do I check that on an Exchange 2003 box?

    Wednesday, April 22, 2015 8:31 PM