none
User can't install Java Add-in - "untrusted publisher" RRS feed

  • Question

  • An end-user is having this problem.  He has a laptop running Win7 x64 Enterprise.  He's trying to open a link to an AS400 'session' (we have a page for all users to choose a 3270 or 5250 session for their geographical location).  He can't access it (neither can I when logged in under my account); he gets a dialog window stating that IE9 (32-bit) - first - needs a Java Virtual Machine; you click OK and then it says it can't install the add-in as the publisher is untrusted.  A quick search found that the fix is straight-forward - however, it didn't work.

    Since then I've tried the following:

    • Uninstalled & reinstalled Java (using a 3rd-party tool to scrub traces from the registry and user profiles). 
    • Scrubbed out all temp files.
    • Cleared the IE9 SSL state.
    • Tried it without add-ons running.
    • Reset IE9 to default settings.
    • Ran GPUPDATE /FORCE and reboot.
    • Opened Certificate Manager in a console on his machine and ensured it had the company certs in the right locations.  Also deleted all date-expired certs.
    • Ensured it was current with updates.

    Several hours work over 2 days remoted in has gotten me nowhere.  What might I be missing?



    Mike

    south-central Nebraska


    • Edited by RV2011 Friday, April 5, 2013 3:34 PM clarification on error message
    Friday, April 5, 2013 3:20 PM

Answers

  • Hi,

    In Internet Options, switch to Security tab and click Custom Level and set the following items to “Prompt” an see if it works:

    Download unsigned ActiveX Control

    Initialize and script ActiveX controls not mark as safe

    Thanks.

    Nicholas Li
    TechNet Community Support

    • Marked as answer by RV2011 Tuesday, April 9, 2013 1:02 PM
    Tuesday, April 9, 2013 11:18 AM
    Moderator

All replies

  • I used Lync 2010 to speak with him and share the whitreboard with screen-captures of my Java Control Panel, IE9 Add-ons, and Internet Options pages - we match in all of them.

    A real 'head-scratcher'.



    Mike

    south-central Nebraska

    Friday, April 5, 2013 6:20 PM
  • Hi,

    In Internet Options, switch to Security tab and click Custom Level and set the following items to “Prompt” an see if it works:

    Download unsigned ActiveX Control

    Initialize and script ActiveX controls not mark as safe

    Thanks.

    Nicholas Li
    TechNet Community Support

    • Marked as answer by RV2011 Tuesday, April 9, 2013 1:02 PM
    Tuesday, April 9, 2013 11:18 AM
    Moderator
  • I think this will work, but I had to refer the user to a near-by on-site tech for a re-image.  The issue had gone on too long.


    Mike

    south-central Nebraska

    Tuesday, April 9, 2013 1:03 PM