none
Windows 2016 Integration Services

    Question

  • Hi,

    I've migrated a Windows 2008 R2 and Windows 2012 R2 servers to my Windows 2016 Data Center Host server. 
    I'm currently having some challenges updating IS on this 2 servers even after I patch them and both of them are already version 6.3.9600.18907.

    Appreciate any help on this one.

    Thanks,
    Monday, July 9, 2018 11:23 PM

All replies

  • What problems? Integration services updates are now presented via windows update. This one may also help.

    https://support.microsoft.com/en-us/help/3063109/hyper-v-integration-components-update-for-windows-virtual-machines

     

     



    Regards, Dave Patrick ....
    Microsoft Certified Professional
    Microsoft MVP [Windows Server] Datacenter Management

    Disclaimer: This posting is provided "AS IS" with no warranties or guarantees, and confers no rights.


    Tuesday, July 10, 2018 12:04 AM
  • Hi,

    I agree with Dave.

    There is a article for you


    FAQ: Windows Server 2016 and Hyper-V Integration Services

    https://rlevchenko.com/2017/02/18/faq-windows-server-2016-and-hyper-v-integration-services/

    Please Note: Since the web site is not hosted by Microsoft, the link may change without notice. Microsoft does not guarantee the accuracy of this information.
    Best Regards,

    Frank


    Please remember to mark the replies as an answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com

    Tuesday, July 10, 2018 5:48 AM
  • Hi Dave,

    My issue is that I'm still getting "Update Required" on my IS. As mentioned in my original post im already using the latest version of IS and I've used windows update to update it.

    Also, I've read the link you provided.

    Thanks,

    Tuesday, July 10, 2018 1:57 PM
  • Hi Frank,

    I've already read this one and it did not help. I'm using the latest IS version (18907) and I'm still getting "Update Required".

    Thanks,

    Tuesday, July 10, 2018 1:59 PM
  • Hi,

    I think I know I know why I'm getting this error. I was using the hyper-v module 1.1 and it's bug on the Hyper V module.

    thanks,

    Tuesday, July 10, 2018 3:48 PM
  • Hi,

    If you resolve it using your own solution,please "mark it as answer" to help other community members find the helpful reply quickly.


    Best Regards,
    Frank


    Please remember to mark the replies as an answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com

    Wednesday, July 11, 2018 5:37 AM
  • Hi,

    I think I know I know why I'm getting this error. I was using the hyper-v module 1.1 and it's bug on the Hyper V module.

    thanks,


    What do you mean by Hyper-V module 1.1? How to I find the Hyper-V module version?
    Thursday, July 12, 2018 2:42 PM