locked
Lync - Calls drop 30 seconds after 2nd Transfer RRS feed

  • Question

  • I have a small Lync setup 1 FE server with a Backend/Monitoring server and no Edge server that is integrated to Exchange 2010 SP1 and uses a Dialogic DMG2000 series media gateway with the newest (Lync Certified) firmware.  I'm migrating from a similar sized OCS R2 topology that used the same gateway.  The problem I am having is that when an inbound call is transfered for the second time (Either [Exchange AA > User > User] or [User > User > User]) the call with drop every time 30 (32) seconds after the 3 party picks the call up.  The gateway records a "0x0180 - Encoding Error" error and I see a "GatewayCall SignalingState is disconnected, reason is: Timeout" in the mediation server logs that occurs roughly 30 seconds after a "SIP/2.0 500 Server Internal Error (Ms-client-diagnostics: 52130;reason="The internal transaction state does not match")"

    I have searched up and down for days and am getting absolutely no where.  Anyone have any ideas?

    Friday, January 28, 2011 1:58 PM

Answers

  • You could try with REFER disabled so that call transfer is entirely done by Lync. Next step would be tracing SIP messages using Logging Tool.


    Johann Deutinger | MCTS Exchange 2007/2010 / OCS 2007 | ucblog.deutinger.de
    • Marked as answer by RCCHULUOTA Monday, January 31, 2011 7:20 PM
    Friday, January 28, 2011 9:35 PM
  • If you look at Lync documentation (the big help file) you will find a description of Set-CsTrunkConfiguration. There is a parameter called "EnableSessionTimer". You can also disable REFER without setting those other parameters to FALSE; in that case you will not get media bypass.

    Please propose/mark answers if you think they answer your questions :-)


    Johann Deutinger | MCTS Exchange 2007/2010 / OCS 2007 | ucblog.deutinger.de
    • Marked as answer by RCCHULUOTA Monday, January 31, 2011 7:21 PM
    Monday, January 31, 2011 7:17 PM

All replies

  • You could try with REFER disabled so that call transfer is entirely done by Lync. Next step would be tracing SIP messages using Logging Tool.


    Johann Deutinger | MCTS Exchange 2007/2010 / OCS 2007 | ucblog.deutinger.de
    • Marked as answer by RCCHULUOTA Monday, January 31, 2011 7:20 PM
    Friday, January 28, 2011 9:35 PM
  • OK, I've disabled REFER support and it seems to be working correctly now.  Now I have a second question... inorder to disable REFER support you have to set both RTCPActiveCalls and RTCPCallsOnHold to FALSE.  When setting these in PowerShell, I received the following warning "WARNING: When RTCP active calls or RTCP calls on hold is false, it is recommended that you enable session timer to periodically verify that the call is still active."  The problem is, I can't find any information on enabling the referenced session timer.  Any chance someone can point me in the right direction? ; )

    Monday, January 31, 2011 7:10 PM
  • If you look at Lync documentation (the big help file) you will find a description of Set-CsTrunkConfiguration. There is a parameter called "EnableSessionTimer". You can also disable REFER without setting those other parameters to FALSE; in that case you will not get media bypass.

    Please propose/mark answers if you think they answer your questions :-)


    Johann Deutinger | MCTS Exchange 2007/2010 / OCS 2007 | ucblog.deutinger.de
    • Marked as answer by RCCHULUOTA Monday, January 31, 2011 7:21 PM
    Monday, January 31, 2011 7:17 PM
  • Thank you!  If it were a snake, I'd be dead right now with how close it was sitting there in that help file!  Thanks again!
    Monday, January 31, 2011 7:20 PM