locked
Windows 7, problems with indexing, defender etc. RRS feed

  • Question

  • Well this is probably a hartd core case. I bought a new HP Pavilion 7 (intel core i7) with Windows 7 I have a several problems:

    I can't search in libraries

    I can't start indexing

    I cant start defender

    I can't start Windows updater

    I have tried all suggested solutions for each of the problems that can be found on the Internet. I have also tried to do a factory restore but the problem persists.

    If I go to libraries I can see that the location is unresponsive. If I try to start indexing troubleshooter i get an error message: A problem is preventing  the troubleshooter from starting. In advanced it says restricted. Error code 0x8ES0247

    If I go to services and try to start the services manually i get a number of error messages. If necessary I can describe each of them but it seems to be a fundamantal problem

    So please what is wrong?

     

    Friday, August 27, 2010 5:53 PM

Answers

  • Hi,

     

    Regarding the problem, I would like to propose the following suggestions:

     

    1.     Check the following services and ensure that they are all started automatically.

     

    Cryptographic Services

    Windows Search Service

     

    2.     Rebuild the Index.

     

    1)    Open the Control Panel.

    2)    In the Instant Search box, type Index.

    3)    Click on Indexing Options.

    4)    Click on Run as Administrator and allow the privileges.

    5)    Click on Advanced, then Rebuild.

     

    3 Uninstall and reinstall Windows Search Feature.

     

    1)    Click Start and type: features in the Start Search box.

    2)    Click on “Turn Windows Features on or off” and open it.

    3)    Uncheck the box in front of Windows Search.

    4)    Restart the machine.

    5)    Delete the folder: C:\ProgramData\Microsoft\Search.

    6)    Then repeat step 1) and 2).

    7)    Re-check the box in front of Windows Search.

    8)    Restart the machine again.

     

    Now see if the index works correctly.

     

    If the issue persists, please continue the step.

     

    3.     Modify the following registry and change the value data.

     

    1)    Press Win + R keys to open a run box.

    2)    Type: regedit and press Enter.

    3)    Navigate to the following path:

     

    HKEY_LOCAL_MACHINE\Software\Microsoft\WindowsSearch\SetupCompletedSuccessfuly

     

    4)    Change the value to 0.

    5)    Restart the machine.

     

    Best Regards

    Dale


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. ”
    • Marked as answer by Dale Qiao Thursday, September 2, 2010 9:25 AM
    Monday, August 30, 2010 5:25 AM
  • Try this procedure which will let Windows try to repair any missing or incorrect files:

    1 - Type cmd into the Start menu, then press Ctrl-Shift-Enter. This opens the Command window as an administrator.

    2 - In the Command Prompt window, type sfc /scannow 

    This begins the System File Checker process, which can take some time.  After it has finished, try rebooting and then check if the issue persists.

     

    - Malware can cause issues such as the one you describe.  I recommend using Security Essentials, a AntiVirus and Anti-Spyware/Malware system from Microsoft, available for free from http://microsoft.com/security_essentials.  Note that Windows Defender cannot detect viruses, so this program provides a higher level of protection that the default system tools alone.

    If the issues persist, I would recommend making a backup of important data, re-installing Windows, and then installing security tools (such as Security Essentials) before the system experiences issues.

     


    If this was helpful, please vote by clicking the green triangle. If it solves the issue, click Propose as Answer. Thanks!
    • Marked as answer by Dale Qiao Thursday, September 2, 2010 9:25 AM
    Monday, August 30, 2010 2:13 PM

All replies

  • Done some more investigation. When I look at the event log I find that there is a problem with the cryptographic services:

    The Cryptographic Services service failed to initialize the Catalog Database. The ESENT error was: -583.

    I also get a number of error messages concerning the search function like this:

    The Windows Search Service cannot open the Jet property store.

    Details:

    0x%08x (0x8004117f - The content index server cannot update or access information because of a database error. Stop and restart the search service. If the problem persists, reset and recrawl the content index. In some cases it may be necessary to delete and recreate the content index. (HRESULT : 0x8004117f))

    and this:

    The Windows Search Service has failed to create the new search index. Internal error <4, 0x8004117f, Failed to add project: C:\ProgramData\Microsoft\Search\Data\Applications\Windows\Projects>.

    For windows defender i get error messages like:

    The Windows Defender service terminated with the following error:

    %%-1906441657

    I hope somebody can make sense of this and tell me how I can save my laptop ;-)

    Saturday, August 28, 2010 4:53 AM
  • Hi,

     

    Regarding the problem, I would like to propose the following suggestions:

     

    1.     Check the following services and ensure that they are all started automatically.

     

    Cryptographic Services

    Windows Search Service

     

    2.     Rebuild the Index.

     

    1)    Open the Control Panel.

    2)    In the Instant Search box, type Index.

    3)    Click on Indexing Options.

    4)    Click on Run as Administrator and allow the privileges.

    5)    Click on Advanced, then Rebuild.

     

    3 Uninstall and reinstall Windows Search Feature.

     

    1)    Click Start and type: features in the Start Search box.

    2)    Click on “Turn Windows Features on or off” and open it.

    3)    Uncheck the box in front of Windows Search.

    4)    Restart the machine.

    5)    Delete the folder: C:\ProgramData\Microsoft\Search.

    6)    Then repeat step 1) and 2).

    7)    Re-check the box in front of Windows Search.

    8)    Restart the machine again.

     

    Now see if the index works correctly.

     

    If the issue persists, please continue the step.

     

    3.     Modify the following registry and change the value data.

     

    1)    Press Win + R keys to open a run box.

    2)    Type: regedit and press Enter.

    3)    Navigate to the following path:

     

    HKEY_LOCAL_MACHINE\Software\Microsoft\WindowsSearch\SetupCompletedSuccessfuly

     

    4)    Change the value to 0.

    5)    Restart the machine.

     

    Best Regards

    Dale


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. ”
    • Marked as answer by Dale Qiao Thursday, September 2, 2010 9:25 AM
    Monday, August 30, 2010 5:25 AM
  • Try this procedure which will let Windows try to repair any missing or incorrect files:

    1 - Type cmd into the Start menu, then press Ctrl-Shift-Enter. This opens the Command window as an administrator.

    2 - In the Command Prompt window, type sfc /scannow 

    This begins the System File Checker process, which can take some time.  After it has finished, try rebooting and then check if the issue persists.

     

    - Malware can cause issues such as the one you describe.  I recommend using Security Essentials, a AntiVirus and Anti-Spyware/Malware system from Microsoft, available for free from http://microsoft.com/security_essentials.  Note that Windows Defender cannot detect viruses, so this program provides a higher level of protection that the default system tools alone.

    If the issues persist, I would recommend making a backup of important data, re-installing Windows, and then installing security tools (such as Security Essentials) before the system experiences issues.

     


    If this was helpful, please vote by clicking the green triangle. If it solves the issue, click Propose as Answer. Thanks!
    • Marked as answer by Dale Qiao Thursday, September 2, 2010 9:25 AM
    Monday, August 30, 2010 2:13 PM
  • 3 Uninstall and reinstall Windows Search Feature.

     

    1)    Click Start and type: features in the Start Search box.

    2)    Click on “Turn Windows Features on or off” and open it.

    3)    Uncheck the box in front of Windows Search.

    4)    Restart the machine.

    5)    Delete the folder: C:\ProgramData\Microsoft\Search.

    6)    Then repeat step 1) and 2).

    7)    Re-check the box in front of Windows Search.

    8)    Restart the machine again.

     

    Now see if the index works correctly.

     

    Hi.  I had the same problem. Turned it all off then rebooted then turned it all on as Dale above recommended.  Indexing and searching are now back on at last.  This was a real headache for me.  I wonder how many million people switched over to google desktop when this happened to them.

    Thanks Dale.

    • Proposed as answer by barjammar Tuesday, February 8, 2011 3:28 PM
    Tuesday, February 8, 2011 3:28 PM
  • post is old but this is still the correct answer - still works a year later even AFTER a fresh install of win 7 ultimate! i believe the root cause is a permission issue on the C:\ProgramData\Microsoft\Search folder. turn off indexing, reboot, take ownership of the folder, delete it, will reappear without the lock, turn indexing back on - all is well.
    Saturday, October 29, 2011 12:35 AM
  • Found solution:

    download and install 'intel rapid storage technology' from the following site.

    http://h10025.www1.hp.com/ewfrf/wc/document?docname=c02219204&cc=nl&lc=en&dlc=en&product

    Not entirely sure why it worked, but reading other peoples problems it seems to work if you have/ have had a problem with your hard drive, or have installed a new one.

    This is also possibly where my problem originated from as I did have my hard drive repaired a few months back- it is likely I was unaware of the problem with windows update and defender for a while after.

    Certainly give it a try, nothing else came close to solving the problem, whereas this worked straight away.

    • Proposed as answer by TechDivision Thursday, April 11, 2013 4:08 PM
    Wednesday, December 19, 2012 6:54 PM
  • Big thanks to RAF Palomino for posting here!!!

    You can save yourself a lot of time by running the Intel RST (Rapid Store Technology) driver from the link he posted. That is the ultimate, and ONLY, fix! After migrating to a new Samsung 1TB HDD from a 160GB drive, all the issues referenced above by MikeTZ and thruout multiple threads, such as: Win Search, Defender, Win Update, CAPI2 log errors, were all present on my system.  As F5 Tornado mentions above, it's mainly manifested as a serious permissions issue thruout the machine, probably due to a Windows database(s) corruption of sorts, and despite having elevated levels of permissions, you can't apply any of the fixes to registry, folders or run high-level cmd level utilities. Hence, my comment on saving time...

    Cut to the chase and apply Mr. Palomino's suggestion from the link provided, and you'll be glad you did! :)

    FWIW: my IRTS version prior to update was: 9.5.4.1001.  The update bumps it up to 9.5.6.1001.

    US Link here:  http://h10025.www1.hp.com/ewfrf/wc/document?docname=c02219204&cc=us&destPage=document&lc=en&product=&tmp_docname=c02219204

    Sunday, April 21, 2013 1:34 PM
  • Many thanks!

    Updating the Intel RST driver worked for me also.

    Similar situation to what others have reported here. Had recently upgraded from a 320MB to a 1TB C: drive, and a few weeks later realized that Windows Search and Windows Update were no longer working and the services could not be started. Above errors posted in the Application log when I tried (0x8004117f and Jet property store). Registry okay. sfc/scannow did not fix it. Deinstalling and reinstalling Windows Search did not fix it.

    Have a Dell computer, but got the Intel driver from an HP site (probably should have searched it out on Intel's site, but the HP download worked fine).

    Tuesday, December 10, 2013 5:34 PM
  • thank you so much.

    this solution worked for me.

    download and install 'intel rapid storage technology' from the following site.

    http://h10025.www1.hp.com/ewfrf/wc/document?docname=c02219204&cc=nl&lc=en&dlc=en&product


    windows search service is now running!!!!

    Bill


    • Edited by wchuang_67 Sunday, February 16, 2014 1:50 AM
    Saturday, February 15, 2014 11:20 PM