locked
virtual directory not being configured as an application in IIS RRS feed

  • Question

  • Hi,

    I am gettng forrlowing error,

    It is an error to use a section registered as allowDefinition='MachineToApplication' beyond application level. This error can be caused by a virtual directory not being configured as an application in IIS. (C:\Program Files\Common Files\Microsoft Shared\Web Server Extensions\12\template\layouts\amex_engagement\web.config line 52).

    I have tried to change the authentication Mode to 'None' in Web.config.

    I have even tried to recreate the application name in Application settings in IIS,but still error is the same.

    i am using the workflow solution built in some other machine and pasted on my machine

    kindly help

     

     

    • Moved by Mike Walsh FIN Tuesday, March 29, 2011 8:05 AM Not a general question. Moving to admin which seems more appropriate than workflow (From:SharePoint - General Question and Answers and Discussion (pre-SharePoint 2010))
    Tuesday, March 29, 2011 6:40 AM

Answers

  • Hi ReemaBeban,

     

    Please make sure that the directory from where your website is running is configured as an application is IIS. To do this, you need to go into IIS and find your project folder on the server, right click to Properties Under Application Settings click Create.

     

    Thanks & Regards,

    Peng Lei

    • Marked as answer by David HM Monday, April 4, 2011 8:05 AM
    Wednesday, March 30, 2011 8:29 AM