locked
Domain admin seeing "Managed by your systems administrator" RRS feed

  • Question

  • We have a new domain admin doing manual updates from WSUS after patch Tuesday and when he goes to the Windows Update gui on server 2012 R2 he sees 

    You receive updates: Managed by your systems administrator

    There is no option for Check for Updates or Install updates. Oddly, this is only on member servers. He is able to update Domain Controllers. The GPO settings on the servers and domain conrtrollers are identical.

    Windows Components/Windows Update
    Policy Setting Comment


    Enabled
    Configure automatic updating: 3 - Auto download and notify for install
    The following settings are only required and applicable if 4 is selected.
    Install during automatic maintenance  
    Scheduled install day: 1 - Every Sunday
    Scheduled install time: 03:00
    Install updates for other Microsoft products  
    Policy Setting Comment
    Set the intranet update service for detecting updates: http://wsusserver:8530
    Set the intranet statistics server: http://wsusserver:8530

    I do see I can modify the NoWindowsUpdate from 1 to 0 in the User hive which fixes it but I really don't want to do this on 50+ servers.

    What can cause this behavior? I don't see anything in gpresults /h that points me to the culprit. Any easy way to resolve?


    • Edited by mtnman1000 Monday, November 28, 2016 1:59 PM
    Monday, November 28, 2016 1:58 PM

Answers

  • Sounds to me there is a GPO setting that limits/denies you from using Windows Update. Try using Resultant Set of Policy (Group Policy Modeling) to check which GPO setting is causing this issue.

    Boudewijn Plomp | Conclusion FIT

    Please remember, if you see a post that helped you please click "Vote as Helpful", and if it answered your question, please click "Mark as Answer". This posting is provided "AS IS" with no warranties, and confers no rights.

    • Marked as answer by mtnman1000 Tuesday, November 29, 2016 11:24 AM
    Monday, November 28, 2016 11:39 PM
  • Hi mtnman,

    >I do see I can modify the NoWindowsUpdate from 1 to 0 in the User hive which fixes it but I really don't want to do this on 50+ servers.

    You may run gpresult /h on the computer to check which GPOs are applied on the computer and check if you can find the related GPO modifying the registry key.

    Best Regards,

    Anne


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    • Marked as answer by mtnman1000 Tuesday, November 29, 2016 11:24 AM
    Tuesday, November 29, 2016 7:24 AM

All replies

  • Sounds to me there is a GPO setting that limits/denies you from using Windows Update. Try using Resultant Set of Policy (Group Policy Modeling) to check which GPO setting is causing this issue.

    Boudewijn Plomp | Conclusion FIT

    Please remember, if you see a post that helped you please click "Vote as Helpful", and if it answered your question, please click "Mark as Answer". This posting is provided "AS IS" with no warranties, and confers no rights.

    • Marked as answer by mtnman1000 Tuesday, November 29, 2016 11:24 AM
    Monday, November 28, 2016 11:39 PM
  • Hi mtnman,

    >I do see I can modify the NoWindowsUpdate from 1 to 0 in the User hive which fixes it but I really don't want to do this on 50+ servers.

    You may run gpresult /h on the computer to check which GPOs are applied on the computer and check if you can find the related GPO modifying the registry key.

    Best Regards,

    Anne


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    • Marked as answer by mtnman1000 Tuesday, November 29, 2016 11:24 AM
    Tuesday, November 29, 2016 7:24 AM
  • Although I had done that, I missed the offending setting to disable Windows update. There was another GPO for domain admins that enabled it but it was not applying due to delegation settings. Once that was corrected, all is well. 

    Thanks

    Tuesday, November 29, 2016 11:27 AM