none
Disable the BDE Partition

    Question

  • How do you disable the BDE partition from being created with a Lite Touch Windows 2008R2 deployment?  I dont want to create the 300MB drive for Bitlocker and can not figure out how to get rid of it.

    Any help would be appreciated...

    Thanks,
    Joe
    Wednesday, March 3, 2010 5:36 PM

All replies

  •  Add 'DoNotCreateExtraPartition=YES'  in the CustomSettings.ini
    • Proposed as answer by SyNaX Sunday, September 1, 2013 4:46 PM
    Wednesday, March 3, 2010 5:45 PM
  • I did that with no luck.  Here is my customsettings.ini

    [Settings]
    Priority=Default
    Properties=MyCustomProperty
    DeploymentType=NEWCOMPUTER

    [Default]
    OSInstall=Y
    DeploymentType=NEWCOMPUTER
    SkipAppsOnUpgrade=YES
    SkipCapture=YES
    SkipAdminPassword=YES
    SkipProductKey=YES
    DoNotCreateExtraPartition=Yes
    SkipBitlocker=YES
    BDERequired=NO
    SkipBitLockerDetails=YES
    SkipDomainMembership=YES

    Wednesday, March 3, 2010 6:51 PM
  • try disabling the bitlocker task in general in your ts
    -D

    -Dustin
    Wednesday, March 3, 2010 6:57 PM
  • I tried that as well.  It is disabled.

    Wednesday, March 3, 2010 6:59 PM
  • Are you sure you are using the correct customsettings.ini
    Check the log te ensure that it reads the correct customsettings.ini
    Update the deployment share.
    Wednesday, March 3, 2010 7:02 PM
  • I am using the one in "\depoyment\control".  I have also updated the share with no luck.

    Where can I find the log file at?

    Thanks,...
    Wednesday, March 3, 2010 7:10 PM
  • It should be under c:\minint\smsosd\osdlogs. Look for the Bdd.log file if possible post your log here hand we can try see whats happening.

    If you dont find it on C:\ you may need to start the deployment again. In Windows PE the logs will initially be on the X:\ but will be moved to the C:\ once the drive is partitioned and formated.
    Wednesday, March 3, 2010 7:16 PM
  • try

    DoNotCreateExtraPartition=YES

    instead of

    DoNotCreateExtraPartition=Yes


    --> MDT Help says: Caution   This property value must be specified in uppercase so that the deployment scripts can read it properly.
    Wednesday, March 3, 2010 7:27 PM
  • Well spotted Robert I did not see he had it in lower case

    That should do the trick
    Wednesday, March 3, 2010 7:30 PM
  • Thanks.  I am trying it now.  I will update once I am done.
    Wednesday, March 3, 2010 7:51 PM
  • Made the change to using all caps, and it still didn't work. 

    Any other suggestions? 

    Thanks for all your help.
    Thursday, March 4, 2010 2:00 PM
  • Then we will need to see the log it should be on c:\minint\smsosd\osdlogs\bdd.log
    Thursday, March 4, 2010 8:51 PM
  • The parameter is "CASE SENSITIVE". It's like this:

    DoNotCreateExtraPartition=YES

    And run an "update" to the deployment share after the change.
    Friday, March 5, 2010 6:02 PM
  • Appears looking through the code that DoNotCreateExtraPatition is *not* case sensitive.
    So we need to see the bdd.log file to see what ZTIDiskPart is doing.
    Can you upload the log file to a public location?


    Keith Garner (KeithGa.com) - Deployment Consultant - http://deployment.XtremeConsulting.com
    Friday, March 5, 2010 10:27 PM
    Moderator
  • I will be more than happy to upload it. 

    Where should I upload it to?
    Tuesday, March 9, 2010 2:17 PM
  • I know this may sound silly but thought i would ask as sometimes we forget these steps:

    edit the customsettings.ini file, update the deployementshare, and if using WDS replace the current boot image with the updated one?

    In your bdd.log file you want to look for this line:

    DiskPart>Create Partition Primary Size=300

    That's your system partition that the setting above is supposed to get rid of.

    Also check this line in your log to make sure the proper customsettings.ini is being used:

    Using DEFAULT VALUE: Ini file = \\yourserver\share\customsettings.ini

    Tuesday, March 9, 2010 7:11 PM
  • I will be more than happy to upload it. 

    Where should I upload it to?

    You can paste the log here
    Wednesday, March 10, 2010 8:35 AM
  • So what have you found, and why do you say that you have to update the storage when changing in customsettings.ini...you dont have todo that..

     


    RDP customer
    Thursday, May 6, 2010 12:50 PM
  • I set the settings and it worked like a charm, no problems
    RDP customer
    Friday, May 7, 2010 11:07 AM
  • What exactly did you do to get it working? I have the problem you describe and have done the same steps but the partition is still being created.
    Tuesday, August 24, 2010 11:38 PM
  • snip from my customsettings.ini

    and I dont get the extrapartitions with this. But in remark to this, we only creat MBR disks. So on new hardware, ex IBM that uses UEFI and want to have GPT disks we have enforced to use MBR anyway. We do this by renaming the file bootmgfw.efi under RemoteInstall\Boot\x64. Then the server cannot boot into UEFI PXE and it will not enforce GPT disks..Sorry..this is another topic but can be related to extra partitions..

    [Default]

    SkipAdminPassword=YES

    SkipApplications=YES

    SkipAppsOnUpgrade=YES

    SkipBDDWelcome=YES

    SkipBitLocker=YES

    SkipCapture=YES

    SkipComputerName=YES

    SkipComputerBackup=YES

    SkipDeploymentType=YES

    SkipDomainMembership=YES

    SkipFinalSummary=YES

    SkipLocaleSelection=YES

    SkipPackageDisplay=YES

    SkipProductKey=YES

    SkipSummary=YES

    SkipTaskSequence=YES

    SkipTimeZone=YES

    SkipUserData=Yes

    SkipFinalSummary=YES

    DoNotCreateExtraPartition=YES

    FinishAction=REBOOT


    RDP customer
    Wednesday, September 22, 2010 12:08 PM
  • I have the exact issue you resolved with disabling the bootmgfw.efi... I have Lenovo 1578H3U desktops.  How did you disable it?  MDTK 2012 keeps using a GPT partition even though I am telling it to use a MBR.  When it does this the system can't boot unless I use a boot dvd which I start my image with and then it gets to Windows no problem and everything is great from there.  I tried using EASYBCD to fix it but no good.   Every once in a while it does use a MBR partition and everything works perfectly.  Where is that path you mentioned? 


    Eric Laughery System Administrator

    Tuesday, May 8, 2012 7:17 PM
  • If MDT is creating a GPT disk, it is detecting that the computer has booted in UEFI mode.  If this isn't what you want, you will need to turn off UEFI in the computer's BIOS, or choose a non-UEFI boot option when booting the computer.


    Thanks, -Michael Niehaus Senior Program Manager, Microsoft Deployment Toolkit mniehaus@microsoft.com http://blogs.technet.com/mniehaus

    Wednesday, May 9, 2012 4:04 AM
  • every bios is different but you should switch the pci rom priority from efi compatible to legacy
    Wednesday, May 9, 2012 8:15 AM
  • I contacted Lenovo and they are telling me there is no way to disable UEFI within the BIOS.  I don't see anything either.  I'm really ok with using UEFI if it would boot.  But, it won't boot unless I use one of my boot disks I created with MDTK.  Since it looks like I can't do anything about disabling the UEFI maybe I should concentrate my efforts getting my image to boot with GPT.  Do you have any ideas why the boot files aren't being created?

    Eric Laughery System Administrator

    Friday, May 25, 2012 9:09 PM
  • I didn't see this option in my BIOS so I contacted Lenovo and they told me it can't be disabled.  Any other ideas?

    Eric Laughery System Administrator

    Friday, May 25, 2012 9:09 PM
  • Additonal interesting facts...  I can install Windows 7 and Windows 8 and it automatically installs NTFS with MBR just like it's supposed to.  I can't turn off UEFI with GPT in the BIOS.  Is there a 3rd party BIOS I can reinstall over Lenovo's?  There just has to be a way to overide MDTK and force it to only use MBR regardless of what it detects.  If I could get it to boot I would be ok with GPT but the bootloader is not referencing the OS.  I tried to use EASYBCD but it won't work.  Does anyone have any ideas?

    Eric Laughery System Administrator

    Wednesday, June 6, 2012 4:51 PM