locked
hardcoded user profile path issue in Media Encoder CS6 RRS feed

  • Question

  • Hi guys,

    Does anyone have an idea how to get around this issue.

    Media Encoder CS6 sequenced as part of Captivate 6. Both run fine except.

    Error on exit of Media Encoder was traced wtih procmon to be attempting a write operation to c:/users/myusername_adminaccountusedforsequencing/appdata/roaming/Adobe/adobe media encoder/6.0

    this folder is inaccessible to the standard test user account, when I create this folder structure and give the standard user access to it, two xml files are created there and there is no more error.

    It seems there is a hardcoded path being used which is somehow not being redirected by App-V.  Any idea how I can get around this?

    Many thanks for your time,

    Sean.A

    Monday, January 7, 2013 5:17 PM

Answers

  • Hi Sean,

    I was able to sequence it successfully.I have added the issue and resolution in my blog appvtech.blogspot.com/2013/01/sequencing-adobe-captivate-6_8.html. Let me know if the issue still persists.

    • Proposed as answer by znack Tuesday, January 8, 2013 1:36 PM
    • Marked as answer by Aaron.ParkerModerator Wednesday, August 7, 2013 9:42 PM
    Tuesday, January 8, 2013 10:26 AM
  • If you have the folders inside the virtual bubble then its good no need to add again. Please follow the steps as given below:

    1) Go to virtual file system tab under package configuration wizard --> CSIDL_APPDATA-->Adobe-->Adobe Media Encoder--> Right click on folders and all the sub folders Mark it as "override". But when u right click on 6.0 folder it will be grayed out as the package configuration wizard does'nt allow you to enable "override" options, so to enable this please follow step 2.

    2) Go to Files tab under package configuration wizard and make sure you enable the "override" option for the 6.0 folder. The check box is in the extreme right corner.

    Hope this solves!!!!!

    • Proposed as answer by znack Tuesday, January 8, 2013 1:36 PM
    • Marked as answer by Aaron.ParkerModerator Wednesday, August 7, 2013 9:42 PM
    Tuesday, January 8, 2013 12:23 PM

All replies

  • Hi,

    Can you try to add these folders inside the virtual bubble with the two xml files and then try to test with a user account?

    Tuesday, January 8, 2013 2:16 AM
  • Hi,

    This morning I checked inside the bubble, the folder structure with the two xml files are already present. I tried to add a new folder structure under my user profile folder as above but the sequencer says it cannot add it as it is already in the sequence. It is trying to add it in the variablised folder structure, it won't let me add a fixed folder.

    Regards,

    Sean

    Tuesday, January 8, 2013 9:54 AM
  • You'll need to find where the paths are stored - most likely in an XML or INI file. You may need to create a script that executes an launch to edit those paths.


    Please remember to click "Mark as Answer" or "Vote as Helpful" on the post that answers your question (or click "Unmark as Answer" if a marked post does not actually answer your question). This can be beneficial to other community members reading the thread.


    This forum post is my own opinion and does not necessarily reflect the opinion or view of my employer, Microsoft, its employees, or other MVPs.

    Twitter: @stealthpuppy | Blog: stealthpuppy.com | The Definitive Guide to Delivering Microsoft Office with App-V

    Tuesday, January 8, 2013 9:54 AM
    Moderator
  • Hi Sean,

    I was able to sequence it successfully.I have added the issue and resolution in my blog appvtech.blogspot.com/2013/01/sequencing-adobe-captivate-6_8.html. Let me know if the issue still persists.

    • Proposed as answer by znack Tuesday, January 8, 2013 1:36 PM
    • Marked as answer by Aaron.ParkerModerator Wednesday, August 7, 2013 9:42 PM
    Tuesday, January 8, 2013 10:26 AM
  • Hi Pavan

    Your solution does not show how to add these files to the virtual file system, the sequencer will not allow it as it sees it as the %appdata% folder and says it is already present.

    Hi Aaron, thanks for this guidance I will try find the xml or ini where it has this hardcoded path.

    Cheers,

    Sean.


    • Edited by sean.a Tuesday, January 8, 2013 11:18 AM
    Tuesday, January 8, 2013 11:18 AM
  • If you have the folders inside the virtual bubble then its good no need to add again. Please follow the steps as given below:

    1) Go to virtual file system tab under package configuration wizard --> CSIDL_APPDATA-->Adobe-->Adobe Media Encoder--> Right click on folders and all the sub folders Mark it as "override". But when u right click on 6.0 folder it will be grayed out as the package configuration wizard does'nt allow you to enable "override" options, so to enable this please follow step 2.

    2) Go to Files tab under package configuration wizard and make sure you enable the "override" option for the 6.0 folder. The check box is in the extreme right corner.

    Hope this solves!!!!!

    • Proposed as answer by znack Tuesday, January 8, 2013 1:36 PM
    • Marked as answer by Aaron.ParkerModerator Wednesday, August 7, 2013 9:42 PM
    Tuesday, January 8, 2013 12:23 PM
  • No Need to add XML files inside the bubble just the folder structures with "Override" options will do the job
    Tuesday, January 8, 2013 12:29 PM