File server Resource Manager Cannot send email


  • I have a fileserver that does not allow emails to be sent when soft quotas are enabled to notify users of their limit they have exceeded.

    the error message is posted below (from the event log).

    Where can I select the user to send emails from?

    A quick search points in the direction something to do with dot net.


    Where can I cange this option? is there another way to do this?

    From within the FSRM console I get the following error.

    File Server Resource Manager
    Failed to send the test e-mail due to the following error: Cannot send the email due to an error. Check the application event log for more information.

    This is the event log error.

    A File Server Resource Manager Service email action could not be run.

    Error-specific details:
       Error: IFsrmEmailExternal::SendMail, 0x8004531c, Mailbox unavailable. The server response was: 5.7.1 Client does not have permissions to send as this sender

    Monday, April 5, 2010 9:31 PM

All replies

  •  I found the issue was a connector problem in exchange I simply diverted the mail server to an appliance within our network for mail filtering.
    Thursday, April 15, 2010 10:37 AM
  • I'm having the same issue, but after looking at the SMTP Receive logs on my Exchange 2007 server, I can see that the server is authenticating as the server's name  mydomain\servername$ and that the Exchange server authenticates that 'user', but then won't let it send any mail.
    Friday, April 16, 2010 7:14 PM
  • Actually I noticed this too. When I tried to run the FRSM service with an AD account. But I restored it to the default account and redirected the emails to our spam filtering device which has its own SMTP server and forwards all mail on the exchange server (connector already there).


    Sunday, April 18, 2010 7:54 AM
  • Unfortunately, that's not really an option for us.  We feel we really shouldn't need another SMTP server in our environment.
    Thursday, April 29, 2010 2:40 PM
  • I have a same problem but haven't found the solution yet.  We have no another mail server on it. It has to retest it.

    Wednesday, May 12, 2010 10:20 AM
  • Solution solved. By create a receive connector with basic authentication only & anonymous permission. The network address will be configured only specified DFS server IP.  Everything works fine !

    Thank you GOD !

    Wednesday, May 12, 2010 10:42 AM