locked
After I change the WSUS default port 8530 to 80. I can't connect to the WSUS console. RRS feed

  • Question

  • I have windows server 2012 r2  installed with WSUS using port 8530 as default.  And I ran the command'C:\Program Files\Update Services\Tools\WSUSutil usecustomwebsite false' . After that the default port has changed from 8530 to 80. UnfortunatelyI found that I can't  connect  to the WSUS console any more .  Only if I reset the IIS  ,I can  connect to the WSUS console again. But it just continued for about one minute.

    Tuesday, December 8, 2015 8:04 AM

Answers

  • port 8530 is the recommended setting (this is also the default).

    I would recommend you leave it on port 8530, unless you need to implement SSL (use 8531 for SSL).

    Only older WSUS defaults to port 80..


    Don [doesn't work for MSFT, and they're probably glad about that ;]

    • Proposed as answer by Steven_Lee0510 Thursday, January 7, 2016 3:24 PM
    • Marked as answer by Steven_Lee0510 Thursday, January 7, 2016 11:08 PM
    Tuesday, December 8, 2015 9:15 AM

All replies

  • and  here is the log

    The WSUS administration console has encountered an unexpected error. This may be a transient error; try restarting the administration console. If this error persists,

    Try removing the persisted preferences for the console by deleting the wsus file under %appdata%\Microsoft\MMC\.

    System.AppDomainUnloadedException -- Attempted to access an unloaded AppDomain.

    Source

    MMCFxCommon

    Stack Trace:

       at Microsoft.ManagementConsole.Internal.ISnapInPlatform.ProcessCommand(Command command)

       at Microsoft.ManagementConsole.NodeSyncManager.OnNodeChanged(Object sender, NodeChangedEventArgs e)

       at Microsoft.ManagementConsole.Node.NodeChangedEventHandler.Invoke(Object sender, NodeChangedEventArgs e)

       at Microsoft.UpdateServices.UI.SnapIn.Scope.BaseScopeNode.ClearActionsPaneActions()

       at Microsoft.UpdateServices.UI.SnapIn.Scope.ServerSummaryScopeNode.ShowUnhandledErrorMessage(ErrorOccurredEventArgs e)

       at System.EventHandler`1.Invoke(Object sender, TEventArgs e)

       at Microsoft.UpdateServices.UI.AdminApiAccess.ErrorManager.ReportUnhandledError(Exception ex, Object errorContext)

       at Microsoft.UpdateServices.UI.SnapIn.Pages.ComputersListPage.GetListScope()

       at Microsoft.UpdateServices.UI.SnapIn.Pages.BaseListPage.RefreshScope()

       at Microsoft.UpdateServices.UI.SnapIn.Pages.BaseListPage.Initialize(FormView thisScope)

    Tuesday, December 8, 2015 8:04 AM
  • port 8530 is the recommended setting (this is also the default).

    I would recommend you leave it on port 8530, unless you need to implement SSL (use 8531 for SSL).

    Only older WSUS defaults to port 80..


    Don [doesn't work for MSFT, and they're probably glad about that ;]

    • Proposed as answer by Steven_Lee0510 Thursday, January 7, 2016 3:24 PM
    • Marked as answer by Steven_Lee0510 Thursday, January 7, 2016 11:08 PM
    Tuesday, December 8, 2015 9:15 AM