none
Trouble with Sharepoint 2010 RRS feed

  • Question

  • HI I have quetstaion about backup sharepoint 2010 .

    os : 2008r2 with last updatest

    Sharepoint 2010

    DB on separate server aliases in sharepoint , version 2008R2 . But after I click in the DPM to alias , dpm return error :

    I look to this link but there no section to thi configuration . I can separate backup DB , Filesystem , or not sharepoint :-(

    thanx for answer

    One or more prerequisites for protecting this data source are missing.
    Ensure that the following prerequisite software is installed on S7000SP01.ds.mfcr.cz, the front-end web servers and all of the back-end computers running SQL Server (including all cluster nodes and mirror partner nodes):

    All Front-end Web servers:
    Windows Server 2008 x64

    All Back-end computers running SQL Server:
    Windows Server 2003 SP1 with Knowledge Base article 940349
    - OR -
    Windows Server 2008

    All Front-end Web servers:
    SharePoint Foundation Server 2010
    -OR-
    Microsoft Office SharePoint Server (MOSS) 2010

    Back-end computers running SQL Server:
    SQL Server 2000 SP4
    - OR -
    SQL Server 2005 SP1
    - OR –
    SQL Server 2008

    Servers hosting a mirrored instance of SQL Server:
    SQL Server 2005 SP1
    - OR –
    SQL Server 2008

    To obtain the required updates, go to http://go.microsoft.com/fwlink/?LinkId=128883



    ID: 31312


    Falcon

    Tuesday, November 6, 2012 2:35 PM

All replies

  • Hi MareK,

    First, you should verify Protected Computer Software Requirements http://technet.microsoft.com/fr-fr/library/ff399140.aspx

    Second, Before you begin to protect your SharePoint farm, did you run  "ConfigureSharepoint.exe" on one of your front-end Web server ?

    ConfigureSharepoint.exe -enableSharepointProtection ?

    ConfigureSharepoint.exe -enableSPSearchProtection ?

    ConfigureSharepoint.exe -ResolveAllSQLAliases ?

    http://technet.microsoft.com/en-us/library/ff399069.aspx

    Stephane


    Please remember to click “Mark as Answer” on the post that helps you. This posting is provided "AS IS" with no warranties. knowledge is valid only if it is shared by All.

    My DPM blog Yet Another DPM Blog

    Tuesday, November 6, 2012 4:32 PM
  • Hi I run this commands :

    ConfigureSharepoint.exe -enableSharepointProtection 
    ConfigureSharepoint.exe -ResolveAllSQLAliases  , this command return no row :-(

    We have only one server for sharepoint and second for database . Which requirement from this file i must use ? i look and there not option for sharepoint 2010 , sql 2008r2 and win 2008r2 

    thanx


    Falcon

    Tuesday, November 6, 2012 8:33 PM
  • Hi Marek,

    To properly configure SQL aliasing setup both 64-bit and 32-bit aliases: http://support.microsoft.com/kb/2543859

    Stephane


    Please remember to click “Mark as Answer” on the post that helps you. This posting is provided "AS IS" with no warranties. knowledge is valid only if it is shared by All.

    My DPM blog Yet Another DPM Blog

    Wednesday, November 7, 2012 9:35 AM
  • I use DPM verion 2012 . I try set this alias for win 32 , but not affect

    Falcon

    Wednesday, November 7, 2012 3:07 PM
  • some solution ?

    Falcon

    Saturday, November 17, 2012 2:08 PM
  • Hi Parek,

    On which server did you setup SQL Aliases ? It should be on WFE where DPM agent is installed  ?

    Did you setup both 32bits & 64bits ?

    Stephane


    Please remember to click “Mark as Answer” on the post that helps you. This posting is provided "AS IS" with no warranties. knowledge is valid only if it is shared by All.

    My DPM blog Yet Another DPM Blog

    Monday, November 19, 2012 3:48 PM
  • Hello,

    I've got exactly the same issue, and it was coming from a missing key into the registry for the SharePoint version

    By adding the key, that has been solved on my backup solution

    Verify that the key below is existing:

    HKLM\SOFTWARE\Microsoft\Shared Tools\Web Server Extensions\14.0

    Key name: Version

    Content: <your SP version> (ex 14.0.0.4762)

    if the key is missing run the PSconfig command on the SP farm or just create manually the missing key

    regards

    Friday, November 23, 2012 11:01 AM