locked
UAG Remote Desktop settings not working RRS feed

  • Question

  • Hi all, I'm having trouble getting a modified rdp file to take effect when creating a predefined Remote Desktop icon on UAG.
    It is configured to to connect to a 2003 Server TS farm to run a 3rd party program but for testing I have been trying o just run notepad/calculator etc

    After reading this: http://technet.microsoft.com/en-us/library/ff607422.aspx 
    I created the C:\Program Files\Microsoft Forefront Unified Access Gateway\common\conf\CustomUpdate\rd-template.txt file with the following content:

    allow desktop composition:i:0
    allow font smoothing:i:1
    alternate shell:s:c:\windows\notepad.exe
    audiocapturemode:i:0
    authentication level:i:0
    autoreconnection enabled:i:1
    compression:i:1
    connection type:i:2
    disable full window drag:i:1
    disable menu anims:i:1
    disable themes:i:1
    disable wallpaper:i:0
    displayconnectionbar:i:1
    enablecredsspsupport:i:0
    negotiate security layer:i:1
    prompt for credentials:i:0
    remoteapplicationmode:i:0
    shell working directory:s:c:\windows

    ...and added a new 'Remote Desktop (Predefined)' application in UAG but it fails to apply the settings from the template file to the connection.
    For example when I connect I get the full desktop and taskbar instead of just the Notepad application.

    I have couple of questions about how RDP customisation works on the UAG:

    Is there something else I need to do to get the application to pick up the settings?

    I intend to make about 30 RD icons on UAG with different settings - Do I have to keep editing the same rd-template.txt file every time I make a new application or can I save them in a structure something like below to get picked up automatically?

    C:\Program Files\Microsoft Forefront Unified Access Gateway\common\conf\CustomUpdate\<uag-app-name>.rd-template.txt

    Many thanks,
    Simon. 

    Wednesday, January 12, 2011 11:47 AM

Answers

  • For example when I connect I get the full desktop and taskbar instead of just the Notepad application.

    You are connecting to a 2003 Terminal Server which does not support RemoteApp so you will not be able to get just the application.  The best you can do is change the RDP file to launch an applicaiton (in the RDP client under Options -> Programs), which will hide the taskbar, but you will always have the desktop window with the application displayed inside it.
    MrShannon | TechNuggets Blog | Concurrency Blogs
    • Proposed as answer by Chris O'Callaghan Wednesday, January 19, 2011 10:30 AM
    • Marked as answer by James Kilner Thursday, February 24, 2011 8:16 AM
    Wednesday, January 19, 2011 10:27 AM

All replies

  • Hello - does anyone know how I can resolve this?
    Tuesday, January 18, 2011 2:10 PM
  • For example when I connect I get the full desktop and taskbar instead of just the Notepad application.

    You are connecting to a 2003 Terminal Server which does not support RemoteApp so you will not be able to get just the application.  The best you can do is change the RDP file to launch an applicaiton (in the RDP client under Options -> Programs), which will hide the taskbar, but you will always have the desktop window with the application displayed inside it.
    MrShannon | TechNuggets Blog | Concurrency Blogs
    • Proposed as answer by Chris O'Callaghan Wednesday, January 19, 2011 10:30 AM
    • Marked as answer by James Kilner Thursday, February 24, 2011 8:16 AM
    Wednesday, January 19, 2011 10:27 AM
  • Hi MrShannon - thanks for your reply.

    The best you can do is change the RDP file to launch an applicaiton (in the RDP client under Options -> Programs), which will hide the taskbar, but you will always have the desktop window with the application displayed inside it.

    That's exactly what I'm trying to do - an RDP connection launched from the UAG to a 2003 server, which shows the desktop and runs an application instead of the explorer shell; Notepad in this example.

    The problem is the parameter needs to be set in the 'alternate shell:s:c:\windows\notepad.exe' line in the rd-template.txt file on the UAG as the user never sees the RDP client to set it manually.

    If I make an rd-template.txt with the settings in my first post and save it as anything.rdp it will connect and run the application instead of the explorer shell as expected but when I use the same template to create the UAG RD application icon it connects OK but launches the explorer shell, not the Notepad application!

    Any further help you can suggest would be much appreciated!

    Thanks.

     

     

     

     

    Thursday, January 20, 2011 2:22 PM
  • Hi,

    Did you get anywhere with regards to structuring the RDP settings so as to not have to delete and re-create the file for each specific change?

    Thanks

    Saturday, February 19, 2011 8:00 PM