none
ECF doesnt ALWAYS save on PDP RRS feed

  • Question

  • I have an ECF on a PDP: Project Status.  For a majority of the time, this ECF saves without issue using the Save button on the Project ribbon.  Sometime, though, some users will revise the text within the Project Status, click Save, and the revision will not Save.  Clicking the Save button multiple times does not resolve the issue.  Clicking the Save button and waiting a few minutes also does not resolve the issue.

    This PDP only has one ECF on it: Project Status.
    the Project Status ECF has these settings:

    Entity: Project
    Type: Text
    Custom Attributes: Multiple lines of text


    -Mike


    Friday, October 16, 2020 11:55 AM

All replies

  • Hi Mike,

    The first thing to check would be the patch level installed on your Project Server. I do remember a similar issue on multi line text custom fields not saved.

    See there : https://social.microsoft.com/Forums/th-TH/334a7d83-5ac0-4b24-a0be-0cad50015e62/project-server-2013-project-details-description-field-is-not-saved?forum=projserv2010setup

    You could also try to delete the PDP and recreate it. It won't delete the custom field neither the data in it, you can just recreate it to see if the issue is due to the PDP.

    Finally I also saw this issue due to a corrupted EPT template. You would eventually check if the issue happens for all projects with a specific EPT and test on another EPT. 


    Hope this helps,


    Guillaume Rouyre, MBA, MVP, P-Seller

    Friday, October 16, 2020 3:26 PM
    Moderator
  • Hi Guillaume,

    Thank you for your reply. I re-created the PDP.  A few users are able to save, while other users are not able to save.  What happens is: The user edits the ECF and clicks Save.  It looks like PWA has saved because the flash of text "Save Completed Successful". But when the user clicks the Red X button "Close", nothing happens.  I watched them click the close button multiple times, and nothing happens.

    Do you know why the Close button (close/check-in button) does not work for some users?


    For the next step, I will ask my IT if they can check the patch levels.


    -Mike

    Thursday, October 29, 2020 12:20 PM