locked
EditDSServer.aspx Timeout after 30 Minutes RRS feed

  • Question

  • I am trying to configure the Profile Synch on SharePoint 2010 in an EXTREMELY large AD domain.  I have gone through all the guides and all appears to work until I try to create my connection.  I enter all the correct info and click Populate Containers and then it greys out to Querying.  Nothing shows in the area below the Querying button and 30 minutes later I will receive the following warning in the event log:

     

    Event code: 3001
    Event message: The request has been aborted.
    Event time: 8/29/2011 3:17:58 PM
    Event time (UTC): 8/29/2011 8:17:58 PM
    Event ID: 4f66ae00c18e4e1b831fbbd8eaabc3ce
    Event sequence: 1316
    Event occurrence: 1
    Event detail code: 0
     
    Application information:
        Application domain: /LM/W3SVC/600301984/ROOT-1-129591191319569032
        Trust level: WSS_Minimal
        Application Virtual Path: /
        Application Path: C:\inetpub\wwwroot\wss\VirtualDirectories\24355\
        Machine name: SPWEBA
     
    Process information:
        Process ID: 4016
        Process name: w3wp.exe
        Account name: DOMAIN\SVC.ACCOUNT
     
    Exception information:
        Exception type: HttpException
        Exception message: Request timed out.
     
    Request information:
        Request URL: http://spweba:15350/_layouts/EditDSServer.aspx?ApplicationID=374a64c8The request has been aborted.Da0beThe request has been aborted.D47e2The request has been aborted.D871fThe request has been aborted.D78d1e26008d4
        Request path: /_layouts/EditDSServer.aspx
        User host address:
        User: DOMAIN\svc.account
        Is authenticated: True
        Authentication Type: NTLM
        Thread account name: DOMAIN\svc.account
     
    Thread information:
        Thread ID: 14
        Thread account name: DOMAIN\svc.account
        Is impersonating: False
        Stack trace:
     
     
    Custom event details:

    The source of the warning is ASP.NET 2.0.50727.0 and the Event ID is 1309.  I have used PowerShell to increase the timeouts outlined in this article: http://social.msdn.microsoft.com/Forums/en-US/sharepoint2010general/thread/69bf9292-5ef6-4049-bc6d-f21807b70469.  I have also tried reloading SP several times, I have created my own UPA service following harber.net guidance. 

    It always times out and gives me the above warning after 30 minutes. I am totally stuck and at a loss after 2 weeks of troubleshooting.


    Tuesday, August 30, 2011 2:16 PM

Answers

  • After spending 8 hours on the phone with Microsoft it turned out the Farm account needed added to the "Pre-Windows 2000 Compatibility Group" as well as granted the "Replicate Directory Changes All" permissions.  This removed the ASP.NET warnings at 30 minutes but still did not populate containers correctly.  This was resolved with the following PowerShell command: Set-SPProfileServiceApplication -Id <GUID> -UseOnlyPreferredDomainController 1.  These two things resolved my issues.  Hope this helps others.
    Thursday, September 1, 2011 3:05 PM

All replies

  • After spending 8 hours on the phone with Microsoft it turned out the Farm account needed added to the "Pre-Windows 2000 Compatibility Group" as well as granted the "Replicate Directory Changes All" permissions.  This removed the ASP.NET warnings at 30 minutes but still did not populate containers correctly.  This was resolved with the following PowerShell command: Set-SPProfileServiceApplication -Id <GUID> -UseOnlyPreferredDomainController 1.  These two things resolved my issues.  Hope this helps others.
    Thursday, September 1, 2011 3:05 PM
  • The powershell command fixed my issue in about 5 minutes.

    Thanks so much for the post!

    Monday, November 21, 2011 9:15 PM
  • Yes !!

    same for me the powershell command "Set-SPProfileServiceApplication -Id <GUID> -UseOnlyPreferredDomainController 1" Fixed my issue.

    I was working on it since 1 day ...

    For me it was related to this issue : 

     User profile synchronization, cannot expand the domain tree

    (cf http://social.msdn.microsoft.com/Forums/en/sharepoint2010general/thread/69bf9292-5ef6-4049-bc6d-f21807b70469)

    Thank you very much !


    Alexandre DAVID

    Friday, April 6, 2012 2:13 PM
  • YEAH, I also had this same issue. A large domain with many sub domains and trees. All my permissions were correct for the sync account, I enabled that attribute for UseOnlyPreferredDomainController and the containers populated within a few seconds. Thanks, I spent days sifting through log files to no avail. This fixed me.

    Set-SPProfileServiceApplication -Id <GUID> -UseOnlyPreferredDomainController 1

    Tuesday, July 17, 2012 2:47 PM