none
In a pickle, cannot re add protection to sources after going to modern storage RRS feed

  • Question

  • I upgraded my server and DPM to 2016.  I had to delete all my dynamic volumes and convert to modern storage with ReFS to get the disk to work with DPM 2016.  Now however I cannot add previously protected sources back into the protection group.  DPM crashes with 917 error.  I CAN add sources I hadn't previously protected though.  I know what's happening but I don't know how to fix it.  DPM has an old reference to the dynamic volume and I can't get rid of it.

    I tried a DPMSync -sync at command prompt, but that didn't fix the situation.  

    What are my options here at this point?

    Tuesday, March 19, 2019 3:02 PM

All replies

  • Hi,

    Could you elaborate a bit more in detail on your upgrade process to DPM 2016?

    You upgraded from DPM 2012 R2 (UR?) to DPM 2016, you mentioned that you "deleted all dynamic volumes", did you delete all data or have any retained data left?

    Did you preserve the protection groups from before? If yes, are those the protection groups you are trying to modify?

    Have you also tried creating new protection groups?

    Could you also provide the following information:

    • DPM build.
    • DPM SQL server version.
    • Event log information from the DPM server.
    • Was the DPM SQL Server upgraded as well?

    Also check the log below for any more clues:

    DPM server log:

    • %ProgramFiles%\Microsoft System Center 2016\DPM\DPM\Temp\MSDMPCurr.errlog


    Best regards,
    Leon


    Blog: https://thesystemcenterblog.com LinkedIn:

    Tuesday, March 19, 2019 4:48 PM
  • I deleted everything off the dynamic volume so I could restore it back to a basic volume and add it into DPM.  This worked.

    I had a protection group but I stopped the protection on it while retaining replicas.  Apparently this is what has DPM hung up because it retains the old dynamic disk location then crashes when it tries to remove it upon adding the items back into a new protection group.

    Yes everything was upgraded when DPM was upgraded, so SQL went to 2017.

    Tuesday, March 19, 2019 5:51 PM
  • DPM 2016 doesn't support SQL Server 2017.

    There is also a procedure to move from legacy storage to modern backup storage. Manually deleting the volumes isn't part of it, DPM does that for you when you remove protection and eventually remove the remaining data.

    I am afraid you are way out of the supported scenarios. Better to reinstall everything and start from scratch.

    • Proposed as answer by Leon Laude Friday, March 29, 2019 10:04 AM
    Wednesday, March 27, 2019 10:44 AM
  • You might expect odd behaviors since SQL Server 2017 is not supported for DPM 2016 as of today.

    I suggest checking the supported configurations prior to any installation/upgrade, here's the list of supported SQL Servers:
    https://docs.microsoft.com/en-us/system-center/dpm/prepare-environment-for-dpm?view=sc-dpm-2016#sql-server-database


    Blog: https://thesystemcenterblog.com LinkedIn:

    • Proposed as answer by Leon Laude Friday, March 29, 2019 10:04 AM
    Wednesday, March 27, 2019 10:59 AM