locked
Multicast problems RRS feed

  • Question

  • We has set up multicast and it technically works successfully, but is way too slow.  We could deploy multiple systems back to back without using multicast in less time than deploying 2 systems simultaneously with multicast enabled.

    The MDT/WDS server is a Hyper-V VM.

    Is there anything that needs to be done on the MDT Hyper-V VM or the Hyper-V host to optimize multicast?

    Does anything need to be done with the boot image to make multicast work better?

    What kinds of network issues would allow multicast to work, but work very slowly compared to unicast on the same network? 

    Thursday, January 5, 2017 12:59 AM

Answers

All replies

  • Frame size could be too small.


    Many questions such as where do I find logs and what logs are interesting are found in: MDT TechNet Forum - FAQ & Getting Started Guide Please take the time to read it. Also if you don't post logs your problem won't be easily solved.

    Thursday, January 5, 2017 7:02 AM
  • My blog post on the subject:

    https://keithga.wordpress.com/2014/04/23/multicasting-with-mdt/


    Keith Garner - Principal Consultant [owner] - http://DeploymentLive.com

    • Marked as answer by Keith GarnerMVP Friday, January 6, 2017 1:47 AM
    • Unmarked as answer by MyGposts Friday, January 6, 2017 2:03 AM
    • Marked as answer by MyGposts Saturday, January 7, 2017 2:12 AM
    Friday, January 6, 2017 1:47 AM
  • Frame size could be too small.


    Many questions such as where do I find logs and what logs are interesting are found in: MDT TechNet Forum - FAQ & Getting Started Guide Please take the time to read it. Also if you don't post logs your problem won't be easily solved.

    Frame size of what is too small?  Where are these settings?

    I found that changing the registry settings on the WDS server at 

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\WDSServer\Providers\WDSMC\Protocol


    TpMaxBandwidth" from 100 to 10 is helping, but I don't know if that's the only issue.
    • Marked as answer by MyGposts Saturday, January 7, 2017 2:12 AM
    Friday, January 6, 2017 2:08 AM
  • This is circular.  You asked this quest 3 years ago which is what Keith's blog post references.  If you want to know what the actual reason is you will get some benefit from looking at a network capture and your WDS server logs.  There is no 100% correct answer without a deep knowledge of your network which is something I have no idea of knowing.

    Many questions such as where do I find logs and what logs are interesting are found in: MDT TechNet Forum - FAQ & Getting Started Guide Please take the time to read it. Also if you don't post logs your problem won't be easily solved.

    Saturday, January 7, 2017 1:39 AM
  • I'm asking what are typical causes of slow multicast.

    I found the "TpMaxBandwidth" registry setting on my own with a search and noticed an improvement when I made that change, but I wanted to find what else might optimize multicast.

    I asked for more detail on what "frame size could be too small" means.  Keith's blog post has no mention of frame size.

    Saturday, January 7, 2017 1:48 AM
  • I probably should have said block size:
    https://social.technet.microsoft.com/Forums/windows/en-US/a9e5291d-4665-4b33-9376-4fcd697f4975/wds-multicast-extremely-slow?forum=winserversetup

    That being said I don't know what will resolve your slowness however:
    https://www.google.com/search?q=wds+multicast+slow


    Many questions such as where do I find logs and what logs are interesting are found in: MDT TechNet Forum - FAQ & Getting Started Guide Please take the time to read it. Also if you don't post logs your problem won't be easily solved.

    • Marked as answer by MyGposts Saturday, January 7, 2017 2:12 AM
    Saturday, January 7, 2017 1:59 AM
  • I wasn't asking someone to resolve the slowness.  I was just asking for examples of things to look for and then the thread was marked as answered too quickly when I still had questions not addressed in link to the blog post.
    • Edited by MyGposts Saturday, January 7, 2017 2:16 AM
    Saturday, January 7, 2017 2:12 AM