none
Trying to execute a VB Script (using VBSEdit - Evaluation) Microsoft Debugger opens automatically RRS feed

  • Question

  • Hello,

    I'm trying to experiment with a Sample VB Script ( as below) and am using the VbsEdit editor.. 

    ' List Local Computer Information


    Set objComputer = CreateObject("Shell.LocalMachine")

    Wscript.Echo "Computer name: " & objComputer.MachineName
    Wscript.Echo "Shutdown allowed: " & objComputer.IsShutdownAllowed
    Wscript.Echo "Friendly UI enabled: " & objComputer.IsFriendlyUIEnabled
    Wscript.Echo "Guest access mode: " & objComputer.IsGuestAccessMode
    Wscript.Echo "Guest account enabled: " & _
        objComputer.IsGuestEnabled(0)
    Wscript.Echo "Multiple users enabled: " & _
        objComputer.IsMultipleUsersEnabled
    Wscript.Echo "Offline files enabled: " & _
        objComputer.IsOfflineFilesEnabled
    Wscript.Echo "Remote connections enabled: " & _
        objComputer.IsRemoteConnectionsEnabled
    Wscript.Echo "Undock enabled: " & objComputer.IsUndockEnabled

    But when I click on 'Start' it opens a Microsoft Debugger Window automatically and renders the program unresponsive with a pop-up window that gives "Switch to" and "Retry" buttons. 

    Also the Output Window contains the errors as below..

    Microsoft (R) Windows Script Host Version 5.8
    Copyright (C) Microsoft Corporation. All rights reserved.

    C:\Users\Manager\AppData\Local\Adersoft\VbsEdit\Temp\OROQTNST.vbs(4, 1) Microsoft VBScript runtime error: ActiveX component can't create object: 'Shell.LocalMachine'


    ***** script completed - exit code: 0 *****

    Screen shot below:

    I'm fairly new to VB Script and also the VbsEdit editor, and this is driving me crazy. Can someone please help suggest a way out?



    SamSV

    Tuesday, September 13, 2016 8:11 PM

Answers

  • The object does not exist on your machine.  It has been removed since Vista.

    VBSEdit has a support forum so you need to post there for help with that product.


    \_(ツ)_/

    • Marked as answer by SamSV Tuesday, September 13, 2016 8:37 PM
    Tuesday, September 13, 2016 8:29 PM

All replies

  • This is not a support forum for that product; sorry.

    You need to ask the author of that tool.


    -- Bill Stewart [Bill_Stewart]

    Tuesday, September 13, 2016 8:13 PM
    Moderator
  • Update: 

    I tried Uninstalling only "Micosoft Debugger" and then re-ran the script in the WScript mode. But receiving the below error now.

    Any clue as to what I might be doing wrong?


    SamSV

    Tuesday, September 13, 2016 8:18 PM
  • The object does not exist on your machine.  It has been removed since Vista.

    VBSEdit has a support forum so you need to post there for help with that product.


    \_(ツ)_/

    • Marked as answer by SamSV Tuesday, September 13, 2016 8:37 PM
    Tuesday, September 13, 2016 8:29 PM
  • This is not a support forum for that product.

    You need to ask the author of that product.


    -- Bill Stewart [Bill_Stewart]

    • Marked as answer by SamSV Tuesday, September 13, 2016 8:37 PM
    • Unmarked as answer by SamSV Tuesday, September 13, 2016 8:37 PM
    Tuesday, September 13, 2016 8:30 PM
    Moderator
  • Sure.. Thank You.

    SamSV

    Tuesday, September 13, 2016 8:37 PM
  • Sure.. Thank You

    SamSV

    Tuesday, September 13, 2016 8:38 PM