locked
Delay in Maximizing the Window RRS feed

  • Question

  • Hello,
     
    I have noticed either in Windows Server 2008 or R2 there is a delay when you click Maximize button or from minimized position to maximized window. Also happens when you try to restore a window from Maximized window.

    What might be the cause? Please help.

    Thanks
    Kris
    Monday, January 19, 2009 9:32 PM

Answers

  • Hello Sainath,

    It happens with all windows. What I have noticed is when I enable Aero theme this problem exsists. DWM.EXE takes quiet a bit of toll on CPU along with other processes. If I do turn off Aero, delay is not seen.
    There is only one user as I have installed OS on my laptop.

    Same issue doesn't exists with Win 7 OS.

    Thanks,
    Krishna
    Tuesday, January 20, 2009 2:28 PM
  • hi kris,

    i have reproduced your scenario and i am unable to repro your problem.

    i have installed aero theme on my server, but i do not see any delay with maximizing or minimizing windows.

    i tried opening 40 windows at one shot in order to see the resource depletion and page file usage , but nothing seems to be getting affected.

    major suspect is the video drivers which is required for your themes to work in expected way, if we have bad display drivers then the problem occurs.

    Remember we are loading vista video drivers on to windows 2008 which is a key point.

    can you check if this issue is occuring in other windows 2008 server ? if so please check the display drivers installed for windows 2008 ?

    Question
    =======

    Is it really required for you to have Aero theme for windows 2008 ? as its a server i would prefer to have default theme



    sainath Windows Driver Development
    Wednesday, January 21, 2009 4:21 AM
    Moderator

All replies

  • hi kris,

    good day...

    this is pretty interesting, but i havent seen users complaining about the issue.

    minimize or maxime the windows depends on shell component which is internally related to shell32.dll and explorer.exe written in win32 programing

    i would like to get the below information

    a) is this happening with safe mode?

    b) is this happening with all the windows you open or only to specific windows ( like explorer etc )

    c) is this happening with specific users / all users ?






    sainath Windows Driver Development
    Tuesday, January 20, 2009 9:18 AM
    Moderator
  • Hello Sainath,

    It happens with all windows. What I have noticed is when I enable Aero theme this problem exsists. DWM.EXE takes quiet a bit of toll on CPU along with other processes. If I do turn off Aero, delay is not seen.
    There is only one user as I have installed OS on my laptop.

    Same issue doesn't exists with Win 7 OS.

    Thanks,
    Krishna
    Tuesday, January 20, 2009 2:28 PM
  •  

    DWM.EXE is the Desktop Window Manager .When you’re using Aero Glass , DWM owns an offscreen bitmap for every open window, the size of the window, with a rendering of that window’s contents.

    DWM needs this so it can quickly show you thumbnails of all the open windows, and so it can do things like composing and animating quickly. But it requires a lot of memory.

    If you can’t afford this much RAM, don’t use the Aero Glass theme

    if you still want to use aero theme on your windows 2008 server, try kill the dwm process and check for the behavior


    sainath Windows Driver Development
    Tuesday, January 20, 2009 3:04 PM
    Moderator
  • I understand the purpose of DWM. The question of RAM doesn't play at all 'coz this behavior is not seen on Win 7 (client) OS on a SAME hardware.  I have a D820 Laptop with 2.33Ghz Core 2 Duo Processor, 4GB of RAM and 512MB of Video RAM. Why should Win 2008 R2 behave differently at least with respect to the issue ;).

    If I switch to Classic theme; behavior is not seen and switch to Aero; brings back the issue. Killing DWM results same behavior.
    Tuesday, January 20, 2009 10:22 PM
  • hi kris,

    i have reproduced your scenario and i am unable to repro your problem.

    i have installed aero theme on my server, but i do not see any delay with maximizing or minimizing windows.

    i tried opening 40 windows at one shot in order to see the resource depletion and page file usage , but nothing seems to be getting affected.

    major suspect is the video drivers which is required for your themes to work in expected way, if we have bad display drivers then the problem occurs.

    Remember we are loading vista video drivers on to windows 2008 which is a key point.

    can you check if this issue is occuring in other windows 2008 server ? if so please check the display drivers installed for windows 2008 ?

    Question
    =======

    Is it really required for you to have Aero theme for windows 2008 ? as its a server i would prefer to have default theme



    sainath Windows Driver Development
    Wednesday, January 21, 2009 4:21 AM
    Moderator
  • sainath,

    I agree like you have suspected video drivers might be cause but interesting point is why Win 7 (client) was able to deliver with no issues? Is there a possibility that Microsoft might release a nVidia drivers for Windows 2008 R2 for older generation video cards like NVS 120M?

    I was able to install on another laptop with Aero running on it works like a charm!!! no delays at all.

    The reason I'm using Aero is I want Win 7 (client) features with Hyper-V  .... to achieve that Win 2008 R2 with Aero enabled.

    Thanks for your help.

    Wednesday, January 21, 2009 4:00 PM