locked
WSUS Patches related to Language Packs do not deploy RRS feed

  • Question

  • Hi,

    I have 4 WSUS patches related to Language Packs that are not deploying to my Windows 2012r2 servers. The patches are
    - KB2839636 (en-US)
    - KB2839636 (fr-FR)
    - KB3012997 (en-US)
    - KB3012997 (fr-FR)

    I've reviewed several other posts on this and they did not resolve my issues but they did pose a lot of questions which I hope I detail here, so here goes.

    I am only concerned with Windows 2012r2.  I am not deploying to any other operating systems yet.

    I am using my Windows 2012 R2 WSUS server (patched to January 2016) as the reference here but my other 10 Windows 2012 R2 servers also have the problem.

    This server and related domain is not connected to the internet. All information is replicated from an internet-connected WSUS server on another domain using a USB hard drive. The Internet-connected WSUS server has various health checks and file verifications run weekly and shows no issues or problems.

    In December 2015, I activated the Language Pack category in WSUS and all language pack updates appeared for the 50 or 60 languages. I approved the patches for en-US and fr-FR (total 4) and declined the remainder.  I wanted the en-US & the fr-FR patches to apply to all of my Windows 2012r2 servers however they did not deploy.

    After some investigation, I figured I should have installed the Language Packs manually so I downloaded the Language Pack iso, extracted the en-US and fr-FR language packs and installed them manually using the lpksetup.exe utility. I checked Language settings in the control panel and both languages are installed and available.

    I tried to redeploy the patches but no success.

    I downloaded the January WSUS patches and deployed them successfully to my servers however the 4 language pack patches still did not deploy.  This shows me that WSUS works but those patches do not deploy for some reason.

    They are marked in WSUS as "needed" which means (I think) that the server requires them because the full language pack was installed manually. I do not want to decline them because I would prefer to have them installed.

    I checked the file information for the 4 patches and it exists on the server.  In the WSUS console, I right click the patch, select file information to list the file location.  I then browse to that location and the file exists.

    I checked the WindowsUpdate.Log which says "4 installable, 166 installed, 0 for everything else" which is what the WSUS console states.

    I checked the SoftwareDistribution.log which indicates that the patches were deployed successfully to the correct server groups.

    I run "Windows Update" manually and it doesn't say that the 4 updates are available but they should be.

    I checked the Installed Updates (from the control panel) and could not find them so they do not appear to be installed at all.

    There are no errors in the event logs related to WSUS.

    Are there any other options? Anything else to check?

    Thank you

    Chris

    Wednesday, January 27, 2016 8:43 PM

All replies

  • Hi Chris,

    >>Anything else to check?

    Have you tried to download the update and install it manually?

    Also, please try to reset the Windows Update Components of the client.

    I'll test these updates on my lab server and update the result to you.

    Best Regards.


    Steven Lee Please remember to mark the replies as answers if they help and unmark them if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    • Proposed as answer by Steven_Lee0510 Monday, February 8, 2016 1:29 PM
    • Unproposed as answer by Steven_Lee0510 Monday, February 8, 2016 1:30 PM
    Thursday, January 28, 2016 3:02 PM