locked
Executing a runbook RRS feed

  • Question

  • All -

    Complete newbie to Scorch.  I have created a simple runbook:

    

    It prompts for a username and a machine name, queries AD, formats the password last set date, and sends an event log entry to a remote system (won't be using in prod - proof of concept).  It works just fine when I run with the Runbook Tester.  However, whenever I click the straight forward "Run" button, nothing happens.  Likewise, when I try to run from the Orchestration Console, it does prompt for the input I need in "Initialize Data", but it then proceeds to do nothing.  What n00b mistake am I making?

    I am also having the same issue with another runbook, which monitors for the output from the send event log message above.  That runbook obviously needs to continuously run, since its first event is monitor event log.  I can't get it working via either method above, but it works when I use the runbook tester.

    Please help!

    Thanks,

    ~Chris

    Monday, October 28, 2013 4:22 PM

All replies

  • If the Runbook is working via Runbook tester but it doesn't work outside that, then most likely is something to do with the 'Orchestrator Service Account' as the Runbook tester uses the account you logged in with while the Orchestrator server uses the service account
    http://www.sc-orchestrator.eu/index.php/scoblog/99-functionality-differences-executing-a-runbook-with-runbook-tester
    http://blogs.technet.com/b/orchestrator/archive/2012/04/30/running-the-runbook-tester-as-another-user.aspx

    Note: I guess you will get more answers as well if you move this question under Orchestrator instead of SCSM.

    Monday, October 28, 2013 4:56 PM
  • Thanks for the links - I will check that out.  Also I didn't even notice I was in the wrong forum =X  Hopefully an admin will come along and move this as needed.  I will post back my results after checking out the service account.

    Thanks!

    Monday, October 28, 2013 5:23 PM
  • I created another thread in the appropriate forum:

    http://social.technet.microsoft.com/Forums/en-US/aac10ba6-3278-4885-9c18-e70c04a582f9/executing-a-runbook?forum=scogeneral

    Anyway - I checked out those links.  That could be my issue, but I will need to figure out how to setup a different service account.  Runbook tester works with my current logon, using run as won't give me any useful results (it can only break).  I don't see how run as will affect the context for the orchestration console or regular run button.

    Monday, October 28, 2013 7:43 PM
  • Resolved my own issue:

    http://windowsarchitecture.wordpress.com/2012/11/28/deployed-runbook-not-running-scorch/

    I still don't know WHY that is an issue, but restarting all the services fixed it.

    Monday, October 28, 2013 8:21 PM