locked
When I sequence application with services - I get "The parameter is incorrect" on the service properties. RRS feed

  • Question

  • I've been having this issue with a couple of different apps but in that case i'm talking about Open Text Document Pipeline Base

    the application has a service that should run in the background all the time.

    I'm using Windows 7 SP1 with App-V 4.6 SP1 Sequencer.

    when I install the application regularly - I can start the service without any problems,

    when I install the application during sequencing , the application installs successfully but  the service could not start.

    when I try to enter the service's properties I get the error message "The parameter is incorrect"
    when I try to start the service I get "service on Local Computer started and then stopped. Some service stop automatically if they have no work to do, for example the  Performance logs and Alert Service"
    if I choose to end the sequencing and open the package on the client side - I still unable to start the service

    things I already try:

    tried it on a completely different sequencer machine

    Sequence the application on XP

    Sequence the application on App-V 4.6

    cancel all the exclusion paths

    checkmark "rebase Dll's"

    add 94 value of * in the registry under HKLM\SOFTWARE\Microsoft\SoftGrid\4.5\SystemGuard\ObjExclusions before sequencing

    export the service settings and import it while sequencing
    http://social.technet.microsoft.com/Forums/en-US/appvgeneralsequencing/thread/57f0131e-cef7-438b-87aa-28e07a27ecf8/

    recreate the service with SC during sequencing
    http://www.logitblog.com/?p=1474

    the application doesn't have license issue, it's only 20-30 MB, there are no COM objects or Shell extensions, the service doesn't have to be prelogon - anyway according to Microsoft documentory there's shouldn't be any limitation that this app won't work with App-V.

    as I said before - I had this issue with other apps as well and just couldn't find the solution, though I could sequence other apps with services and there was no problem. so what do I miss? I cannot get any indication from the App-V Sequencer what bothers it from being sequenced successfully.

    I'de love to get some new ideas how to troubleshoot this application or any other service related application App-V sequence.

    thanks you!


    Tamir Levy

    Monday, July 23, 2012 6:56 AM

Answers

All replies

  • Hello,

    How did you export the service settings and import it while sequencing?


    Nicke Källén | The Knack| Twitter: @Znackattack

    Wednesday, July 25, 2012 6:27 AM
  • Hi Znack. Thanks for you reply.

    What I did was

    1. Installed the software locally and exported the HKLM\System\CurrentControlSet\Services\<servicename> key. to a reg file

    2. Reverted the machine and then installed the software again while the sequencer is running

    3. I tried 2 methods.
         a. imported the the reg file on the machine

         b. deleted the service with SC, created the service with SC (with the parameters I took before I deleted it) and then imported the reg file

    in both of the methods I still couldn't start the service or look the the service's properties ("The Parameter is Incorrect")

    4. on interesting thing I saw which unfortunately doesn't help me as well - I managed to sequence and start the service with AppV 5.0 Beta 2 successfully!

    as I said - it's not the software , it's how the sequencer deals with some application services. maybe it's how the installation of the app registeres the service, though I can't control it.
    I have the exact same issue with 3 completely different apps and completely different environments.

    still looking for ideas.

    thanks


    Tamir Levy

    Sunday, July 29, 2012 9:33 AM
  • Hello,

    Unless the service runs with a service-account - it should start fine. I experienced the same behavior when looking at the properties of the service, but never saw a reason to as they have started without errors anyways.

    Nicke Källén | The Knack| Twitter: @Znackattack

    Monday, July 30, 2012 5:49 AM
  • if it would have run - of course I wouldn't mine about "The parameter is incorrect" error.

    but it's a combination of this and the error of "service on Local Computer started and then stopped. Some service stop automatically if they have no work to do, for example the  Performance logs and Alert Service" when I try to start the service

    it suppose to run with a system account and even if I choose to install it with a different account I still get the same errors.

    I just remind you the fact the there's no problem to install the software and run the service if the sequencer isn't running. so no doubts - the sequencer interrupts the service from running. I just can't seem to exclude what bothers it :/

    I wouldn't mind uploading the MSI for other people to see and try to understand what do we miss.

    I also tried to sequence it with App-V 4.6 SP2 Beta. no luck.

    the only sequencer I was able to sequence it was App-V 5.0 Beta which gives me nothing because I can't run it in my organization


    Tamir Levy

    Monday, July 30, 2012 8:50 AM
  • Hello,

    Sure post it online


    Nicke Källén | The Knack| Twitter: @Znackattack

    Monday, July 30, 2012 9:06 AM
  • Hello,

    Sure post it online


    Nicke Källén | The Knack| Twitter: @Znackattack

    Monday, July 30, 2012 9:07 AM
  • Hi

    the link to download the MSI is https://docs.google.com/open?id=0B-oa3jobei5EZWxEc3A2ampGOUk

    no need for special installation instructions. just click next and see if you're manage to start\stop\view the service either in the Sequencer or the Client.

    the service name is "Archive Spawner"

    AppV 4.6, 4.6 SP1 , 4.6 SP2 Beta - "The Parameter is Incorrect"

    AppV 5.0 Beta - Runs Successfully

    thanks again for your help


    Tamir Levy

    Sunday, August 5, 2012 6:59 AM
  • What is the "Start" registry value of the service? Also, does it require running using DLLHost or SVCHOST?


    Steve Thomas, Senior Consultant, Microsoft

    App-V/MED-V/SCVMM/Server App-V/MDOP/AppCompat

    http://blogs.technet.com/gladiatormsft/
    The App-V Team blog: http://blogs.technet.com/appv/
    The MED-V Team Blog: http://blogs.technet.com/medv
    The SCVMM Team blog: http://blogs.technet.com/scvmm/

    “This posting is provided "AS IS" with no warranties, and confers no rights. User assumes all risks.”

    Monday, August 6, 2012 11:37 PM
  • I don't know the answer for that.

    the service uses a native exe from the installation. the name in the registry is HKLM\System\CurrentControlSet\Services\Spawner


    Tamir Levy

    Tuesday, August 7, 2012 1:06 PM
  • Hello,

    Troubleshooting steps on how I got to know your application;

    http://www.applepie.se/open-text-document-pipeline-base-and-services


    Nicke Källén | The Knack| Twitter: @Znackattack

    Monday, September 3, 2012 8:11 AM
  • Amazing! how didn't I find this post?!

    seems like the service is running following theses steps

    now I just need to check the package functionallity with the developer.

    now I can guess that I might had problems with sequencing other apps because the App-V didn't catch the environment variables that were created while monitoring. and in App-V 5.0 this issue has been fixed so it's an important thing to know

    I'll keep you posted if it actually worked

    Znack,thank you very much for your help so far


    Tamir Levy

    Monday, September 3, 2012 8:54 AM
  • Amazing! how didn't I find this post?!

    Because Znack made the post to answer your question :-)
    Tuesday, September 4, 2012 6:47 AM
  • after a while I got to check it deeply hard,

    I admit it looks like a good process and a good idea and on the Sequencer side if you set the variables with SETX before start sequencing the service does starts, though I still get a message "The Parameter is Incorrect" when I try to double click on it. did you see something about that on procmon? cuz I didn't.
    I wouldn't mind about the error message as long as the service running , but it runs only under the sequencer.

    when I go to the client I side and I try to run the application, if I go to services.msc inside the bible - I can't get the service to run :(
    I tried to set the variables inside the OSD , Locally and both and it still the same result.

    I have another completely different application that acts EXACTLY the same!
    it has a service. if I sequence regularly I get the same error message when I try to run it.
    if I set the application variables before sequencing and then try to run the service it runs (double click still pops "The Parameter is Incorrect"
    nevertheless, when I try to run in with App-V client I can't seem to make the service start in any combination

    now I'm sequencing with 4.6 SP2 (Not the beta)

    I would like to hear your advice. thanks


    Tamir Levy

    Wednesday, November 28, 2012 8:53 AM
  • Hello,

    The primary take away from the article should perhaps not be that you should re-validate that environment variables are set, but you should understand how your application works or not.

    If the service fails via the services.msc, there is probably an underlaying error. I spelled out the steps in the article posted above on howto verify this during sequencing and how I personally did it, I can't see any reason that these steps are still not valid and can at least be attempted on the client side?

    I suggest you re-read the article again


    Nicke Källén | The Knack| Twitter: @Znackattack

    Wednesday, November 28, 2012 10:29 PM
  • I did re-read it.

    You wrote that you saw on the procmon log it tells you it attempts to read the file c:\00SPAWNER.conf.
    when I run procmon I can't seem to find this row (while monitoring), and I'm guessing it would help me to understand also why it cannot start on the client side.

    on the same subject, I think I'm missing something that related to do with services on app-v in general.

    try this:

    on a regular machine create a service for calc.exe. I know it won't start and makes no sense but still:
    SC CREATE CALC BinPath= C:\Windows\system32\calc.exe DisplayName= Calc

    open services.msc and double click on it, you'll see the details of the service like all the others.

    now, do the same thing but from a bubble, doesn't matter of what package
    SFTTRAY /EXE CMD "Package Name"
    SC CREATE CALC BinPath= C:\Windows\system32\calc.exe DisplayName= Calc
    Services.msc

    now when you double click on the service you will get "The Parameter is Incorrect".
    so it the same result and has nothing to do with my application. it's all over App-V area in general. :/


    Tamir Levy

    Thursday, November 29, 2012 5:33 AM
  • Hello,

    Yes, that was one troubleshoot step performed after seeing the error message when manually starting the service.

    Since the concern doesn't seem to be with the service or wether or not it should work, but rather just seeing the properties of it - I suggest you open a call with Microsoft.

    In the article I posted, these are my comments to the error you are experiencing,
    "

    This service is called Archive Spawner – or spawner for short. If opening services.msc and choosing manually to initiate the startup – you get a message that tells you the service started and then stopped again. If attempting to check the properties of the service you would receive another error message with saying this; ”The parameter is incorrect”.

    Obviously – we don’t care about any parameters as the service started – and then stopped. The question here is - why it stopped"


    Nicke Källén | The Knack| Twitter: @Znackattack


    • Edited by znack Thursday, November 29, 2012 12:39 PM
    Thursday, November 29, 2012 10:57 AM