none
Subject: DPM2010 RTM - SMTP required authentication RRS feed

  • Question

  • I'm trying to setup SMTP without authentication however it always returns the
    error ID 2013 logon failure.

    2007 worked fine, can 2010 send alert with anonymous SMTP?

    Wednesday, June 2, 2010 10:01 AM

Answers

  • DPM 2010 supports sending e-mail through both authenticated SMTP servers and unauthenticated SMTP servers.

    To configure DPM to use an SMTP server that does not require authentication you need:

    1. In DPM Administrator Console, on the Action menu, click Options.

    2. In the Options dialog box, on the SMTP Server tab, type the SMTP server name, the SMTP server port, and the e-mail address you want to display in the From box of the e-mail messages that DPM sends.

    3. Enter Username and Password of User who have administrator privileges on the DPM server! Its important!

    http://technet.microsoft.com/en-us/systemcenter/dm/ff399060.aspx

    • Marked as answer by Chris Proud Wednesday, July 7, 2010 8:46 AM
    Wednesday, July 7, 2010 8:34 AM

All replies

  •  

    DPM 2010 requires ALL the fields under the SMTP Server options to be filled in regardless if your SMTP server accepts anonymous connections or not.

    To workaround this issue, enter the domain\username and password under the Authenticated SMPT Server section of the SMTP options page.  The Username and password MUST be for the same user you entered for the "From" address.  If the user does not match, or the settings are incorrect, you will receive the following error:

     

    An Authentication error occured when trying to connect to the SMTP server. (ID: 518)

    You typed an incorrect user name, password, or SMTP server name. Type the correct user name and password to enable e-mail delivery of reports and alerts notifications.

     

    After entering the information in all fields, sending a test message should succeed and you should then be able to receive e-mail reports and notifications if configured.

     

     

     


    Regards, Mike J [MSFT] This posting is provided "AS IS" with no warranties, and confers no rights.
    Wednesday, June 2, 2010 5:42 PM
    Moderator
  • Thanks for your reply Mike.

    What do you do if your SMTP server doesn't support authentication? For example Exchange Edge servers.

    I'm sure this wasn't a requirement of DPM 2007, was it?

    Wednesday, June 2, 2010 6:08 PM
  • This was definitely not a requirement in DPM 2007.  Will this be fixed in an upcoming hotfix or service pack?

    My organization don't wish to configure authenticated SMTP for these notifications.  It's yet another location to have to statically record a user's credentials... if those credentials need to be regular changed, it's another place where the system breaks.

    We set up a temporary workaround in which we created a local account and used unauthenticated SMTP, but it actually does *not* correspond to the FROM address... so it seems like it really isn't required that the credentials match the FROM address if using an unauthenticated SMTP session.

    I'd ask that this bug be fixed at some point.  I've never seen a product *require* authenticated SMTP for very simple email notifications.

    Thursday, June 3, 2010 1:35 AM
  • We're not requiring authentication, as noted, if your SMTP server does not require authentication the crededtials are meaningless, it's just this GUI is expecting all fields to be filled in.

     

    As far as the requirement of Username and password MUST be for the same user you entered for the "From" address, if you are noting that is not the case, they must have changed that before we released, so it's good to know - thanks. 


    Regards, Mike J [MSFT] This posting is provided "AS IS" with no warranties, and confers no rights.
    Thursday, June 3, 2010 2:26 AM
    Moderator
  • As far as the requirement of Username and password MUST be for the same user you entered for the "From" address, if you are noting that is not the case, they must have changed that before we released, so it's good to know - thanks. 

    I presume this is just requirement of the SMTP server rather than DPM. Exchange server for example will check the user has the correct permissions to send from the specified from address.

    I always get a login failure from our SMTP server even though anonymous connections are allowed. I've tried two different SMTP servers - Exchange Edge and Windows SMTP server.

    Is there a powershell command to configure the SMTP server? Does this correctly allow you to set the server as anonymous?

    Thursday, June 3, 2010 8:13 AM
  • That's not our experience at all.

    Sending test notifications fails sending mail through a server that only accepts anonymous SMTP connections unless the credentials are correct.  So, they're actually not meaningless.  I also set *incorrect* credentials (without sending a test notification), then attempted to trigger a notification, and the notification was never sent (presumably since the credentials were invalid).

    So, for us, the credentials are absolutely required, even if they're not actually used for the SMTP session.

    That's my concern -- we don't want another set of credentials statically stored in this application, and we have to remember to update them lest we unknowingly break our notifications.  We have requirements for password expiration in our environment (as do many organizations).

    I'm just asking that this be addressed in a future service pack or hotfix -- a simple checkbox to enable/disable the credentials.  That seems like a standard UI feature when configuring SMTP notifications in any application.

     

    Friday, June 4, 2010 1:53 PM
  • I agree that this is a mistake to require authentication. I can't get this working, even when I use a local username on our smtp relay server.

    Kaj

    Tuesday, June 29, 2010 10:37 AM
  • I am afraid we do not have a powershell commandlet to configure SMTP settings. 

    [Paggi]

    This posting is provided "AS IS" with no warranties, and confers no rights.

    Tuesday, June 29, 2010 1:09 PM
    Moderator
  • I cant get this to work either, even when using valid credentials, has anyone got this to work or is it completely broken in 2010 rtm ?

    Martyn

    Thursday, July 1, 2010 10:32 AM
  • For me i find that the GUI requires a username & password to be present even though our exchange server can accept anonymous emails from the server.

    So for now I've used my username & password until the issue is fixed, this is working fine & we're receiving emails from the DPM server.

    Also the emails aren't being sent from my email address as suggested above.

    Thursday, July 1, 2010 11:17 AM
  • DPM 2010 supports sending e-mail through both authenticated SMTP servers and unauthenticated SMTP servers.

    To configure DPM to use an SMTP server that does not require authentication you need:

    1. In DPM Administrator Console, on the Action menu, click Options.

    2. In the Options dialog box, on the SMTP Server tab, type the SMTP server name, the SMTP server port, and the e-mail address you want to display in the From box of the e-mail messages that DPM sends.

    3. Enter Username and Password of User who have administrator privileges on the DPM server! Its important!

    http://technet.microsoft.com/en-us/systemcenter/dm/ff399060.aspx

    • Marked as answer by Chris Proud Wednesday, July 7, 2010 8:46 AM
    Wednesday, July 7, 2010 8:34 AM
  • Hi Mark,

    This works exactly as you described. The UI doesn't give any clue to this at all.

    Thanks for your help

    Chris

    Wednesday, July 7, 2010 8:46 AM
  • My password expires every 30 days.  Do I need to continue to go in and change my admin credentials to keep this feature working?
    Wednesday, August 11, 2010 11:00 PM
  • When my password expired and I changed it, emails immediately stopped working.  So the instructions to enter your admin password is nothing more than authenticating using your admin credentials, which is pretty bad for security.  Do not follow those instructions!

    I can't believe there is no fix for this.  DPM 2007 did not require SMTP authentication.  This is ridiculous!

    Tuesday, September 14, 2010 7:47 PM
  • Is anyone aware of any fix to this DPM 2010 issue? It really make no sense that we have to store credentials is the SMTP server requires no authentication. Other System Center products do not have this bug.
    Wednesday, April 27, 2011 6:04 AM
  •  

    You can enter a non-Exchange server in the STMP Server field!

    But you still have to enter an domain account for authenticated SMTP server!

    And this account does not even has to have a mailbox!

    If anybody can explain this mind bogling logic, i would love to hear it.

    Huhhh, I would love to meet the developer that put this bit in......

     



    Wednesday, June 29, 2011 7:29 PM
  • I dont know why this happened, but I entered the IP address of the exchange server, rather than the FQDN of the machine (which pings and resolves from the command line)

    The error isnt happenening anymore.

    Monday, August 15, 2011 11:30 PM
  • I have managed to get this to work by creating a local administrator on the DPM server. Then enter that users details dpmservername\username and password into the GUI and works fine for anonymous SMTP.

    Very strange, and not well documented!

    Saturday, September 24, 2011 10:56 PM