Disable digital driver signature in Windows 7 Home Premium x64 RRS feed

  • Question

  • Thank you for care
    Absolutely I face problem with driver signature after formatting my laptop on the same edition of Windows 7 Home Premium x64, the problem is Windows fails to verify the signature of MT65xx Preloader driver!

    It was working fine before formatting and I only face this problem after format, but in the last time before formatting, I installed updates from Windows Update, so this time I can't install any update because of Windows Update is keep searching and doesn't give any update list...

    Some one here said: install singed driver or try sign driver yourself, I say: I work on Boxes and Service Tools for mobile phone, required to install unsigned drivers to work those stuff properly!

    Another thing, I can't switch to any other version of Windows 7 because I purchased this edition and I need Home Premium for my work

    Any suggestion will be so much appreciated

    Thank you

    • Edited by Leonelle Thursday, July 28, 2016 2:36 PM
    Thursday, July 28, 2016 2:27 PM

All replies

  • Hi Leonelle,

    We could press F8 while the computer is turning on, then in the menu options (safe mode, safe mode /w networking, etc), at the bottom there should be "Disable Windows Digital Driver Signing".

    Also we could try to use the command to Disable digital driver signature in Windows 7. Please check the link below to follow the steps.


    Please Note: Since the website is not hosted by Microsoft, the link may change without notice. Microsoft does not guarantee the accuracy of this information.

    Hope it will be helpful to you

    Please mark the reply as an answer if you find it is helpful.

    If you have feedback for TechNet Support, contact tnmff@microsoft.com

    Friday, July 29, 2016 9:28 AM
  • Thank you Carl Fan for your suggestion F8 functions menu is temporarily solution and I should press it each time when the computer boots up... In what relates to Command Prompt commands, nothing worked for me, it's Home Premium rough edition and there is no Group Policy Editor (gpedit.msc) Thank you again
    Friday, July 29, 2016 12:04 PM