locked
Zipped folders are created without inherited permissions RRS feed

  • Question

  • When I create a zip folder, the zip folder does not inherit permissions are from its parent folder, nor from the files being archived. 

    (Fixing the permissions manually is not a problem -- only an inconvenience -- but this is repetitive.)  I confirmed that the text files, before archiving, have inherited full-control for Everyone from the parent folder. 

    Specific example:
    -- in a folder with inherited full-control for Everyone, I archive text files.
    -- I archive the files by selecting a group of them, right-clicking the selection, hovering over "Send to", and selecting "Compressed (zipped) folder".
    -- The zip folder is created within the same folder... 
    but the zip folder does not allow full-control to Everyone. 


    Why I care: 
    The parent folder is being backed-up using a bat file that executes ROBOCOPY. 
    The robocopy fails to backup the zip sub-folders. 
    I have to edit the permissions on each zip sub-folder after creating it, or set ROBOCOPY parameters to limit retries (in which case zip folders are not backed up). 


    Is there a simple fix, trick, or setting to make "Send to" / "Compressed (zipped) folder" automatically create the zip folder with inherited permissions? 


    (Note:  this problem mostly affects us on one of our "Server 2008 R2" systems, but I have recreated it in Windows 7.) 
    (Also: I posted this question first on answers.microsoft.com, but was told to post it here.) 


    Related question on technet (not yet resolved, as of 9/26/2012) --
    "Compressed (zipped) folder option always created locked zip file" 
    http://social.technet.microsoft.com/Forums/en-US/w7itproui/thread/b83cb991-b554-43a0-9baf-b05a711993ae 


    Doug Ivison


    • Edited by Doug_Ivison Wednesday, September 26, 2012 2:28 PM added *title* for related link.
    Wednesday, September 26, 2012 2:25 PM

All replies

  • Hi,

    If you need to make a backup of the zip folder, make sure you run the BAT file as an Administrator. When running as an Administrator, your files should be copied no matter what the folder permissions are.

    Hope this helps.


    Preveen

    Thursday, October 11, 2012 9:01 PM
  • Is permission inheritance enabled on the folder where you are saving this zip files?
    Saturday, April 20, 2013 12:07 PM
  • I realise that this is post has been here for a long time but I happened to be researching something similar and think I have somewhat of a solution for you.

    Send to compressed (zipped) folder inherites permissions from the temp folder as this is the folder that windows uses to make the zip file.

    Try changing the permissions to %USERPROFILE%\AppData\Local\Temp

    • Proposed as answer by Dr. NO Tuesday, January 15, 2019 9:28 AM
    Wednesday, February 11, 2015 10:27 PM