locked
Clean install of Win XP SP3 yet I can't run windows update RRS feed

  • Question

  • Hello:

    I did a fresh install of winxp w/ sp3 from an ISO off of the licensing site for MS. Install works flawlessly. Try to run windows update and get hit with KB2497281 - cannot run windows update unless on the latest service pack.  I check the properties of the PC and it reflects windows XP with SP3.  Any reason why I can't get to windows update?

    Thanks.

    Milnesy

    Thursday, August 4, 2011 7:38 PM

Answers

  • OK guys, this was bugging me all day.

    No "Fix it for me" worked, reinstall didn't work, re-install sp3 over and over didn't work...long story short, nothing was working.

     

    Then, I put automatic updates to "notify me before downloading" and it let me get about 100 updates.
    Still wouldn't let me on the site however. So I installed .net Framework 4.0

    This let the .net framework updates and more come down, and NOW I am able to get on the site.

     

    Please check and confirm if this fixes the problem for you guys.

    Saturday, August 6, 2011 11:15 AM

All replies

  • Thursday, August 4, 2011 7:42 PM
    Moderator
  • Did that, and no dice.  Then I tried to register the DLL... and still didn't work...  any thoughts? Could it have been the ISO that I got from TechNet?

    Thursday, August 4, 2011 7:48 PM
  • Try resetting Windows Update components: follow the instructions in the Microsoft Knowledge Base article published at the following web address

    http://support.microsoft.com/kb/971058/en-us

    Bye.


    Luigi Bruno - Microsoft Community Contributor 2011 Award
    Thursday, August 4, 2011 10:00 PM
  • Some people are trying to reinstall SP3. That, nor the attempts you've made, have worked for me. Whatever they've done, they've jimmy'd it up pretty good.
    Friday, August 5, 2011 12:37 PM
  • OK guys, this was bugging me all day.

    No "Fix it for me" worked, reinstall didn't work, re-install sp3 over and over didn't work...long story short, nothing was working.

     

    Then, I put automatic updates to "notify me before downloading" and it let me get about 100 updates.
    Still wouldn't let me on the site however. So I installed .net Framework 4.0

    This let the .net framework updates and more come down, and NOW I am able to get on the site.

     

    Please check and confirm if this fixes the problem for you guys.

    Saturday, August 6, 2011 11:15 AM
  • I normally don't reply to these, but wanted to confirm that you were absolutely right and saved me several hours of work -THANKS!
    Monday, August 8, 2011 1:25 PM
  • I have the same problem. But it didnt work after i done all the methods above. At last it works for me...

    I installed IE8 and then again install windows update agent.. now it worked...

     

    Thank you all..

     


    Thursday, August 11, 2011 6:08 AM
  • Sadly this fix did not work for me. This is a fresh installation of Windows XP SP3 from our Volume License Installation.

    -I've installed .NET Framework 4.0.
    -Installed Internet Explorer 7.0
    -Install all device drivers.
    -Installed all automatic updates that are detected.
    -Run wuauclt /detectnow
    -Repaired Windows Update in the usual fashion
    -Completely formated the drive and reinstalled XP SP3 all over again

    Yet I am still redirected to the KB page every time I connect to either Windows Update, or Microsoft Update.

    I can't upgrade to IE8.0 as our Intranet site does not work on anything higher than 7.0. I need to have a fully patched installation completed to build a pre-patched base image for a set of laptops, and this is frustrating the hell out of me.

    Thursday, August 11, 2011 3:25 PM
  • I've never posted on here before, but had to after experiencing this exact problem.  .Net 4 didn't fix it and waiting for auto updates to pop up was really wasting my time. 

    The fix for me was this:

    http://support.microsoft.com/kb/943144

    It had me install the Windows Update Agent and without even having to restart I was able to get onto the Windows Update/MS update pages!!!

    Hope this helps somebody in the near future.

    Thursday, August 11, 2011 5:31 PM
  • I've also installed a few different versions of the Windows Update Agent without success.
    Thursday, August 11, 2011 5:32 PM
  • ACK! Nothing working for me. Not the things suggested in the redirect; not installing .net 4; not installing the suggested Update Agent and registering the .dll; not installing IE 8. WTF?! This was all working fine the last time I used WU (last week...Wednesday, as I recall)!

    Edit: Finally! Yowza's suggestion here (setting Automatic Updates to Notify Only) worked for me:

    http://superuser.com/questions/318606/windows-update-website-redirecting-newly-built-windows-xp-sp3-computers-to-kb-art


    Thursday, August 11, 2011 10:27 PM
  • Sadly setting the updates to Notify Only were not a solution for me.

    The logic on the Windows Update site has to have been broken. If there's another security update that the site is checking for Microsoft needs to put that information in the KB article.

    Friday, August 12, 2011 3:03 PM
  • I had the same problem.  Just figured it out.  Solution is to download the latest windows update agent to a known directory such as C:\Wuagent.  Then click Start->Run and type in the following:

    c:\wuagent\windowsupdateagent30-x86.exe /wuforce

    Be sure to change the directory if you save it somewhere else.

    I found the solution at majorgeeks at: http://forums.majorgeeks.com/showthread.php?t=240536.

    Note that I tried pretty much everything else on here first.  I tried installing the latest Windows Update Agent.  I tried installing ie8.  ie8 would not install.  I tried uninstalling .Net 2.  Then I tried to re-install .Net 2 but it wouldn't install.  I installed .Net 4 successfully.  None of the above fixed the problem until I installed the update agent with the /wuforce option.  Hope this helps others.

    Bryan Rubingh

    Saturday, February 9, 2013 10:13 PM
  • I have been installing XP Pro on an old laptop. The release includes SP2. Something is going on at MS because I had to install Chrome in order to download IE8. IE6 is now completely non-functional to MS servers. This is my 2nd attempt. The last time IE8 could not update itself. SP3 is installing now and then I will try your fix. People are becoming very emotional about giving up XP. I wonder how many are running pirated copies trying to stay under the radar.
    Wednesday, September 11, 2013 11:33 PM
  • You should never get emotional about that. Just switch to Apple and you'll never have problems again.


    Tuesday, December 10, 2013 11:04 AM
  • Hi All,

    It took me a while to cut this one down. I created a blog post on my website with detailed instructions and links to the updates you'll need to download. It'll take you about 10 minutes and you should have Windows Updates working again.
    http://www.geekallday.com/windows-xp-sp3-update-issues/

    I'll also list the updates here that are required.

    • Proposed as answer by JFRIDEY Thursday, January 2, 2014 5:55 PM
    Thursday, January 2, 2014 5:52 PM
  • I was having real problems with this on multiple installations.  This fix is what worked for me. http://support.microsoft.com/kb/943144

    End of life sucks :(

    Monday, January 13, 2014 4:34 PM