locked
drive mappings not working sometimes RRS feed

  • Question

  • I have a domain that consists of 4 2003 server DC's. Users login and run a system VB script to map their drives. This works fine except that sometimes these drives are not accessible and ask for a username and password when the user clicks on them. they appear in explorer but are not accessible. The user logs out and then back in and the drives work fine.
    Tuesday, December 15, 2009 2:46 PM

Answers

  • You might want to ensure that Fast Logon Optimization is turned off (http://technet.microsoft.com/en-us/library/cc780527(WS.10).aspx)

    hth
    Marcin

    • Proposed as answer by philamonster Thursday, December 17, 2009 1:58 AM
    • Marked as answer by Bruce-Liu Tuesday, December 22, 2009 3:15 AM
    Tuesday, December 15, 2009 2:58 PM
  • Hello kjs59,

    I think your issue is that if you keep mapped drives idle for a while, they ask for user name and password?

    If so, this may help you: It is from one of my other posts: (http://social.technet.microsoft.com/Forums/en-US/winserverNIS/thread/99861133-5351-497b-8c0c-bc42632e9118)

    Hi,

    When you connect the network drives, they connect via an SMB session. Now SMB has a session timeout. The default timeout for SMB session is 15 minutes. That is, if the machines are inactive for more than 15 minutes, they may lose connection with the server.

    You can run a few commands to control the autodisconnect feature.

    net config server /autodisconnect:-1 : To disable autodisconnect timer.

    net config server /autodisconnect:<Minutes> : Provide the number of minutes you want to keep the session alive and the client will send the keep alive packets to the server every two minutes untill it reaches the number of minutes you have specified in the command.

    The autodisconnect feature can be adjusted or can be disabled. Here is the article for this:
    http://support.microsoft.com/kb/297684


    Thanks,

    Arun.
    • Marked as answer by Bruce-Liu Tuesday, December 22, 2009 3:15 AM
    Tuesday, December 15, 2009 3:13 PM

All replies

  • You might want to ensure that Fast Logon Optimization is turned off (http://technet.microsoft.com/en-us/library/cc780527(WS.10).aspx)

    hth
    Marcin

    • Proposed as answer by philamonster Thursday, December 17, 2009 1:58 AM
    • Marked as answer by Bruce-Liu Tuesday, December 22, 2009 3:15 AM
    Tuesday, December 15, 2009 2:58 PM
  • Hello kjs59,

    I think your issue is that if you keep mapped drives idle for a while, they ask for user name and password?

    If so, this may help you: It is from one of my other posts: (http://social.technet.microsoft.com/Forums/en-US/winserverNIS/thread/99861133-5351-497b-8c0c-bc42632e9118)

    Hi,

    When you connect the network drives, they connect via an SMB session. Now SMB has a session timeout. The default timeout for SMB session is 15 minutes. That is, if the machines are inactive for more than 15 minutes, they may lose connection with the server.

    You can run a few commands to control the autodisconnect feature.

    net config server /autodisconnect:-1 : To disable autodisconnect timer.

    net config server /autodisconnect:<Minutes> : Provide the number of minutes you want to keep the session alive and the client will send the keep alive packets to the server every two minutes untill it reaches the number of minutes you have specified in the command.

    The autodisconnect feature can be adjusted or can be disabled. Here is the article for this:
    http://support.microsoft.com/kb/297684


    Thanks,

    Arun.
    • Marked as answer by Bruce-Liu Tuesday, December 22, 2009 3:15 AM
    Tuesday, December 15, 2009 3:13 PM
  • Kindly update if this helped or not...
    Wednesday, December 16, 2009 12:53 PM
  • Are the workstations on the same domain as the server?
    My blog: http://cjwdev.wordpress.com
    Wednesday, December 16, 2009 7:40 PM