locked
WSUS Connection Error after SSL setup RRS feed

  • Question

  • Hello,

    I followed this link here to setup SSL:

    http://www.vkernel.ro/blog/configure-wsus-to-use-ssl

    I used a wildcard cert here so *.company.com rather than wsus.company.com.

    Is this a problem?

    Could see through a "netstat -an" that machines were connecting to the https rather than http.

    In Eventvwr there were events 7053 and 7032 and among the things it mentioned was remove wsus files in %appdata%\Microsoft\MMC\.

    We didn't get a chance to do these things as we had to rollback.

    Do you know if that certificate is a problem or is it something else?

    Thanks,

    David

    Thursday, July 21, 2016 2:05 PM

All replies

  • Hi daithiofeich,

    >I used a wildcard cert here so *.company.com rather than wsus.company.com.

    You may use wildcard cert, while in the GPO settings, the WSUS URL must be https://wsus.company.com:8531 (example);

    On WSUS clients, they must trust the wildcard cert. If the certificate is issued by a CA server, then WSUS clients must have the root certificate of the CA server.

    Best Regards,

    Anne


    Please remember to mark the replies as answers if they help and unmark them if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    Friday, July 22, 2016 7:08 AM
  • Not sure what was wrong. I used the port 9443 and I was able to navigate to https://wsus.company.com:9443

    WSUSUtil.exe configuressl showed correct address and port.

    Also the WSUS clients could connect fine. I had Clients getting updates but just I couldn't open the WSUS console to manage them.


    Monday, July 25, 2016 11:08 AM
  • Hi daithiofeich,

    When you connect to the WSUS console, have you configured this:

    Best Regards,

    Anne


    Please remember to mark the replies as answers if they help and unmark them if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    Tuesday, July 26, 2016 8:07 AM
  • Sorry only seeing this now.

    I did do this but I got an error.

    We're applying updates at the moment and I'll have to go back at this once we complete these.

    I'll come back here to see if people have inputs if I'm seeing the same thing.

    Friday, July 29, 2016 4:50 PM
  • Hi daithiofeich,

    >We're applying updates at the moment and I'll have to go back at this once we complete these.

    Just to confirm if you have gone back to troubleshoot the issue?

    Wsus event log might be of help, you may check C:\program files\update services\logfiles to find wsus event log.

    Best Regards,

    Anne


    Please remember to mark the replies as answers if they help and unmark them if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    Wednesday, August 3, 2016 8:27 AM