locked
MDT, windows 10 and SQL problems RRS feed

  • Question

  • Hello all!

    I really need your help as this is making me going crazy...

    So i have installed MDT latest version with AIK latest version all to deploy windows 10 1709 kms iso.

    I setup MDT with sql database as i have multiple locations to manage; the setup went fine without problems or errors. So now i have  put only windows 10 OS, created the pxe boot drivers disk from Dell pxe v10 download, created roles, locations, models, task sequences and uploaded the needed drivers.

    On the SQL server the database is up and running and all tables/views seem to be there.

    Now when a new pc boots it fires up the pxe boot and the task sequence and all seems ok until the step where the custom settings are loaded and the different SQL sections are loaded.... it all goes fine until loading the LPACKAGES section. Until here it goes fast for each section but from here it is slow and generates errors on the logs.

    I cant understand why this happens.... please HELP!

    Wednesday, October 24, 2018 10:19 AM

All replies

  • Please find here http://txt.do/dn7xc the logs needed to verify this issue.

    I just can't understand why some parts we can access the sql server and get the data from it and then it stops working...

    Seems he forgets about the location of the ini file....

    Using DEFAULT VALUE: Ini file = \\lu*******\DeploymentShare$\Control\CustomSettings.ini ZTIGather

    then on the next section:

    Determining the INI file to use.	ZTIGather	10/24/2018 1:34:55 AM	0 (0x0000)
    FindFile: The file CustomSettings.ini could not be found in any standard locations.	

    • Edited by UnhuZpt Wednesday, October 24, 2018 10:22 AM
    Wednesday, October 24, 2018 10:20 AM
  • Bump - i really need help here please!

    Thursday, October 25, 2018 7:53 AM
  • I can't tell what's going on here from the logs present. 

    The question is, why does one database table work, and the others not work?

    Try copying the content from [croles] into [lpackages] just to see if it works. 

    What happens if you try removing lpackages from [settings] priority ? does it continue or are there other sections that also have problems?

    Have you tried to access the LocationPackages table remotely from outside of MDT using the same creds?

    it's entirely possible that the database does not have the correct permissions


    Keith Garner - Principal Consultant [owner] - http://DeploymentLive.com

    Saturday, October 27, 2018 4:22 PM
  • Hello and thank you for your reply.

    For what i can see, using sql profiler, i can see all the select being sent to the db, and in fact there is never an login error  in the sql logs/profiler. The most astonishing thing is that if i run the ztigather by cli in the pc that is going to be imaged i get all ok and i would assume by the output that all goes correct.

    Running form the mdt side automated install i can see the select statements until LPACKAGES and from there all goes slow until all others. I have tried put them 1st and saw exact same thing happen, slow and no return from the select. I see all these selects in LPACKAGES and after get zero results. By reading the select @ LPACKAGES one would assume there should be already some info there about the machine in deployment.

    One thing i notice is even if i did a clean on the drive in the pc and changed the user/pass in the bootstrap.ini the pc is still running the old account to access sql (that also works).

    My config:

    [Settings]
    Priority=CSettings, CPackages, CApps, CAdmins, CRoles, Locations, LSettings, LPackages, LApps, LAdmins, LRoles, MMSettings, MMPackages, MMApps, MMAdmins, MMRoles, RSettings, RPackages, RApps, RAdmins, Default
    Properties=MyCustomProperty

    [Default]
    EventService=http://..local:9800

    [CSettings]
    SQLServer=LU01..local
    Instance=MSSQLSERVER
    Port=1433
    DBID=%UserID%
    DBPwd=%UserPassword%
    Database=MDTSQLDB
    Netlib=DBMSSOCN
    SQLShare=DeploymentShare$
    Table=ComputerSettings
    Parameters=UUID, AssetTag, SerialNumber, MacAddress
    ParameterCondition=OR

    [CPackages]
    SQLServer=LUi.local
    Instance=MSSQLSERVER
    Port=1433
    DBID=%UserID%
    DBPwd=%UserPassword%
    Database=MDTSQLDB
    Netlib=DBMSSOCN
    SQLShare=DeploymentShare$
    Table=ComputerPackages
    Parameters=UUID, AssetTag, SerialNumber, MacAddress
    ParameterCondition=OR
    Order=Sequence

    [CApps]
    SQLServer=L.local
    Instance=MSSQLSERVER
    Port=1433
    DBID=%UserID%
    DBPwd=%UserPassword%
    Database=MDTSQLDB
    Netlib=DBMSSOCN
    SQLShare=DeploymentShare$
    Table=ComputerApplications
    Parameters=UUID, AssetTag, SerialNumber, MacAddress
    ParameterCondition=OR
    Order=Sequence

    [CAdmins]
    SQLServer=L.local
    Instance=MSSQLSERVER
    Port=1433
    DBID=%UserID%
    DBPwd=%UserPassword%
    Database=MDTSQLDB
    Netlib=DBMSSOCN
    SQLShare=DeploymentShare$
    Table=ComputerAdministrators
    Parameters=UUID, AssetTag, SerialNumber, MacAddress
    ParameterCondition=OR

    [CRoles]
    SQLServer=LU1.local
    Instance=MSSQLSERVER
    Port=1433
    DBID=%UserID%
    DBPwd=%UserPassword%
    Database=MDTSQLDB
    Netlib=DBMSSOCN
    SQLShare=DeploymentShare$
    Table=ComputerRoles
    Parameters=UUID, AssetTag, SerialNumber, MacAddress
    ParameterCondition=OR

    [Locations]
    SQLServer=L.local
    Instance=MSSQLSERVER
    Port=1433
    DBID=%UserID%
    DBPwd=%UserPassword%
    Database=MDTSQLDB
    Netlib=DBMSSOCN
    SQLShare=DeploymentShare$
    Table=Locations
    Parameters=DefaultGateway

    [LSettings]
    SQLServer=Li.local
    Instance=MSSQLSERVER
    Port=1433
    DBID=%UserID%
    DBPwd=%UserPassword%
    Database=MDTSQLDB
    Netlib=DBMSSOCN
    SQLShare=DeploymentShare$
    Table=LocationSettings
    Parameters=DefaultGateway

    [LPackages]
    SQLServer=Li.local
    Instance=MSSQLSERVER
    Port=1433
    DBID=%UserID%
    DBPwd=%UserPassword%
    Database=MDTSQLDB
    Netlib=DBMSSOCN
    SQLShare=DeploymentShare$
    Table=LocationPackages
    Parameters=DefaultGateway
    Order=Sequence

    [LApps]
    SQLServer=L.local
    Instance=MSSQLSERVER
    Port=1433
    DBID=%UserID%
    DBPwd=%UserPassword%
    Database=MDTSQLDB
    Netlib=DBMSSOCN
    SQLShare=DeploymentShare$
    Table=LocationApplications
    Parameters=DefaultGateway
    Order=Sequence

    [LAdmins]
    SQLServer=LU1.local
    Instance=MSSQLSERVER
    Port=1433
    DBID=%UserID%
    DBPwd=%UserPassword%
    Database=MDTSQLDB
    Netlib=DBMSSOCN
    SQLShare=DeploymentShare$
    Table=LocationAdministrators
    Parameters=DefaultGateway

    [LRoles]
    SQLServer=LUi.local
    Instance=MSSQLSERVER
    Port=1433
    DBID=%UserID%
    DBPwd=%UserPassword%
    Database=MDTSQLDB
    Netlib=DBMSSOCN
    SQLShare=DeploymentShare$
    Table=LocationRoles
    Parameters=DefaultGateway

    [MMSettings]
    SQLServer=Li.local
    Instance=MSSQLSERVER
    Port=1433
    DBID=%UserID%
    DBPwd=%UserPassword%
    Database=MDTSQLDB
    Netlib=DBMSSOCN
    SQLShare=DeploymentShare$
    Table=MakeModelSettings
    Parameters=Make, Model

    [MMPackages]
    SQLServer=Lcal
    Instance=MSSQLSERVER
    Port=1433
    DBID=%UserID%
    DBPwd=%UserPassword%
    Database=MDTSQLDB
    Netlib=DBMSSOCN
    SQLShare=DeploymentShare$
    Table=MakeModelPackages
    Parameters=Make, Model
    Order=Sequence

    [MMApps]
    SQLServer=Lbi.local
    Instance=MSSQLSERVER
    Port=1433
    DBID=%UserID%
    DBPwd=%UserPassword%
    Database=MDTSQLDB
    Netlib=DBMSSOCN
    SQLShare=DeploymentShare$
    Table=MakeModelApplications
    Parameters=Make, Model
    Order=Sequence

    [MMAdmins]
    SQLServer=L.local
    Instance=MSSQLSERVER
    Port=1433
    DBID=%UserID%
    DBPwd=%UserPassword%
    Database=MDTSQLDB
    Netlib=DBMSSOCN
    SQLShare=DeploymentShare$
    Table=MakeModelAdministrators
    Parameters=Make, Model

    [MMRoles]
    SQLServer=L.local
    Instance=MSSQLSERVER
    Port=1433
    DBID=%UserID%
    DBPwd=%UserPassword%
    Database=MDTSQLDB
    Netlib=DBMSSOCN
    SQLShare=DeploymentShare$
    Table=MakeModelRoles
    Parameters=Make, Model

    [RSettings]
    SQLServer=LU.local
    Instance=MSSQLSERVER
    Port=1433
    DBID=%UserID%
    DBPwd=%UserPassword%
    Database=MDTSQLDB
    Netlib=DBMSSOCN
    SQLShare=DeploymentShare$
    Table=RoleSettings
    Parameters=Role

    [RPackages]
    SQLServer=L.local
    Instance=MSSQLSERVER
    Port=1433
    DBID=%UserID%
    DBPwd=%UserPassword%
    Database=MDTSQLDB
    Netlib=DBMSSOCN
    SQLShare=DeploymentShare$
    Table=RolePackages
    Parameters=Role
    Order=Sequence

    [RApps]
    SQLServer=Local
    Instance=MSSQLSERVER
    Port=1433
    DBID=%UserID%
    DBPwd=%UserPassword%
    Database=MDTSQLDB
    Netlib=DBMSSOCN
    SQLShare=DeploymentShare$
    Table=RoleApplications
    Parameters=Role
    Order=Sequence

    [RAdmins]
    SQLServer=Li.local
    Instance=MSSQLSERVER
    Port=1433
    DBID=%UserID%
    DBPwd=%UserPassword%
    Database=MDTSQLDB
    Netlib=DBMSSOCN
    SQLShare=DeploymentShare$
    Table=RoleAdministrators
    Parameters=Role

    Tuesday, October 30, 2018 1:19 PM
  • Bootstrap:

    [Settings]
    Priority=Decode, Default

    [Decode]
    EncodedUserPassword=WsgewrgehyMDE4
    UserExit=DecodeExit.vbs

    [Default]
    DeployRoot=\\lqaargcal\DeploymentShare$
    UserDomain=*****
    UserID=****\admin20fa
    SkipBDDWelcome=YES

    Tuesday, October 30, 2018 1:20 PM
  • What i think is my problem is>

    By checking logs i see all seems to go fine until the process finishes processing LSETTINGS. After that starting to process LPACKAGES i get this>

    MessageNumber    Summary    
    302    <![LOG[------ Processing the [LPACKAGES] section ------]LOG]!><time="15:06:14.000+000" date="10-30-2018" component="ZTIGather" context="" type="1" thread="" file="ZTIGather">    
    303    <![LOG[Determining the INI file to use.]LOG]!><time="15:06:14.000+000" date="10-30-2018" component="ZTIGather" context="" type="1" thread="" file="ZTIGather">    
    304    <![LOG[FindFile: The file CustomSettings.ini could not be found in any standard locations.]LOG]!><time="15:06:15.000+000" date="10-30-2018" component="ZTIGather" context="" type="1" thread="" file="ZTIGather">    
    305    <![LOG[Finished determining the INI file to use.]LOG]!><time="15:06:15.000+000" date="10-30-2018" component="ZTIGather" context="" type="1" thread="" file="ZTIGather">    
    306    <![LOG[FindFile: The file CustomSettings.ini could not be found in any standard locations.]LOG]!><time="15:06:15.000+000" date="10-30-2018" component="ZTIGather" context="" type="1" thread="" file="ZTIGather">    
    307    <![LOG[Unable to find CustomSettings.ini, rc = 1]LOG]!><time="15:06:15.000+000" date="10-30-2018" component="ZTIGather" context="" type="3" thread="" file="ZTIGather">    

    Until processing to LSETTINGS all is fine and working.

    The next step he just does not find the customsettings.ini file and i have no idea why....

    MessageNumber    Summary    
    302    <![LOG[------ Processing the [LPACKAGES] section ------]LOG]!><time="15:06:14.000+000" date="10-30-2018" component="ZTIGather" context="" type="1" thread="" file="ZTIGather">    
    303    <![LOG[Determining the INI file to use.]LOG]!><time="15:06:14.000+000" date="10-30-2018" component="ZTIGather" context="" type="1" thread="" file="ZTIGather">    
    304    <![LOG[FindFile: The file CustomSettings.ini could not be found in any standard locations.]LOG]!><time="15:06:15.000+000" date="10-30-2018" component="ZTIGather" context="" type="1" thread="" file="ZTIGather">    
    305    <![LOG[Finished determining the INI file to use.]LOG]!><time="15:06:15.000+000" date="10-30-2018" component="ZTIGather" context="" type="1" thread="" file="ZTIGather">    
    306    <![LOG[FindFile: The file CustomSettings.ini could not be found in any standard locations.]LOG]!><time="15:06:15.000+000" date="10-30-2018" component="ZTIGather" context="" type="1" thread="" file="ZTIGather">    
    307    <![LOG[Unable to find CustomSettings.ini, rc = 1]LOG]!><time="15:06:15.000+000" date="10-30-2018" component="ZTIGather" context="" type="3" thread="" file="ZTIGather">    
    308    <![LOG[CHECKING the [LPACKAGES] section]LOG]!><time="15:06:15.000+000" date="10-30-2018" component="ZTIGather" context="" type="1" thread="" file="ZTIGather">    
    309    <![LOG[SQLServer key not defined in the section [LPACKAGES]]LOG]!><time="15:06:15.000+000" date="10-30-2018" component="ZTIGather" context="" type="1" thread="" file="ZTIGather">    
    310    <![LOG[Instance key not defined in the section [LPACKAGES]]LOG]!><time="15:06:15.000+000" date="10-30-2018" component="ZTIGather" context="" type="1" thread="" file="ZTIGather">    
    311    <![LOG[Port key not defined in the section [LPACKAGES]]LOG]!><time="15:06:15.000+000" date="10-30-2018" component="ZTIGather" context="" type="1" thread="" file="ZTIGather">    
    312    <![LOG[Database key not defined in the section [LPACKAGES]]LOG]!><time="15:06:15.000+000" date="10-30-2018" component="ZTIGather" context="" type="1" thread="" file="ZTIGather">    
    313    <![LOG[Netlib key not defined in the section [LPACKAGES]]LOG]!><time="15:06:15.000+000" date="10-30-2018" component="ZTIGather" context="" type="1" thread="" file="ZTIGather">    
    314    <![LOG[Table key not defined in the section [LPACKAGES]]LOG]!><time="15:06:15.000+000" date="10-30-2018" component="ZTIGather" context="" type="1" thread="" file="ZTIGather">    
    315    <![LOG[StoredProcedure key not defined in the section [LPACKAGES]]LOG]!><time="15:06:15.000+000" date="10-30-2018" component="ZTIGather" context="" type="1" thread="" file="ZTIGather">    
    316    <![LOG[DBID key not defined in the section [LPACKAGES]]LOG]!><time="15:06:15.000+000" date="10-30-2018" component="ZTIGather" context="" type="1" thread="" file="ZTIGather">    
    317    <![LOG[DBPwd key not defined in the section [LPACKAGES]]LOG]!><time="15:06:15.000+000" date="10-30-2018" component="ZTIGather" context="" type="1" thread="" file="ZTIGather">    
    318    <![LOG[SQLShare key not defined in the section [LPACKAGES]]LOG]!><time="15:06:15.000+000" date="10-30-2018" component="ZTIGather" context="" type="1" thread="" file="ZTIGather">    
    319    <![LOG[ParameterCondition key not defined in the section [LPACKAGES]]LOG]!><time="15:06:15.000+000" date="10-30-2018" component="ZTIGather" context="" type="1" thread="" file="ZTIGather">    
    320    <![LOG[No parameters to include in the SQL call were specified]LOG]!><time="15:06:15.000+000" date="10-30-2018" component="ZTIGather" context="" type="1" thread="" file="ZTIGather">    
    321    <![LOG[ERROR - SQLServer NOT defined in the section [LPACKAGES]]LOG]!><time="15:06:15.000+000" date="10-30-2018" component="ZTIGather" context="" type="3" thread="" file="ZTIGather">    
    322    <![LOG[No SQLShare value was specified, not possible to establish a secure connection.]LOG]!><time="15:06:15.000+000" date="10-30-2018" component="ZTIGather" context="" type="1" thread="" file="ZTIGather">    
    323    <![LOG[OPENING TRUSTED SQL CONNECTION to server .]LOG]!><time="15:06:15.000+000" date="10-30-2018" component="ZTIGather" context="" type="1" thread="" file="ZTIGather">    
    324    <![LOG[Connecting to SQL Server using connect string: Provider=SQLOLEDB;OLE DB Services=0;Data Source=;Initial Catalog=;Network Library=;Integrated Security=SSPI]LOG]!><time="15:06:15.000+000" date="10-30-2018" component="ZTIGather" context="" type="1" thread="" file="ZTIGather">    
    325    <![LOG[ZTI error opening SQL Connection: [DBNETLIB][ConnectionOpen (Connect()).]SQL Server does not exist or access denied. (-2147467259)]LOG]!><time="15:06:33.000+000" date="10-30-2018" component="ZTIGather" context="" type="3" thread="" file="ZTIGather">    
    326    <![LOG[Unable to establish database connection using [LPACKAGES] properties.]LOG]!><time="15:06:33.000+000" date="10-30-2018" component="ZTIGather" context="" type="3" thread="" file="ZTIGather">    
    327    <![LOG[------ Processing the [LAPPS] section ------]LOG]!><time="15:06:33.000+000" date="10-30-2018" component="ZTIGather" context="" type="1" thread="" file="ZTIGather">    


    • Edited by UnhuZpt Tuesday, October 30, 2018 2:43 PM
    Tuesday, October 30, 2018 2:27 PM
  • Can anyone give me a help on this?

    What i think is my problem is>

    By checking logs i see all seems to go fine until the process finishes processing LSETTINGS. After that starting to process LPACKAGES i get this>

    MessageNumber    Summary    
    302    <![LOG[------ Processing the [LPACKAGES] section ------]LOG]!><time="15:06:14.000+000" date="10-30-2018" component="ZTIGather" context="" type="1" thread="" file="ZTIGather">    
    303    <![LOG[Determining the INI file to use.]LOG]!><time="15:06:14.000+000" date="10-30-2018" component="ZTIGather" context="" type="1" thread="" file="ZTIGather">    
    304    <![LOG[FindFile: The file CustomSettings.ini could not be found in any standard locations.]LOG]!><time="15:06:15.000+000" date="10-30-2018" component="ZTIGather" context="" type="1" thread="" file="ZTIGather">    
    305    <![LOG[Finished determining the INI file to use.]LOG]!><time="15:06:15.000+000" date="10-30-2018" component="ZTIGather" context="" type="1" thread="" file="ZTIGather">    
    306    <![LOG[FindFile: The file CustomSettings.ini could not be found in any standard locations.]LOG]!><time="15:06:15.000+000" date="10-30-2018" component="ZTIGather" context="" type="1" thread="" file="ZTIGather">    
    307    <![LOG[Unable to find CustomSettings.ini, rc = 1]LOG]!><time="15:06:15.000+000" date="10-30-2018" component="ZTIGather" context="" type="3" thread="" file="ZTIGather">    

    Until processing to LSETTINGS all is fine and working.

    The next step he just does not find the customsettings.ini file and i have no idea why....

    MessageNumber    Summary    
    302    <![LOG[------ Processing the [LPACKAGES] section ------]LOG]!><time="15:06:14.000+000" date="10-30-2018" component="ZTIGather" context="" type="1" thread="" file="ZTIGather">    
    303    <![LOG[Determining the INI file to use.]LOG]!><time="15:06:14.000+000" date="10-30-2018" component="ZTIGather" context="" type="1" thread="" file="ZTIGather">    
    304    <![LOG[FindFile: The file CustomSettings.ini could not be found in any standard locations.]LOG]!><time="15:06:15.000+000" date="10-30-2018" component="ZTIGather" context="" type="1" thread="" file="ZTIGather">    
    305    <![LOG[Finished determining the INI file to use.]LOG]!><time="15:06:15.000+000" date="10-30-2018" component="ZTIGather" context="" type="1" thread="" file="ZTIGather">    
    306    <![LOG[FindFile: The file CustomSettings.ini could not be found in any standard locations.]LOG]!><time="15:06:15.000+000" date="10-30-2018" component="ZTIGather" context="" type="1" thread="" file="ZTIGather">    
    307    <![LOG[Unable to find CustomSettings.ini, rc = 1]LOG]!><time="15:06:15.000+000" date="10-30-2018" component="ZTIGather" context="" type="3" thread="" file="ZTIGather">    
    308    <![LOG[CHECKING the [LPACKAGES] section]LOG]!><time="15:06:15.000+000" date="10-30-2018" component="ZTIGather" context="" type="1" thread="" file="ZTIGather">    
    309    <![LOG[SQLServer key not defined in the section [LPACKAGES]]LOG]!><time="15:06:15.000+000" date="10-30-2018" component="ZTIGather" context="" type="1" thread="" file="ZTIGather">    
    310    <![LOG[Instance key not defined in the section [LPACKAGES]]LOG]!><time="15:06:15.000+000" date="10-30-2018" component="ZTIGather" context="" type="1" thread="" file="ZTIGather">    
    311    <![LOG[Port key not defined in the section [LPACKAGES]]LOG]!><time="15:06:15.000+000" date="10-30-2018" component="ZTIGather" context="" type="1" thread="" file="ZTIGather">    
    312    <![LOG[Database key not defined in the section [LPACKAGES]]LOG]!><time="15:06:15.000+000" date="10-30-2018" component="ZTIGather" context="" type="1" thread="" file="ZTIGather">    
    313    <![LOG[Netlib key not defined in the section [LPACKAGES]]LOG]!><time="15:06:15.000+000" date="10-30-2018" component="ZTIGather" context="" type="1" thread="" file="ZTIGather">    
    314    <![LOG[Table key not defined in the section [LPACKAGES]]LOG]!><time="15:06:15.000+000" date="10-30-2018" component="ZTIGather" context="" type="1" thread="" file="ZTIGather">    
    315    <![LOG[StoredProcedure key not defined in the section [LPACKAGES]]LOG]!><time="15:06:15.000+000" date="10-30-2018" component="ZTIGather" context="" type="1" thread="" file="ZTIGather">    
    316    <![LOG[DBID key not defined in the section [LPACKAGES]]LOG]!><time="15:06:15.000+000" date="10-30-2018" component="ZTIGather" context="" type="1" thread="" file="ZTIGather">    
    317    <![LOG[DBPwd key not defined in the section [LPACKAGES]]LOG]!><time="15:06:15.000+000" date="10-30-2018" component="ZTIGather" context="" type="1" thread="" file="ZTIGather">    
    318    <![LOG[SQLShare key not defined in the section [LPACKAGES]]LOG]!><time="15:06:15.000+000" date="10-30-2018" component="ZTIGather" context="" type="1" thread="" file="ZTIGather">    
    319    <![LOG[ParameterCondition key not defined in the section [LPACKAGES]]LOG]!><time="15:06:15.000+000" date="10-30-2018" component="ZTIGather" context="" type="1" thread="" file="ZTIGather">    
    320    <![LOG[No parameters to include in the SQL call were specified]LOG]!><time="15:06:15.000+000" date="10-30-2018" component="ZTIGather" context="" type="1" thread="" file="ZTIGather">    
    321    <![LOG[ERROR - SQLServer NOT defined in the section [LPACKAGES]]LOG]!><time="15:06:15.000+000" date="10-30-2018" component="ZTIGather" context="" type="3" thread="" file="ZTIGather">    
    322    <![LOG[No SQLShare value was specified, not possible to establish a secure connection.]LOG]!><time="15:06:15.000+000" date="10-30-2018" component="ZTIGather" context="" type="1" thread="" file="ZTIGather">    
    323    <![LOG[OPENING TRUSTED SQL CONNECTION to server .]LOG]!><time="15:06:15.000+000" date="10-30-2018" component="ZTIGather" context="" type="1" thread="" file="ZTIGather">    
    324    <![LOG[Connecting to SQL Server using connect string: Provider=SQLOLEDB;OLE DB Services=0;Data Source=;Initial Catalog=;Network Library=;Integrated Security=SSPI]LOG]!><time="15:06:15.000+000" date="10-30-2018" component="ZTIGather" context="" type="1" thread="" file="ZTIGather">    
    325    <![LOG[ZTI error opening SQL Connection: [DBNETLIB][ConnectionOpen (Connect()).]SQL Server does not exist or access denied. (-2147467259)]LOG]!><time="15:06:33.000+000" date="10-30-2018" component="ZTIGather" context="" type="3" thread="" file="ZTIGather">    
    326    <![LOG[Unable to establish database connection using [LPACKAGES] properties.]LOG]!><time="15:06:33.000+000" date="10-30-2018" component="ZTIGather" context="" type="3" thread="" file="ZTIGather">    
    327    <![LOG[------ Processing the [LAPPS] section ------]LOG]!><time="15:06:33.000+000" date="10-30-2018" component="ZTIGather" context="" type="1" thread="" file="ZTIGather">    



    Thursday, November 22, 2018 9:14 AM
  • Hello,

    by any chance did you got this resolve as I am having the same issue here.

    everything works fine on my deployment server, but once I started to run it from the management server. it breaks.

    Thursday, April 11, 2019 7:42 PM
  • Hello,

    I have resolve my Error by Configure Database Rules all over. and in the process eliminating a few Query's.

    the following i have left set up in my CustomSettings.ini

    CSettings ,CApps, CRoles, Locations, LSettings, LApps, MMSettings, MMApps, RSettings, RApps.

    [Settings]
    Priority=CSettings, CApps, CRoles, Locations, LSettings, LApps, MMSettings, MMApps, RSettings, RApps, Default
    Properties=MyCustomProperty

    [Default]
    OSInstall=Y
    SkipCapture=YES
    SkipAdminPassword=YES
    SkipProductKey=YES
    SkipComputerBackup=YES
    SkipBitLocker=YES
    EventService=http://:9800

    [CSettings]
    SQLServer=
    Instance=SQLEXPRESS
    Port=1433
    DBID=%UserID%
    DBPwd=%UserPassword%
    Database=
    Netlib=DBMSSOCN
    SQLShare=
    Table=ComputerSettings
    Parameters=UUID, AssetTag, SerialNumber, MacAddress
    ParameterCondition=OR

    [CPackages]
    SQLServer=
    Instance=SQLEXPRESS
    Port=1433
    DBID=%UserID%
    DBPwd=%UserPassword%
    Database=
    Netlib=DBMSSOCN
    SQLShare=
    Table=ComputerPackages
    Parameters=UUID, AssetTag, SerialNumber, MacAddress
    ParameterCondition=OR
    Order=Sequence

    [CApps]
    SQLServer=
    Instance=SQLEXPRESS
    Port=1433
    DBID=%UserID%
    DBPwd=%UserPassword%
    Database=
    Netlib=DBMSSOCN
    SQLShare=
    Table=ComputerApplications
    Parameters=UUID, AssetTag, SerialNumber, MacAddress
    ParameterCondition=OR
    Order=Sequence

    [CAdmins]

    SQLServer=
    Instance=SQLEXPRESS
    Port=1433
    DBID=%UserID%
    DBPwd=%UserPassword%
    Database=
    Netlib=DBMSSOCN
    SQLShare=
    Table=ComputerAdministrators
    Parameters=UUID, AssetTag, SerialNumber, MacAddress
    ParameterCondition=OR

    [CRoles]
    SQLServer=
    Instance=SQLEXPRESS
    Port=1433
    DBID=%UserID%
    DBPwd=%UserPassword%
    Database=
    Netlib=DBMSSOCN
    SQLShare=
    Table=ComputerRoles
    Parameters=UUID, AssetTag, SerialNumber, MacAddress
    ParameterCondition=OR

    [Locations]
    SQLServer=
    Instance=SQLEXPRESS
    Port=1433
    DBID=%UserID%
    DBPwd=%UserPassword%
    Database=
    Netlib=DBMSSOCN
    SQLShare=
    Table=Locations
    Parameters=DefaultGateway

    [LSettings]
    SQLServer=
    Instance=SQLEXPRESS
    Port=1433
    DBID=%UserID%
    DBPwd=%UserPassword%
    Database=
    Netlib=DBMSSOCN
    SQLShare=
    Table=LocationSettings
    Parameters=DefaultGateway

    [LApps]
    SQLServer=
    Instance=SQLEXPRESS
    Port=1433
    DBID=%UserID%
    DBPwd=%UserPassword%
    Database=
    Netlib=DBMSSOCN
    SQLShare=
    Table=LocationApplications
    Parameters=DefaultGateway
    Order=Sequence

    [MMSettings]
    SQLServer=
    Instance=SQLEXPRESS
    Port=1433
    DBID=%UserID%
    DBPwd=%UserPassword%
    Database=
    Netlib=DBMSSOCN
    SQLShare=
    Table=MakeModelSettings
    Parameters=Make, Model

    [MMApps]
    SQLServer=
    Instance=SQLEXPRESS
    Port=1433
    DBID=%UserID%
    DBPwd=%UserPassword%
    Database=
    Netlib=DBMSSOCN
    SQLShare=
    Table=MakeModelApplications
    Parameters=Make, Model
    Order=Sequence

    [RSettings]
    SQLServer=
    Instance=SQLEXPRESS
    Port=1433
    DBID=%UserID%
    DBPwd=%UserPassword%
    Database=
    Netlib=DBMSSOCN
    SQLShare=
    Table=RoleSettings
    Parameters=Role

    [RApps]
    SQLServer=
    Instance=SQLEXPRESS
    Port=1433
    DBID=%UserID%
    DBPwd=%UserPassword%
    Database=
    Netlib=DBMSSOCN
    SQLShare=
    Table=RoleApplications
    Parameters=Role
    Order=Sequence

    i have also ensure SQL Browser is configured on the site server firewall.

    your Deployment Logs are your best friend

    Thursday, April 18, 2019 1:26 PM