Error occurred in deployment step 'Retract Solution': The language-neutral solution package was not found


  • I've got the same error as those who opened this thread, but I'm looking for the cause of this error rather than deleting the solution file from SP2010 Server over and over again. 

    I was developing and deploying with VS2010 and SP2010 Enterprise Edition just fine for over three month now and out of nothing this error pops up again and again for the same solution. I can't tell what I've changed or which software I might have installed in the meantime, so I can't give any hints what causes the errormessage. Which might be interesting: I installed my SP2010 Enterprise Edition in english and installed the german language pack afterwards. Kind regards, Andreas

    Monday, August 23, 2010 2:01 PM

All replies


    I got the same error sometimes. The only solution which helps best is to add the last built the solution store again (Without deploying it or other commands as proposed in the other thread). Then i'm able to redeploy the solution without any error. When you deploy a solution it doesn't a full iisreset it only recycles the application pool which helps you to deploy, debug and test faster. The only reason for this is that i found out that the IIS is sometimes in an undefined state and then the deployment fails and the package already gone from solution store without retraction.

    I have the same setup as you have but the same error occured to me even if i had only the english server installed.

    Hope this will help you.

    Regards Stefan.



    Monday, August 23, 2010 9:00 PM
  • Hey Stefan,

    thanks for making it a little bit more clear for me. Although this is no solution I can now stop looking for one, but maybe somebody will come up with something after reading this. As for now I got a SharePoint Console open all the time and with (Get-SPSolution solutionname.wsp).Delete() I can remove the solution and deploy it again. That's working best for me.

    Regards, Andreas

    Tuesday, August 24, 2010 7:36 AM
  • Hi Andreas,

    i might find the solution for the development problems. Today i developed a Console Application for batch update things in SharePoint via Objekt Model. The console Application wasn't able to work correct because the target was set to x86 which causes some random error. After i have set the Platform Target to x64 the Console Application worked perfect and as expected.

    This make me think a little about the error developers have when they develop and deploy solutions and got a file not found exception. I though i might could help if i set the target of my SharePoint Solutions to x64. With a litte research i found the following article in the msdn.

    If you read the caution to any cpu it falls exactly into our development problems. Default setting in Visual Studio is always "Any CPU". Today i have to develop some things give you a deeper insight if it works for me.

    Regards Stefan

    ----------------------------------------------------------- MCTS - SharePoint / WSS Configuration and Development
    Tuesday, August 24, 2010 6:24 PM
  • Hey Stefan,

    for 2 of my 3 projects I already used x64 as target platform. I now changed it for all 3 projects and will keep an eye on it if the error occurse again or if that could have been the cause.

    Update: I just ran into the same error message so it's not related to the target platform.

    Wednesday, August 25, 2010 9:45 AM
  • I've created a support ticket with the Microsoft SharePoint Support in Germany and hopefully they'll be able to figure it out, since it's a annoying errormessage.
    Monday, October 11, 2010 7:09 AM
  • Tell me if you have any new information
    MCTS - SharePoint / WSS Configuration and Development
    Monday, October 11, 2010 10:18 AM