none
Error to load every Grid - Project Server 2010 RRS feed

  • Question

  • Hi, I have some problems with some users to load Project Center page, Project Detail page, etc, every page that contains a grid view, i get this error 'PWAFeatures' is undefined. I found some information that this erros disapear with SP2 intallation, but after installation the error persist.

    Help us.....pls

    SCRIPT5009: 'PWAFeatures' is undefined

    SCRIPT5007: Unable to get property 'getFullKey' of undefined or null reference


    Raymundo Chapa, MCTS http://www.inavant.mx/blog http://projectaserverzone.blogspot.com/



    • Edited by Ray Chapa Tuesday, January 21, 2014 8:55 PM
    Tuesday, January 21, 2014 8:53 PM

All replies

  • Add your PWA site as Trusted site for Intranet zone and internet zone.

    then run IE as administrator then click on F12 then run it in compatible mode. try to load PWa site on either IE8 or IE 9.

    try disabling all the Add-ons in IE and try it.  If that does not work uninstall and reinstall IE


    kirtesh



    • Edited by Kirteshtiw Tuesday, January 21, 2014 9:02 PM
    Tuesday, January 21, 2014 8:59 PM
  • Hi Raymundo,

    • Thus you confirm that you installed the lastest SP? Since it is hapening for just some users, check theirs IE configuration.
    • Ensure that the Project Server URL is in the trusted sites (intranet and internet).
    • Have you any jscript code in your PDP?
    • If is it happening just for some users, which version of IE do they do on their computers? If you are not respecting Microsoft requisites (IE7, 8, or 9), this can cause such issues. 
    • Have you also tried to press CTRL F5 for those users?

    Hope this helps.


    Guillaume Rouyre - MBA, MCP, MCTS


    Tuesday, January 21, 2014 9:01 PM
    Moderator
  • Thank you for you reply, and yes, I did every thing that you mentioned, and the error continuos :S

    Raymundo Chapa, MCTS http://www.inavant.mx/blog http://projectaserverzone.blogspot.com/

    Tuesday, January 21, 2014 9:17 PM
  • Hi Guillaume,

    Yer I installed the lastest SP, I check for every user the IE and everything appers normally, some users have IE8, IE9 and few of them have 10(In this case run with compatibility mode) and 11, and the PWA URL is already in trusted zone.

    I have a custom code for disable some button of my ribbon only for one PDP, but is for everyone, and in this case this issue affect only some users, I tried to retract the solution, restart the server and the problem persist, so I guess is not my coustom code.

    And yes I cleaned all my cache and cookies users and the problem persist.

    :S


    Raymundo Chapa, MCTS http://www.inavant.mx/blog http://projectaserverzone.blogspot.com/

    Tuesday, January 21, 2014 9:26 PM
  • Hello,

    It might be worth resetting IE on one of the machines to see if it resolves it. Bear in mind saved passwords, settings and history etc are lost:

    https://support.microsoft.com/kb/923737

    Paul


    Paul Mather | Twitter | http://pwmather.wordpress.com | CPS

    Tuesday, January 21, 2014 9:27 PM
    Moderator
  • This is issue is Computer specific as other users are not facing same issue for PWA 

    Try disabling all the Add-on in IE and try it.  If that does not work uninstall and re install IE on system.


    kirtesh

    Tuesday, January 21, 2014 9:27 PM
  • Hi Kirtesh,

    I thought that in the morning, but in the same browser I tested other PWA from another server and works fine, so, I don't think this issue is an specific computer, I' lost :S

    Thanks for you reply.


    Raymundo Chapa, MCTS http://www.inavant.mx/blog http://projectaserverzone.blogspot.com/

    Wednesday, January 22, 2014 2:40 AM
  • Raymundo,Have use log on to another system and try to repro the issue. similarly have working resource log on to affected system. If issue follows the user then issue is not realted to IE or system. Issue could be related to data

     


    Hrishi Deshpande Senior Consultant

    Friday, January 24, 2014 5:43 AM
    Moderator
  • Hi Hrishi, Yes I tried to log on another system and runs well, no issues, so I think the issue is on the IE, but rarely, cause I have five users wth the same issue, and last week for this users worked well :S

    Thanks!


    Raymundo Chapa, MCTS http://www.inavant.mx/blog http://projectaserverzone.blogspot.com/

    Friday, January 24, 2014 5:50 AM
  • You can check with one user uninstall and re install IE on system. 

    kirtesh

    Friday, January 24, 2014 7:45 AM
  • No need to uninstall then install, try the reset option detailed above. Paul

    Paul Mather | Twitter | http://pwmather.wordpress.com | CPS

    Friday, January 24, 2014 8:12 AM
    Moderator
  • This isn't solve my issue, PWMAther, and this is only a comment.....not a solution....

    Ray



    Raymundo Chapa, MCTS http://www.inavant.mx/blog http://projectaserverzone.blogspot.com/

    Monday, February 3, 2014 6:28 PM
  • Hello,

    Please explain what you have tried? Have you tried resetting IE following the steps in the KB article? Have you match the IE settings (zones / security) etc.

    Thanks

    Paul


    Paul Mather | Twitter | http://pwmather.wordpress.com | CPS

    Monday, February 3, 2014 8:43 PM
    Moderator