none
Can't create New Mailbox in Exchange Management Console RRS feed

Answers

  • Hi derek,

     

    From your description, I suspect that you run the command in the different Exchange server. If you want to new mailbox, you need to make sure that you run New-Mailbox command in the Mailbox server.

     

    Hope it helps.

     

    Thanks


    Sophia Xu

    TechNet Community Support

    • Proposed as answer by Sophia Xu Friday, January 13, 2012 1:51 AM
    • Marked as answer by Sophia Xu Friday, January 27, 2012 1:43 AM
    Tuesday, January 10, 2012 2:07 AM

All replies

  • Hi Derek,
    Is it also true that you can't use the commands New-Mailbox,New-MailUser and New-MailContact in Exchange Management Shell (EMS)?

    If so then I think you choosed to use "Active Directory split permission" when you installed Exchange 2010.

    Ref: Configure Exchange 2010 for Split Permissions
    http://technet.microsoft.com/en-us/library/dd638155.aspx


    If that wasn't desired, then you can change the permission model to "Shared" by following the instructions in the below Technet Article.

    Configure Exchange 2010 for Shared Permissions
    http://technet.microsoft.com/en-us/library/dd638146.aspx


    Martina Miskovic - http://www.nic2012.com/
    Friday, January 6, 2012 6:39 PM
  • Hi Martina,

    I am pretty new to Exchange, so please bear with me. When i open up EMS, it shows [PS] C:\Windows\system32>. So I'll type in something like 

    [PS] C:\Windows\system32>New-MailUser -Name Marc -FirstName Marc -LastName Boyer -ExternalEmailAddress
    marc.boyer@adventureworks.com -UserPrincipalName marc@contoso.com
    -OrganizationalUnit contoso.com

    But I get the error "The term New-MailUser is not recognized as the name of a cmdlet, function, etc."

    • Edited by derek4545 Friday, January 6, 2012 7:59 PM
    Friday, January 6, 2012 7:53 PM
  • Hi,
    That was pretty much expected and I do think you choosed to use the split model permission when you installed Exchange 2010 (it was a check box during installation).

    You need to follow the instructions for "Switch from RBAC split permissions to shared permissions " in the second link I posted if you want to be able to create recipients in EMC/EMS.

    If you don't, then you would need to create accounts in ADUC first and then use the command enable-mailbox to give an account a mailbox.


    Martina Miskovic - http://www.nic2012.com/
    Friday, January 6, 2012 8:04 PM
  • Martina, 

    I did what you said. I've been following the instructions in "Switch from RBAC split permissions to shared permissions" from your second link.

    I entered the code under "Configure Shared Permissions":

    New-ManagementRoleAssignment -Role "Mail Recipient Creation" -SecurityGroup "Organization Management" -Delegating

    Got an error again. "The term 'New-ManagementRoleAssignment' is not recognized as the name of a cmdlet, function, etc."

    • Edited by derek4545 Friday, January 6, 2012 8:56 PM
    Friday, January 6, 2012 8:54 PM
  • Hi,
    Can you post a picture of that?

    Also, make sure that the account you are using is a member of the security group "Organization Management".
    Martina Miskovic - http://www.nic2012.com/
    Friday, January 6, 2012 8:58 PM
  • Sorry, I was posting the wrong information to you.

    You need to follow the instructions for "Switch from Active Directory split permissions to shared permissions ".

    Same link: http://technet.microsoft.com/en-us/library/dd638146.aspx

     


    Martina Miskovic - http://www.nic2012.com/

    Friday, January 6, 2012 9:01 PM
  • Double-checked, I am in the Security Group "Organization Management."

    1. Ran just fine from Windows command shell.

    2. Here's what I see after entering the first command from Exchange Management Shell:


    • Edited by derek4545 Friday, January 6, 2012 9:21 PM
    Friday, January 6, 2012 9:15 PM
  • Hi derek,

     

    From your description, I suspect that you run the command in the different Exchange server. If you want to new mailbox, you need to make sure that you run New-Mailbox command in the Mailbox server.

     

    Hope it helps.

     

    Thanks


    Sophia Xu

    TechNet Community Support

    • Proposed as answer by Sophia Xu Friday, January 13, 2012 1:51 AM
    • Marked as answer by Sophia Xu Friday, January 27, 2012 1:43 AM
    Tuesday, January 10, 2012 2:07 AM