locked
Internet Explorer 9 Silent Uninstall RRS feed

  • Question

  • Hello,

    I created a custom IE9 install by using the Microsoft IEAK9. The source used for the custom install and destination OS is the same, Windows 7 Pro x86. My install works perfectly with the correct customizations. However, when I run the msiexec /x {GUID} uninstall key from the command line, I am prompted to locate the IE9 Msi installer. When I point it to the IEAK Output MSI file (which it already had found) it complains about not being a valid IE installer package. When I look at the details of the IE9-Setup-Full.msi I see a different product GUID than listed in the registry uninstall key, however if I attempt to use that key I get the "product is not installed" error. This is the command line used to install the package: MSIEXEC /I "\\serverpath\9.0\IEAK9OUTPUT\FLAT\Win32_WIN7\ENU\IE9-Setup-Full.msi" /qn /norestart

    I can run the uninstall from the control panel without any problems, but I like to have a silent uninstall script in case I need to perform a reinstall if I run into any issues during general deployment. Has anyone else run into this problem and know a way to fix it? 

    Thank you

     

    • Moved by Leo Huang Wednesday, July 20, 2011 2:16 AM IE related problem (From:Windows 7 Installation, Setup, and Deployment)
    Tuesday, July 19, 2011 8:01 PM

All replies

  • Hi,

     

    You can try to use this methods to silent uninstall IE9:

    ·         (1) Log in as Administrator

    ·         (2) Close all IE browser windows

    ·         (3) Open a "Command" windows by Clickin Start > Run > Cmd

    ·         (4) Open "Notepad"

    ·              Copy and paste the text below into Notepad. This will convert the html below into plain text:

     

        FORFILES /P %WINDIR%\servicing\Packages /M Microsoft-Windows-InternetExplorer-*9.*.mum /c "cmd /c echo Uninstalling package @fname && start /w pkgmgr /up:@fname /norestart"

     

    ·         (5) Next copy the text from Notepad and paste into the Command window at the disk prompt and then press the enter key.

    ·         (6) After the commands run and the disk prompt returns, paste the text again and rerun the commands.

    ·         (7) Next reboot to finalize / update the configuration with IE8.

     

    Furthermore, I suggest to contact IE Forum for further help:

     

    http://social.technet.microsoft.com/Forums/en-US/ieitprocurrentver/threads

    The reason why we recommend posting appropriately is you will get the most qualified pool of respondents, and other partners who read the forums regularly can either share their knowledge or learn from your interaction with us.  Thank you for your understanding.

     

     

    Regards,

    Leo   Huang

    TechNet Subscriber Support in forum. If you have any feedback on our support, please contact tngfb@microsoft.com

     


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Wednesday, July 20, 2011 2:44 AM
  • I use an automated solution do deliver our installations. I have worked with the script above without success. An error is displayed. I will get that posted up once I have it available.
    Friday, July 22, 2011 7:39 PM
  • Hello,

     

    I have attempted the above without success. I receive the following error message when running the above via a batch file:

     

    "Operation Failed with 0x80070005 Access is denied"

     

    The script is run in the system user context. I have attempted to run this with IE open/closed and the same error appears.

     

    Thank you

    Thursday, July 28, 2011 5:20 PM
  • Hi

     

    I also got the Access Denied but it seems to be related to some optional installed components that are installed for IE 9.

    If you ok this and continue (Which makes it not silent anymore) then IE9 is actually removed (after reboot).

     

    Ali


    Alistair Dandy - Atlas Copco
    Tuesday, November 29, 2011 11:00 AM
  • Putting in a /quiet on the script removed the access denied for me, and removed internet explorer 9 

    FORFILES /P %WINDIR%\servicing\Packages /M Microsoft-Windows-InternetExplorer-*9.*.mum /c "cmd /c echo Uninstalling package @fname && start /w pkgmgr /up:@fname /quiet/norestart"

    Monday, February 13, 2012 9:38 AM
  • Thanks, with /quiet works like a charm, even if the user has an IE session in used at the moment.
    Friday, February 24, 2012 11:23 AM
  • I realise this thread is old but really could use some help. I have created a batch file using the command string in this article in which I need to push and run before I can install IE9. We currently use LanDesk to push out packages and when the package runs it uses the system account. The problem I have having is that in order for that command to run successfully, it needs to be run in a command prompt with elevated permissions. Otherwise, I get the error, "Operation failed with 0x80070057 The parameter is incorrect." Even if I run it with the /quiet switch.

    The reason for having to run this is I have found that even though IE8 is installed on my computer, it appears that IE9 seems partially installed somehow. If you open IE it runs as v8. But, if you go to, "Turn Windows features on or off", it shows Internet Explorer 9. Looking up IE in the registry, it also says v8. I have found running the script fixes the issue and allows for IE9 to install. If there is another way around this that could be remotely pushed, I would appretiate some direction. Thanks.

    • Edited by Jayden T Monday, November 12, 2012 8:56 PM more info added
    Monday, November 12, 2012 8:35 PM
  • Provide above method now my system working fine

    Thanks & Regard

    Mahaveer Singh

      
    Wednesday, May 15, 2013 10:52 AM
  • Hi,

    after uninstall IE10 with the command but after reboot the screen shows "failure install windows update reverting changes..." and after windows resumed it still IE10.

    any other way to forece IE 10 unistallation from Windows 7?

    thanks & regards.

    S.

    Friday, November 22, 2013 2:43 AM
  • after reboot the screen shows "failure install windows update reverting changes..."

    Interference from security product or permissions problem?  Use ProcMon to elaborate on your symptom description.  E.g. find out what diagnostics are being created and how they relate to each other.  Or it might be sufficient just to do a File Explorer Search for DateModified:Today and sort by that field to see how they all relate.  If necessary you could also run ProcMon for its Boot Logging option in case the problem is only occurring during the boot.

    One simple test to try eliminating interference from other products starting during the boot would be to boot in safe mode.  However, I am not sure that that would help complete the install.  E.g. you would have to find out if the  PendingFileRenameOperations  value gets propagated to the hive used by the safe mode boot.

     
    Good luck



    Robert Aldwinckle
    ---

    Sunday, November 24, 2013 2:18 AM
    Answerer
  • Hi,

    Please try that:

      set kbl=%~dpn0&       :: Set the Log file name and location

    :: Remove IE10

       set Uninstall_KB2862772=wusa.exe /uninstall /kb:2862772 /quiet /norestart /log:"%kbl%"
       set Uninstall_KB2718695=wusa.exe /uninstall /kb:2718695 /quiet /norestart /log:"%kbl%"

       %Uninstall_KB2862772%
       %Uninstall_KB2718695%

    exit

    Best Regards,

    M3700


    • Edited by M3700 Thursday, November 28, 2013 10:35 AM
    Wednesday, November 27, 2013 5:37 PM
  • I have exact problem as you had.  IE version shows 8 but installed updates shows IE 9 and I can't uninstall IE9. I can't install IE 9/10 or 11.  I tried to run the script suggested in this thread, but no luck. 

    How did you resolve it finally? 


    Friday, March 21, 2014 4:47 AM
  • I have exact problem as you had.

    How did you resolve it finally? 

    The symptom could also be caused by not running in an elevated cmd window.  So, are you using an Administrator Command Prompt?  <eg>



    Robert Aldwinckle
    ---

    Friday, March 21, 2014 5:15 AM
    Answerer