none
ggplot2 issues RRS feed

  • Question

  • library(ggplot2)
    Error in loadNamespace(j <- i[[1L]], c(lib.loc, .libPaths()), versionCheck = vI[[j]]) : 
      there is no package called ‘munsell’
    Error: package or namespace load failed for ‘ggplot2’ 

    Above message I am getting when I try to load ggplot2 ; 

    The version I am using :

    Version : 

                   _                           
    platform       x86_64-w64-mingw32          
    arch           x86_64                      
    os             mingw32                     
    system         x86_64, mingw32             
    status                                     
    major          3                           
    minor          3.2                         
    year           2016                        
    month          10                          
    day            31                          
    svn rev        71607                       
    language       R                           
    version.string R version 3.3.2 (2016-10-31)
    nickname       Sincere Pumpkin Patch 

    Due to above issue, I am not able to use all dependent packages (e.g. 'Hmisc', 'caret')

    Any specific reason  & solution ?

    Tuesday, December 13, 2016 1:30 PM

Answers

  • This doesn't happen for me with MRO 3.3.2. It's possible you have some conflicting or incompatible R packages in your path. An easy way to check is to use checkpoint() which will use a distinct package path (and get you a newer version of ggplot2, too).

    Try putting this in a myscript.R file (ideally, in a separate project folder)

    checkpoint("2016-12-12")
    library(ggplot2)

    Save the file and then source it. Does that fix the problem?

    Tuesday, December 13, 2016 5:20 PM