locked
External DVD not seen by Vista RRS feed

  • Question

  •  

    I just bought a Sony external USB DVD manufactured in April 2008 and plugged it in. Vista SP1 assigned it Drive G and it worked fine. I then unplugged it for a couple of days and since I plugged it back in, Vista does not acknowlege its presence in any way. I've tried unplugging and plugging it back in, I've deleted the upper and lower filter entries in the registry as per Microsoft's web site and I've uninstalled the Nero software that I installed when I first plugged in the drive [installing Nero was the only use I've gotten from the drive]. There was a second entry in addition to the one for the internal drive in Device Manager for a while but it has since disapeared [on its own I think - I'm not aware of anything I might have done to get rid of it]. What else can I do to get Vista to see the drive? BTW, when I try to open the key

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\{4D36E965-E325-11CE-BFC1-08002BE10318} / Properties,

    [the key with the reference to upper and lower filters in its top level] I get a message saying that an error is preventing this key from being opened, with no error being specified. At one point the entire 4D36E965-E325-11CE-BFC1-08002BE10318 key was gone but I see now it's back, with the error when trying to open Properties.

     Thanks for any help

    Saturday, August 23, 2008 2:15 AM

Answers

  • Hi,

     

    Regarding the USB DVD issue, could you see it in Disk Management? If you can, please try to assign a letter to it to troubleshoot this issue.

     

    1.Right click Computer and select Manage.

    2.Click on Disk Management.

    3.If problem drive do not have a letter, right click the drive and select Change Drive Letter and Path, give the drive a letter and you are all set.

    4.Restart the computer to test this issue again.

     

    Regarding the registry issue, could you please let me know the detail error message? We need it to narrow down the problem.

     

    By the way, please ensure you are administrator on this computer.

     

    Thanks.

     

    Tuesday, August 26, 2008 6:55 AM
    Moderator